Well I have a .reviewboardrc with valid stuff in it.  I modified (just
now) the script too with the same data but it didn't work.

I really suspect that that the 'execute' command isn't working right.

Note that it gets past that if I change those Popen calls from 'True'
back to 'False'.

If they are 'False' it can't find the repository, and if it is 'True'
it can't execute the diff (per the original posts in this thread).


On Oct 15, 2:01 pm, "Joshua Slominski" <[EMAIL PROTECTED]> wrote:
> I seen that error when i forgot to put in my review board URL in
> post-review.  Also be sure that post-review is using the correct SCM tool.
> It defaults to SVN if it can't find anything else.
> On Wed, Oct 15, 2008 at 4:48 PM, AndyP <[EMAIL PROTECTED]> wrote:
> > That didn't work for me out of the box.  The two Popen() statements
> > are different than the version that I had (v0.7 that worked), but when
> > I changed it to True I got a different error:
> > "The current directory does not contain a checkout from a supported
> > source code repository."
> > Looking at this further, it appears that the only real difference is
> > the way the execute command is created:
> > v0.7
> >  data = execute('p4 info', ignore_errors=True)
> > v0.8
> >  data = execute(["p4", "info"], ignore_errors=True)
> > On Oct 15, 12:45 pm, "Joshua Slominski" <[EMAIL PROTECTED]> wrote:- Hide 
> > quoted text -
> - Show quoted text -
You received this message because you are subscribed to the Google Groups 
"reviewboard" group.
To post to this group, send email to reviewboard@googlegroups.com
To unsubscribe from this group, send email to [EMAIL PROTECTED]
For more options, visit this group at 

Reply via email to