Some people have been recently hitting this. Why it's happening, I don't
know, but I have a workaround I'll commit within the hour.

Christian

-- 
Christian Hammond - [EMAIL PROTECTED]
VMware, Inc.


On Tue, Oct 28, 2008 at 8:19 AM, 13Strider <[EMAIL PROTECTED]> wrote:

>
> I changed my site configuration to my server name and removed
> example.com and now reviewboard wont run
> i keep getting this error. and yes my SIte_id is set to 1
>
> Environment:
>
> Request Method: GET
> Request URL: http://MyIP/
> Django Version: 1.0-final-SVN-unknown
> Python Version: 2.5.1
> Installed Applications:
> ['django.contrib.admin',
>  'django.contrib.auth',
>  'django.contrib.contenttypes',
>  'django.contrib.markup',
>  'django.contrib.sites',
>  'django.contrib.sessions',
>  'djblets.datagrid',
>  'djblets.feedview',
>  'djblets.siteconfig',
>  'djblets.util',
>  'djblets.webapi',
>  'reviewboard.accounts',
>  'reviewboard.admin',
>  'reviewboard.changedescs',
>  'reviewboard.diffviewer',
>  'reviewboard.iphone',
>  'reviewboard.reports',
>  'reviewboard.reviews',
>  'reviewboard.scmtools',
>  'reviewboard.webapi',
>  'django_evolution']
> Installed Middleware:
> ('django.middleware.common.CommonMiddleware',
>  'django.middleware.doc.XViewMiddleware',
>  'django.middleware.locale.LocaleMiddleware',
>  'django.contrib.sessions.middleware.SessionMiddleware',
>  'django.contrib.auth.middleware.AuthenticationMiddleware',
>  'djblets.log.middleware.LoggingMiddleware',
>  'reviewboard.admin.middleware.CheckUpdatesRequiredMiddleware')
>
>
> Traceback:
> File "/usr/lib/python2.5/site-packages/django/core/handlers/base.py"
> in get_response
>  77.                     request.path_info)
> File "/usr/lib/python2.5/site-packages/django/core/urlresolvers.py" in
> resolve
>  180.                     sub_match = pattern.resolve(new_path)
> File "/usr/lib/python2.5/site-packages/django/core/urlresolvers.py" in
> resolve
>  178.             for pattern in self.urlconf_module.urlpatterns:
> File "/usr/lib/python2.5/site-packages/django/core/urlresolvers.py" in
> _get_urlconf_module
>  197.             self._urlconf_module =
> __import__(self.urlconf_name, {}, {}, [''])
> File "/var/www/reviewboard/urls.py" in <module>
>  24. load_site_config()
> File "/var/www/reviewboard/admin/siteconfig.py" in load_site_config
>  105.     apply_django_settings(siteconfig, settings_map)
> File "/var/www/reviewboard/djblets/siteconfig/django_settings.py" in
> apply_django_settings
>  153.             value = siteconfig.get(key)
> File "/var/www/reviewboard/djblets/siteconfig/models.py" in get
>  59.         return self.settings.get(key, default)
>
> Exception Type: AttributeError at /
> Exception Value: 'unicode' object has no attribute 'get'
>
> >
>

--~--~---------~--~----~------------~-------~--~----~
You received this message because you are subscribed to the Google Groups 
"reviewboard" group.
To post to this group, send email to reviewboard@googlegroups.com
To unsubscribe from this group, send email to [EMAIL PROTECTED]
For more options, visit this group at 
http://groups.google.com/group/reviewboard?hl=en
-~----------~----~----~----~------~----~------~--~---

Reply via email to