Have you fixed this?

On Oct 28, 9:00 am, tom <[EMAIL PROTECTED]> wrote:
> Hi,
>
> Has this been resolved?
>
> If not, this is to do with the fact that the newline character(s) are
> in the name of the local file extracted:
>
> here's adiffof what I did to fix the issue as a quick solution:
>
>  #
>  # Repository URL.
> @@ -963,6 +963,7 @@
>              else:
>                  die("Unknown change type '%s' for %s" % (changetype,
> depot_path))
>
> +            new_file = new_file.rstrip('\r\n');
>              diff_cmd = ["diff", "-urNp", old_file, new_file]
>              #Diffreturns "1" if differences were found.
>
> However, I got an internal server error when I tried a test post:
>
> Unableto accesshttp://localhost:8000/api/json/reviewrequests/new/.
> The host path may be invalid
> HTTP Error 500: INTERNAL SERVER ERROR
>
> logs:
>
> [28/Oct/2008 05:59:48] "POST /api/json/reviewrequests/new/ HTTP/1.1"
> 500 96260
>
> On Oct 16, 8:54 am, "Florian Föbel" <[EMAIL PROTECTED]>
> wrote:
>
> > Hi,
>
> > I just got the same error after upgrading post-review. What I found out is
> > that the subprocess.stdout that is read for thediffcommand contains a
> > newline (\n) right after the second filename in thediffheader. Kind of
> > weird...
>
> > No fix or explanation found yet.
>
> > Regards,
> > Florian
>
> > 2008/10/16 Joshua Slominski <[EMAIL PROTECTED]>
>
> > > Can you post the debug output?
>
> > > Sent from my iPhone
>
> > > On Oct 15, 2008, at 6:00 PM, AndyP <[EMAIL PROTECTED]> wrote:
>
> > > > Well I have a .reviewboardrc with valid stuff in it.  I modified (just
> > > > now) the script too with the same data but it didn't work.
>
> > > > I really suspect that that the 'execute' command isn't working right.
>
> > > > Note that it gets past that if I change those Popen calls from 'True'
> > > > back to 'False'.
>
> > > > If they are 'False' it can't find the repository, and if it is 'True'
> > > > it can't execute thediff(per the original posts in this thread).
>
> > > > Thanks,
>
> > > > On Oct 15, 2:01 pm, "Joshua Slominski" <[EMAIL PROTECTED]> wrote:
> > > >> I seen that error when i forgot to put in my review board URL in
> > > >> post-review.  Also be sure that post-review is using the correct
> > > >> SCM tool.
> > > >> It defaults to SVN if it can't find anything else.
>
> > > >> On Wed, Oct 15, 2008 at 4:48 PM, AndyP <[EMAIL PROTECTED]> wrote:
>
> > > >>> That didn't work for me out of the box.  The two Popen() statements
> > > >>> are different than the version that I had (v0.7 that worked), but
> > > >>> when
> > > >>> I changed it to True I got a different error:
>
> > > >>> "The current directory does not contain a checkout from a supported
> > > >>> source code repository."
>
> > > >>> Looking at this further, it appears that the only real difference is
> > > >>> the way the execute command is created:
>
> > > >>> v0.7
> > > >>>  data = execute('p4 info', ignore_errors=True)
>
> > > >>> v0.8
> > > >>>  data = execute(["p4", "info"], ignore_errors=True)
>
> > > >>> On Oct 15, 12:45 pm, "Joshua Slominski" <[EMAIL PROTECTED]>
> > > >>> wrote:- Hide quoted text -
>
> > > >> - Show quoted text -
--~--~---------~--~----~------------~-------~--~----~
You received this message because you are subscribed to the Google Groups 
"reviewboard" group.
To post to this group, send email to reviewboard@googlegroups.com
To unsubscribe from this group, send email to [EMAIL PROTECTED]
For more options, visit this group at 
http://groups.google.com/group/reviewboard?hl=en
-~----------~----~----~----~------~----~------~--~---

Reply via email to