Hi David,

I'm trying to get reviewboard working with our OpenLDAP server but
without much success so far. I've tried to use this patch before it
was committed and also updated to revision 1573 today. Result is still
the same - according to logs I'm getting LDAP error:  {'info':
'invalid DN', 'desc': 'Invalid DN syntax'}. I've tried to connect
running the code from backends.py manually and it worked (btw. I'm
completely new to python). Also using some more debug messages I found
out that the authenticate method works normally, it's just the
get_or_create_user (which is called from authenticate) which obviously
doesn't work even if the code is the same. Also I'm quite sure that
the DN base is correct. So I'm quite confused :).

Any help appreciated.

Cheers,
Tom

On 14 Lis, 20:25, "David Trowbridge" <[EMAIL PROTECTED]> wrote:
> FYI, in SVN revision r1573, I've committed the patch 
> fromhttp://reviews.review-board.org/r/634/
>
> This generalizes the LDAP authentication scheme to work better with
> OpenLDAP. If you're using LDAP authentication, you'll have to update
> your settings:
>
> Your "User Mask" currently looks something like
> "uid=%s,ou=users,dc=example,dc=com"
> You'll now set "User Mask" to "uid=%s" and "LDAP Base DN" to
> "ou=users,dc=example,dc=com"
>
> -David
--~--~---------~--~----~------------~-------~--~----~
You received this message because you are subscribed to the Google Groups 
"reviewboard" group.
To post to this group, send email to reviewboard@googlegroups.com
To unsubscribe from this group, send email to [EMAIL PROTECTED]
For more options, visit this group at 
http://groups.google.com/group/reviewboard?hl=en
-~----------~----~----~----~------~----~------~--~---

Reply via email to