Strange.. I'll look into this and should have a fix by tonight, hopefully.
I'm leaving town for the holidays tonight so I won't be as active on here
but will be checking on e-mail and fixing critical issues like this.

Christian

-- 
Christian Hammond - [EMAIL PROTECTED]
VMware, Inc.


On Tue, Nov 25, 2008 at 11:53 AM, Tomas Friml <[EMAIL PROTECTED]>wrote:

>
> Hi Chris,
>
> Today I updated again and guess what - the setting_local files are
> there again :)
>
> On 25 Lis, 12:57, Tomas Friml <[EMAIL PROTECTED]> wrote:
> > Ok, reinstalling still doesn't help (files are still created, but I
> > suppose that's because your nightly build hasn't been propagated yet
> > to easy_install or something like that), but if I remove the
> > settings_local files rb-site upgrade works :).
> >
> > Thanks a lot,
> > Tom
> >
> > On 25 Lis, 12:24, "Christian Hammond" <[EMAIL PROTECTED]> wrote:
> >
> > > The settings_local.py in the ReviewBoard egg directory was a packaging
> error
> > > that has been fixed in the latest nightly. Go ahead and delete
> > > settings_local.py and .pyc from that directory and try the install
> again.
> >
> > > You shouldn't hit this with future packages. What should be happening
> is
> > > that rb-site will generate a new settings_local.py in your new site's
> conf/
> > > directory, and use that for everything.
> >
> > > Christian
> >
> > > --
> > > Christian Hammond - [EMAIL PROTECTED]
> > > VMware, Inc.
> >
> > > On Mon, Nov 24, 2008 at 3:18 PM, Tomas Friml <[EMAIL PROTECTED]
> >wrote:
> >
> > > > Hi Chris,
> >
> > > > I would think that it works like that. But it doesn't not in my
> > > > case :). The problem obviously is in settings_local.py in the
> > > > ReviewBoard directory. If I set the correct db settings there
> > > > everything works. But the default settings_local don't work for me.
> > > > Settings_local.py in site directory obviously is somehow ignored
> (I've
> > > > checked the rights and settings and everything is working). If I copy
> > > > my site settings_local.py into ReviewBoard directory then rb-site
> > > > upgrade works as well. Does the rb-site have its config somewhere? I
> > > > can imagine that when I was playing with the migration (install,
> > > > upgrade, reinstall, remove, ... in different directories) it could
> > > > somehow remember this wrong location for settings_local file?
> >
> > > > Cheers,
> > > > Tom
> >
> > > > On 25 Lis, 10:58, "Christian Hammond" <[EMAIL PROTECTED]> wrote:
> > > > > Hi Tomas.
> >
> > > > > Yeah, it looks like easy_install leaves the old directory behind. I
> don't
> > > > > know why. I think it's an issue on their end.
> >
> > > > > You shouldn't ever deal with the settings file in that directory,
> though.
> > > > > The settings.py in there is meant to be untouched. You should only
> ever
> > > > > modify conf/settings_local.py in your rb site.
> >
> > > > > Christian
> >
> > > > > --
> > > > > Christian Hammond - [EMAIL PROTECTED]
> > > > > VMware, Inc.
> >
> > > > > On Mon, Nov 24, 2008 at 12:08 PM, Tomas Friml <
> [EMAIL PROTECTED]
> > > > >wrote:
> >
> > > > > > Hi Christian,
> >
> > > > > > Yesterday I've migrated to "new way of..." ReviewBoard (after
> putting
> > > > > > some effort :)). Today I wanted to upgrade it and all went
> smoothly
> > > > > > till I wanted to upgrade site. I got same error as yesterday
> (missing
> > > > > > python sqlite module which was caused by default settings of
> > > > > > ReviewBoard). So I examined the site-packages directory and found
> out
> > > > > > that there were 2 ReviewBoard directories (yesterday and today
> > > > > > ReviewBoard-0.9.dev_200811(23|24)-py2.4.egg). So the easy_install
> > > > > > actually installed new one instead of upgrading the old one (even
> if I
> > > > > > used --upgrade). Now I would have to copy my old setting files to
> this
> > > > > > new instance to get it working. Is this intended behaviour? Do I
> have
> > > > > > to do it everytime I upgrade ReviewBoard?
> >
> > > > > > Cheers,
> > > > > > Tom
> >
> > > > > > On 24 Lis, 00:12, "Christian Hammond" <[EMAIL PROTECTED]>
> wrote:
> > > > > > > Hi everyone.
> >
> > > > > > > We've just finished moving over to a new way of installing and
> > > > upgrading
> > > > > > > Review Board.
> >
> > > > > > > Review Board, Djblets, Django-Evolution, PIL and Django are now
> > > > packaged
> > > > > > up
> > > > > > > in such a way where you can install or upgrade them all with
> one
> > > > command.
> >
> > > > > > > Site installation and upgrading is also handled through a new
> tool,
> > > > > > rb-site.
> >
> > > > > > > The new installation procedure is documented athttp://
> > > > > >www.review-board.org/wiki/GettingStarted. It includes information
> on
> > > > > > > migrating from existing installations.
> >
> > > > > > > To sum up the new changes, basic installation has mostly
> become:
> >
> > > > > > >    $ sudo easy_install ReviewBoard
> > > > > > >    $ sudo rb-site install /var/www/reviews.example.com
> >
> > > > > > > For the most part, nothing too fundamental has changed. It's
> just
> > > > easier
> > > > > > to
> > > > > > > get going now. We are, however, considering some large changes
> within
> > > > the
> > > > > > > SVN tree that would break sites running out of the tree. This
> will
> > > > > > probably
> > > > > > > happen after 1.0, but may happen sooner if we decide it must be
> done.
> > > > We
> > > > > > > recommend that everybody makes an effort to move to the new
> install
> > > > > > method.
> >
> > > > > > > I've done a number of test installs without any problems, but
> if you
> > > > hit
> > > > > > an
> > > > > > > issue, please let me know and I'll work to address it.
> >
> > > > > > > Christian
> >
> > > > > > > --
> > > > > > > Christian Hammond - [EMAIL PROTECTED]
> > > > > > > VMware, Inc.
> >
>

--~--~---------~--~----~------------~-------~--~----~
You received this message because you are subscribed to the Google Groups 
"reviewboard" group.
To post to this group, send email to reviewboard@googlegroups.com
To unsubscribe from this group, send email to [EMAIL PROTECTED]
For more options, visit this group at 
http://groups.google.com/group/reviewboard?hl=en
-~----------~----~----~----~------~----~------~--~---

Reply via email to