It is probably the p4 where command that is throwing it off:

$ p4 where //depot/dev/removed/gx/core/src/win32/desktop/myfile.cpp
//depot/dev/removed/gx/core/src/win32/desktop/DesktopDeviceLite.cpp //
apeterson-removed/removed/gx/core/src/win32/desktop/myfile.cpp c:
\removed\gx\core\src\win32\desktop\myfile.cpp


-- note that the 3rd output is in dos format.



On Dec 4, 5:53 pm, AndyP <[EMAIL PROTECTED]> wrote:
> cygwin bash shell.  That's the only access I have to python on the
> machine.
>
> we are using cygwin for the make system anyway - and reviewboard tools
> fall nicely in there - if I can get them to work!
>
> Thanks!
>
> On Dec 4, 5:41 pm, "Christian Hammond" <[EMAIL PROTECTED]> wrote:
>
>
>
> > It has to do with people not using the right version of GNU diff, or weird
> > stuff happening with file path delimiters with Cygwin.
>
> > There's a change pending that will hopefully fix a lot of this up. Instead
> > of calling out to diff, we'd be generating it inline.
>
> > Are you running from cmd.exe or from the cygwin bash shell?
>
> > Christian
>
> > --
> > Christian Hammond - [EMAIL PROTECTED]
> > VMware, Inc.
>
> > On Thu, Dec 4, 2008 at 5:36 PM, AndyP <[EMAIL PROTECTED]> wrote:
>
> > > I actually found it... in /usr/lib/python2.5/site-packages/
> > > ReviewBoard.....(egg stuff)....../reviewboard/contrib/tools
>
> > > Is this the latest and greatest?
>
> > > I guess I have to ask:  Does reviewboard support cygwin+perforce on a
> > > windows environment?  I have had nothing but trouble getting the post-
> > > review tool to work.  I took a break for a couple of months hoping
> > > that things would settle down...  our production environment is
> > > running something that is old - probably around March or April
> > > timeframe.  I had to hand-tweak the post-review tool back then to make
> > > it work (from suggestions on this forum)... but I was hoping that all
> > > that had gone away.  I really like the new installer - that makes the
> > > server side a snap.  The client side though...
>
> > > The latest trouble I am having is that for some reason the tool is
> > > "Unable to parse diff header".  It's pretty obvious why when I run the
> > > -d flag to debug - it is trying to use the diff tool against a windows-
> > > formatted-pathname.  i.e.
>
> > > diff -urNp /cygdrive/c/path_to_file/myfile.cpp c:\path_to_file
> > > \myfile.cpp
>
> > > and of course the diff will fail - it can't do that under cygwin.
>
> > > On Dec 4, 3:49 pm, Chris Clark <[EMAIL PROTECTED]> wrote:
> > > > AndyP wrote:
> > > > > I installed the latest stuff (blew everything away first) and can't
> > > > > find the latest version of the post-review tool.  Where do I go to get
> > > > > it?
>
> > > > You can pull it down from svn (and you can even use wget if you don't
> > > > have svn to hand):
>
> > > >http://code.google.com/p/reviewboard/source/browse/trunk/reviewboard/...
>
> > > > Chris- Hide quoted text -
>
> > - Show quoted text -- Hide quoted text -
>
> - Show quoted text -
--~--~---------~--~----~------------~-------~--~----~
You received this message because you are subscribed to the Google Groups 
"reviewboard" group.
To post to this group, send email to reviewboard@googlegroups.com
To unsubscribe from this group, send email to [EMAIL PROTECTED]
For more options, visit this group at 
http://groups.google.com/group/reviewboard?hl=en
-~----------~----~----~----~------~----~------~--~---

Reply via email to