With that error, I'd definitely try setting Application to be the Python
binary, and then use the script as the first parameter. P4V probably
requires that the application itself be an actual binary, rather than
assuming it will be opened with something else by file association.

Christian

-- 
Christian Hammond - [EMAIL PROTECTED]
VMware, Inc.


On Mon, Dec 8, 2008 at 9:55 PM, roshan pius <[EMAIL PROTECTED]>wrote:

> Hi Christian,
>
> It show the code being executed in their P4V command Window and then
> it pops up a message saying Unable to execute the command....
>
>
> Error: Unable to run C:\Python26\post-review.py
>
> But the same command works on the command line...
>
> There is some issue here.... I'm attaching a screenshot of the
> configuration...
>
> Maybe someone with a knowledge of how P4V works can help...
>
> Thanks,
> Roshan Pius
>
>
>
> On Tue, Dec 9, 2008 at 11:01 AM, Christian Hammond <[EMAIL PROTECTED]>
> wrote:
> > There's no error messages or any output? It's just doing nothing? I don't
> > know a thing about how P4V works. What happens if you specify the python
> > binary before the script name?
> >
> > Christian
> >
> > --
> > Christian Hammond - [EMAIL PROTECTED]
> > VMware, Inc.
> >
> >
> > On Mon, Dec 8, 2008 at 8:33 PM, roshanpius <[EMAIL PROTECTED]>
> > wrote:
> >>
> >> Sorry, Small typo..
> >>
> >> > C:\python2.6 %C  --p4-client $c --p4-port $p
> >> >
> >> > I can see in the P4V command window the arguments getting populated
> >> > properly :
> >> >
> >> > C:\python post-review.py 8624  --p4-client New_DepotView --p4-port
> >> > xxx.xxx.xxx.xxx:1999
> >>
> >> C:\python2.6\post-review.py  %C  --p4-client $c --p4-port $p
> >>
> >> I can see in the P4V command window the arguments getting populated
> >> properly :
> >>
> >> C:\python\post-review.py 8624  --p4-client New_DepotView --p4-port
> >> xxx.xxx.xxx.xxx:1999
> >>
> >> On Dec 9, 9:21 am, roshanpius <[EMAIL PROTECTED]> wrote:
> >> > Hi,
> >> >
> >> > I am having a small issue integrating post-review with P4V in the
> >> > Windows systems.
> >> >
> >> > I've installed python2.6, setuptools, simplejson and GNU diffutils.
> >> >
> >> > Here is the problem I've renamed post-review to post-review.py(so that
> >> > it gets associated automatically) and when i run it in command line
> >> > with the appropriate arguments, it works perfectly well.
> >> >
> >> > But when I import it into P4V and run the same command, it says not
> >> > able to execute the command:
> >> >
> >> > C:\python2.6 %C  --p4-client $c --p4-port $p
> >> >
> >> > I can see in the P4V command window the arguments getting populated
> >> > properly :
> >> >
> >> > C:\python post-review.py 8624  --p4-client New_DepotView --p4-port
> >> > xxx.xxx.xxx.xxx:1999
> >> >
> >> > What am I missing here.. ?
> >>
> >
> >
> > >
> >
>
> >
>

--~--~---------~--~----~------------~-------~--~----~
You received this message because you are subscribed to the Google Groups 
"reviewboard" group.
To post to this group, send email to reviewboard@googlegroups.com
To unsubscribe from this group, send email to [EMAIL PROTECTED]
For more options, visit this group at 
http://groups.google.com/group/reviewboard?hl=en
-~----------~----~----~----~------~----~------~--~---

Reply via email to