Ah, sorry again...

I must've changed it when I was trying to fix my installation.
Copying the current apache-modpython.conf from the conf folder (which
looks right, and doesn't have any @'s) in the site installation to
sites-available fixed it :)


On 30 Dec., 12:18, "Christian Hammond" <chip...@chipx86.com> wrote:
> Oops sorry, ignore that question. It's late here..
>
> The problem is definitely that you used the wrong template. Your existing
> Apache config is using things like @pythondir@, which is from the template
> file in the Review Board source code used to generate the sample Apache
> config in your conf/ directory.
>
> Does the one in conf/ include @pythondir@ and such, or is it using the real
> paths?
>
> Christian
>
> --
> Christian Hammond - chip...@chipx86.com
> VMware, Inc.
>
> On Tue, Dec 30, 2008 at 3:16 AM, Christian Hammond <chip...@chipx86.com>wrote:
>
>
>
> > You definitely don't want a settings_local.py in the installed directory.
> > This belongs only in the site directory.
>
> > Your Apache configuration should be taking care of this if you used the
> > template in conf/. What does your PythonPath line say?
>
> > Christian
>
> > --
> > Christian Hammond - chip...@chipx86.com
> > VMware, Inc.
>
> > On Tue, Dec 30, 2008 at 2:50 AM, Ibmurai <j...@dansupport.dk> wrote:
>
> >> I have a small problem with my ReviewBoard installation. I think it
> >> might be caused by a suboptimal apache2 configuration, but I'm not
> >> sure how to fix it.
>
> >> I have to put a symlink like so:
> >> #cd /usr/lib/python2.5/site-packages/ReviewBoard-0.9.dev_20081228-
> >> py2.5.egg/reviewboard/
> >> #ln -s /var/www/review-board/conf/settings_local.py settings_local.py
>
> >> If I don't I get the error message:
>
> >> Unable to read settings_local.py.
>
> >> Please seehttp://code.google.com/p/reviewboard/wiki/GettingStarted
> >> for help setting up Review Board.
>
> >> It's a minor nuisance, I know, but if someone knows how to fix it, I'd
> >> appreciate it :)
>
> >> My site config looks like this:
>
> >> <VirtualHost *:80>
> >>        ServerName review-board.dansupport.dk
> >>        DocumentRoot /var/www/review-board/htdocs
>
> >>        # Error handlers
> >>        ErrorDocument 500 /errordocs/500.html
>
> >>        # Serve django pages
> >>        <Directory "/">
> >>                Options FollowSymLinks
> >>        </Directory>
>
> >>        <Location "/">
> >>                PythonPath "['/var/www/review-board/conf'] +
> >> ['@djangodir@'] + ['/home/pbeets/Web/django_projects'] + ['@pythondir@/
> >> djblets'] $
> >>                SetEnv DJANGO_SETTINGS_MODULE reviewboard.settings
> >>                SetHandler mod_python
> >>                PythonHandler django.core.handlers.modpython
> >>                PythonAutoReload Off
> >>                PythonDebug Off
> >>                # Used to run multiple mod_python sites in the same
> >> apache
> >>                PythonInterpreter reviewboard_review-board
> >>        </Location>
>
> >>        # Serve static media without running it through mod_python
> >>        # (overrides the above)
> >>        <Location "/media">
> >>                SetHandler None
> >>        </Location>
>
> >>        <Location "/errordocs">
> >>                SetHandler None
> >>        </Location>
>
> >>        # Alias static media requests to filesystem
> >>        Alias /media /var/www/review-board/htdocs/media
> >>        Alias /errordocs /var/www/review-board/htdocs/errordocs
> >> </VirtualHost>- Skjul tekst i anførselstegn -
>
> - Vis tekst i anførselstegn -
--~--~---------~--~----~------------~-------~--~----~
You received this message because you are subscribed to the Google Groups 
"reviewboard" group.
To post to this group, send email to reviewboard@googlegroups.com
To unsubscribe from this group, send email to 
reviewboard+unsubscr...@googlegroups.com
For more options, visit this group at 
http://groups.google.com/group/reviewboard?hl=en
-~----------~----~----~----~------~----~------~--~---

Reply via email to