Nothing stands out as being wrong in the config file. It sounds like
mod_python isn't handling the request, though. Are you use mod_python is
enabled?

Christian

-- 
Christian Hammond - chip...@chipx86.com
VMware, Inc.


On Fri, Jan 16, 2009 at 11:49 AM, kmw <kochhar...@gmail.com> wrote:

>
> Hi,
>
> I've managed to get reviewboard installed but I'm having problems with
> the apache configuration. I'm running reviewboard on a Gentoo Linux
> server. I've looked through the other threads on th group but all I
> can find is this thread,
>
> http://groups.google.com/group/reviewboard/browse_thread/thread/cb348da7ccbf8ca6/cd931815b1b77446
> which hasn't been of much use.
>
> My httpd.conf includes the reviewboard vhost config which is as
> follows:
>
> <VirtualHost *:80>
>        ServerName foo.bar
>        DocumentRoot /var/www/reviewboard/htdocs
>
>        # Error handlers
>        ErrorDocument 500 /errordocs/500.html
>
>        # Serve django pages
>        <Location "/">
>                PythonPath "['/var/www/reviewboard/conf'] + sys.path"
>                SetEnv DJANGO_SETTINGS_MODULE reviewboard.settings
>                SetHandler mod_python
>                PythonHandler django.core.handlers.modpython
>                PythonAutoReload Off
>                PythonDebug Off
>                # Used to run multiple mod_python sites in the same
> apache
>                PythonInterpreter reviewboard_reviewboard
>        </Location>
>
>        # Serve static media without running it through mod_python
>        # (overrides the above)
>        <Location "/media">
>                SetHandler None
>        </Location>
>        <Location "/errordocs">
>                SetHandler None
>        </Location>
>
>        # Alias static media requests to filesystem
>        Alias /media /var/www/reviewboard/htdocs/media
>        Alias /errordocs /var/www/reviewboard/htdocs/errordocs
> </VirtualHost>
>
> Here's the output from apache error_log
> [Fri Jan 16 19:47:19 2009] [error] [client 172.31.20.117] client
> denied by server configuration: /var/www/reviewboard/htdocs/
>
> Any suggestions on what to do next?
>
> Thanks
> >
>

--~--~---------~--~----~------------~-------~--~----~
You received this message because you are subscribed to the Google Groups 
"reviewboard" group.
To post to this group, send email to reviewboard@googlegroups.com
To unsubscribe from this group, send email to 
reviewboard+unsubscr...@googlegroups.com
For more options, visit this group at 
http://groups.google.com/group/reviewboard?hl=en
-~----------~----~----~----~------~----~------~--~---

Reply via email to