The problem looks to be that you specified a "site root" during install of
"/", when it should have been "/reviews/". You can modify your
conf/settings_local.py to change this (and FORCE_SCRIPT_NAME should probably
be an empty string).

I'm going to be landing new lighttpd config generation in another day or
two, which will fix a lot of out-of-the-box install issues with lighttpd.

Christian

-- 
Christian Hammond - chip...@chipx86.com
VMware, Inc.


On Wed, Jan 28, 2009 at 9:45 AM, san...@gmail.com <san...@gmail.com> wrote:

>
> I am trying to install reviewboard on an Ubuntu 8.10 VMWare virtual
> machine to try it without much luck. The following is the sequence of
> steps that I've followed so far (after looking through various posts
> on this discussion board):
>
> 1. I used "rb-site install /var/www/reviewboard" with the following
> options:
>    domain-name: localhost    site-root: /    media-url: media/
>    db-type: sqlite3    cache-type: file    web-server-type: lighttpd
> 2. Then I copied over the /etc/lighttpd/lighttpd.conf with the file
> in /var/www/conf/lighttpd.conf.
> 3. Added "FORCE_SCRIPT_NAME='/'" to settings_local.py
> 4. Ran "sudo /etc/init.d/lighttpd force-reload"
> 5. Ran "rb-site manage /var/www/reviewboard runfcgi method=threaded
> host=127.0.0.1 port=3033 protocol=fcgi"
>
> Visiting "http://localhost/reviews/"; redirects me to "http://localhost/
> reviewboard.fcgi/reviews/" which produces a "Page not found (404)"
> with the following:
>
> Page not found (404)
> Request Method:         GET
> Request URL:    http://localhost/reviewboard.fcgi/reviews/
>
> Using the URLconf defined in djblets.util.rooturl, Django tried these
> URL patterns, in this order:
>
>   1. ^reviews/
>
> The current URL, reviewboard.fcgi/reviews/, didn't match any of these.
>
> You're seeing this error because you have DEBUG = True in your Django
> settings file. Change that to False, and Django will display a
> standard 404 page.
>
> Any help in getting this up and going is appreciated. Thanks.
>
> >
>

--~--~---------~--~----~------------~-------~--~----~
You received this message because you are subscribed to the Google Groups 
"reviewboard" group.
To post to this group, send email to reviewboard@googlegroups.com
To unsubscribe from this group, send email to 
reviewboard+unsubscr...@googlegroups.com
For more options, visit this group at 
http://groups.google.com/group/reviewboard?hl=en
-~----------~----~----~----~------~----~------~--~---

Reply via email to