Apache's no-login, but you should (as root) be able to sudo as Apache's
user, and you should be able to generate public/private keys for that user
and put it on the SVN server's authorized_keys for the user that Review
Board is trying to connect as.

If you sudo as Apache, you'll need to make sure your $HOME is set to
Apache's user's $HOME, which you may have to create if it doesn't have one
set in /etc/pass.

There's a tutorial on password-less logins with svn+ssh at:

http://cnmat.berkeley.edu/library/cnmat_users_manual/software_development_guides/using_subversion/troubleshooting/setting_ssh_password_less_login

Christian

-- 
Christian Hammond - chip...@chipx86.com
Review Board - http://www.review-board.org
VMware, Inc. - http://www.vmware.com


On Thu, Feb 12, 2009 at 12:53 AM, Dev <devmeg...@gmail.com> wrote:

>
> Below is the Log message i got from the SVN server.
> "Feb 12 14:07:40 XXXXXXXXXXX sshd[27074]: Failed password for apache
> from ::ffff:XXX.XXX.XXX.XXX port 39183 ssh2 "
>
> I guess if i enable apache as password less in the server,there may be
> security violence.Is it possible to point out the ReviewBoard server
> to login as unix users' login?
>
> Regards,
> dev
>
> On Feb 12, 1:18 pm, Dev <devmeg...@gmail.com> wrote:
> > No christian.Apache is in 'nologin' mode.So as a apache user i won't
> > be able to check-out.
> >
> > On Feb 12, 11:52 am, Christian Hammond <chip...@chipx86.com> wrote:
> >
> > > So doing a checkout as Apache/lighttpd's user using svn+ssh is working
> > > without a password on that server? What did you do to enable that?
> >
> > > Christian
> >
> > > --
> > > Christian Hammond - chip...@chipx86.com
> > > Review Board -http://www.review-board.org
> > > VMware, Inc. -http://www.vmware.com
> >
> > > On Wed, Feb 11, 2009 at 8:55 PM, Dev <devmeg...@gmail.com> wrote:
> >
> > > > Hi,
> > > > I have given password less entry in my SVN server for my unix
> user.But
> > > > still i am facing the same problem..:(
> >
> > > > Pl help me.
> >
> > > > On Feb 11, 4:55 pm, Christian Hammond <chip...@chipx86.com> wrote:
> > > > > It probably was.
> >
> > > > > If you can at all access the server through HTTP, that would be
> best.
> > > > > Otherwise, you'll need to configure the web server user's ssh and
> svn
> > > > > configuration to allow it to access files without prompting for a
> > > > password.
> > > > > Same way you would any other user.
> >
> > > > > Christian
> >
> > > > > --
> > > > > Christian Hammond - chip...@chipx86.com
> > > > > VMware, Inc.
> >
> > > > > On Wed, Feb 11, 2009 at 3:50 AM, Dev <devmeg...@gmail.com> wrote:
> >
> > > > > > SVN check-out successfull in my client m/c.But when i tried to
> check-
> > > > > > out from the RB server,it was asking my unix user's password.
> > > > > > I guess when i hit the 'view diff' button,it is looking for unix
> user
> > > > > > password? Pl correct me if i am wrong.
> > > > > > I am using URL "svn+ssh://URL/subversion/data/project/"
> >
> > > > > > On Feb 11, 4:32 pm, Dev <devmeg...@gmail.com> wrote:
> > > > > > > No.This is fresh installation in the centOS machine.
> > > > > > > Let me try a check-out and let you know.
> >
> > > > > > > -Dev
> >
> > > > > > > On Feb 11, 4:27 pm, Christian Hammond <chip...@chipx86.com>
> wrote:
> >
> > > > > > > > You should try a checkout from both your local box and from
> the
> > > > server
> > > > > > > > running Review Board, using the same settings (SVN URL,
> username,
> > > > > > password)
> > > > > > > > that Review Board is using.
> >
> > > > > > > > This doesn't sound like it's a Review Board issue
> specifically. It
> > > > > > sounds
> > > > > > > > like a connection issue with SVN.
> >
> > > > > > > > Did this used to work, and just recently break? Does it
> happen with
> > > > all
> > > > > > > > diffs?
> >
> > > > > > > > Christian
> >
> > > > > > > > --
> > > > > > > > Christian Hammond - chip...@chipx86.com
> > > > > > > > VMware, Inc.
> >
> > > > > > > > On Wed, Feb 11, 2009 at 3:01 AM, Dev <devmeg...@gmail.com>
> wrote:
> >
> > > > > > > > > Can you pl let me know what will be my next step to attack
> this
> > > > > > > > > problem?
> >
> > > > > > > > > -Dev
> >
> > > > > > > > > On Feb 11, 3:50 pm, Christian Hammond <chip...@chipx86.com
> >
> > > > wrote:
> > > > > > > > > > Diff generation isn't a problem. In SVN, diffs are
> generated
> > > > > > locally
> > > > > > > > > without
> > > > > > > > > > talking to the server.
> >
> > > > > > > > > > Review Board needs to actually fetch each file in the
> diff in
> > > > order
> > > > > > to
> > > > > > > > > > generate a full side-by-side diff, so it talks to the SVN
> > > > server
> > > > > > before
> > > > > > > > > even
> > > > > > > > > > taking your generated diff into account.
> >
> > > > > > > > > > Christian
> >
> > > > > > > > > > --
> > > > > > > > > > Christian Hammond - chip...@chipx86.com
> > > > > > > > > > VMware, Inc.
> >
> > > > > > > > > > On Wed, Feb 11, 2009 at 2:48 AM, Dev <
> devmeg...@gmail.com>
> > > > wrote:
> >
> > > > > > > > > > > But i can able to see the diff in the windows command
> line by
> > > > > > giving --
> > > > > > > > > > > output-diff command.
> > > > > > > > > > > It shows perfectly in command line.
> >
> > > > > > > > > > > On Feb 11, 2:25 pm, Christian Hammond <
> chip...@chipx86.com>
> > > > > > wrote:
> > > > > > > > > > > > This sounds like an issue between your Review Board
> server
> > > > and
> > > > > > your
> > > > > > > > > SVN
> > > > > > > > > > > > server. Are you having any of these problems from
> your
> > > > local
> > > > > > box?
> >
> > > > > > > > > > > > Try a checkout from the Review Board server using the
> same
> > > > > > > > > configuration
> > > > > > > > > > > > specified in Review Board. See if you can duplicate
> it, and
> > > > if
> > > > > > you
> > > > > > > > > can
> > > > > > > > > > > get
> > > > > > > > > > > > any debug info from there.
> >
> > > > > > > > > > > > Christian
> >
> > > > > > > > > > > > --
> > > > > > > > > > > > Christian Hammond - chip...@chipx86.com
> > > > > > > > > > > > VMware, Inc.
> >
> > > > > > > > > > > > On Wed, Feb 11, 2009 at 1:07 AM, Dev <
> devmeg...@gmail.com>
> > > > > > wrote:
> >
> > > > > > > > > > > > > Hi,
> >
> > > > > > > > > > > > > I have installed RB 1.0 and pointed webserver as
> apache.
> > > > > > > > > > > > > I am able to post the reviews perfectly.But when i
> try to
> > > > see
> > > > > > the
> > > > > > > > > diff
> > > > > > > > > > > > > by using 'view diff' buton,it says below error.
> >
> > > > > > > > > > > > > Diff currently unavailable.
> > > > > > > > > > > > > Error: Connection closed unexpectedly
> > > > > > > > > > > > > Details
> >
> > > > > > > > > > > > > Traceback (most recent call last):
> > > > > > > > > > > > >  File
> > > > > > "/usr/lib/python2.4/site-packages/ReviewBoard-1.0alpha2-
> > > > > > > > > > > > > py2.4.egg/reviewboard/diffviewer/views.py", line
> 183, in
> > > > > > > > > > > > > view_diff_fragment
> > > > > > > > > > > > >    file = get_requested_diff_file()
> > > > > > > > > > > > >  File
> > > > > > "/usr/lib/python2.4/site-packages/ReviewBoard-1.0alpha2-
> > > > > > > > > > > > > py2.4.egg/reviewboard/diffviewer/views.py", line
> 159, in
> > > > > > > > > > > > > get_requested_diff_file
> > > > > > > > > > > > >    get_chunks)
> > > > > > > > > > > > >  File
> > > > > > "/usr/lib/python2.4/site-packages/ReviewBoard-1.0alpha2-
> > > > > > > > > > > > > py2.4.egg/reviewboard/diffviewer/diffutils.py",
> line 613,
> > > > in
> > > > > > > > > > > > > get_diff_files
> > > > > > > > > > > > >    large_data=True)
> > > > > > > > > > > > >  File
> > > > > > > > >
> "/usr/lib/python2.4/site-packages/Djblets-0.5alpha2-py2.4.egg/
> > > > > > > > > > > > > djblets/util/misc.py", line 143, in cache_memoize
> > > > > > > > > > > > >    data = lookup_callable()
> > > > > > > > > > > > >  File
> > > > > > "/usr/lib/python2.4/site-packages/ReviewBoard-1.0alpha2-
> > > > > > > > > > > > > py2.4.egg/reviewboard/diffviewer/diffutils.py",
> line 612,
> > > > in
> > > > > > > > > <lambda>
> > > > > > > > > > > > >    enable_syntax_highlighting),
> > > > > > > > > > > > >  File
> > > > > > "/usr/lib/python2.4/site-packages/ReviewBoard-1.0alpha2-
> > > > > > > > > > > > > py2.4.egg/reviewboard/diffviewer/diffutils.py",
> line 341,
> > > > in
> > > > > > > > > > > > > get_chunks
> > > > > > > > > > > > >    old = get_original_file(filediff)
> > > > > > > > > > > > >  File
> > > > > > "/usr/lib/python2.4/site-packages/ReviewBoard-1.0alpha2-
> > > > > > > > > > > > > py2.4.egg/reviewboard/diffviewer/diffutils.py",
> line 248,
> > > > in
> > > > > > > > > > > > > get_original_file
> > > > > > > > > > > > >    large_data=True)[0]
> > > > > > > > > > > > >  File
> > > > > > > > >
> "/usr/lib/python2.4/site-packages/Djblets-0.5alpha2-py2.4.egg/
> > > > > > > > > > > > > djblets/util/misc.py", line 143, in cache_memoize
> > > > > > > > > > > > >    data = lookup_callable()
> > > > > > > > > > > > >  File
> > > > > > "/usr/lib/python2.4/site-packages/ReviewBoard-1.0alpha2-
> > > > > > > > > > > > > py2.4.egg/reviewboard/diffviewer/diffutils.py",
> line 247,
> > > > in
> > > > > > > > > <lambda>
> > > > > > > > > > > > >    data = cache_memoize(key, lambda:
> [fetch_file(file,
> > > > > > revision)],
> > > > > > > > > > > > >  File
> > > > > > "/usr/lib/python2.4/site-packages/ReviewBoard-1.0alpha2-
> > > > > > > > > > > > > py2.4.egg/reviewboard/diffviewer/diffutils.py",
> line 227,
> > > > in
> > > > > > > > > > > > > fetch_file
> > > > > > > > > > > > >    data = tool.get_file(file, revision)
> > > > > > > > > > > > >  File
> > > > > > "/usr/lib/python2.4/site-packages/ReviewBoard-1.0alpha2-
> > > > > > > > > > > > > py2.4.egg/reviewboard/scmtools/svn.py", line 115,
> in
> > > > get_file
> > > > > > > > > > > > >    raise SCMError(e)
> > > > > > > > > > > > > SCMError: Connection closed unexpectedly
> >
> > > > > > > > > > > > > Pl help me in this regard.
> >
> > > > > > > > > > > > > Regards,
> > > > > > > > > > > > > dev
> >
>

--~--~---------~--~----~------------~-------~--~----~
You received this message because you are subscribed to the Google Groups 
"reviewboard" group.
To post to this group, send email to reviewboard@googlegroups.com
To unsubscribe from this group, send email to 
reviewboard+unsubscr...@googlegroups.com
For more options, visit this group at 
http://groups.google.com/group/reviewboard?hl=en
-~----------~----~----~----~------~----~------~--~---

Reply via email to