Thanks Lester and Christian.  I enabled debugging and logging, but it
doesn't seem to spit out anything terribly useful (no errors,
exceptions or stacktraces).

This is on CentOS 4.5.  Most everything I have installed is compiled
from source, so I wouldn't be surprised at something being amiss or
misconfigured.  I just tried bringing up all relevant software up to
the latest versions, but to no help to ReviewBoard.
Apache 2.211
SVN 1.5.6
mod_python 3.3.1
Python 2.6.1
PySvn 1.6.3
Django 1.0.2
...etc...

Is there anywhere I could drop some debug statements or maybe a way to
figure out what is seg faulting?  Many of the other JSON API calls
seem to work just fine, but get_repository_info seems to cause some
issues....


On Feb 26, 5:50 pm, Christian Hammond <chip...@chipx86.com> wrote:
> Ooh, that's pretty scary. Our stuff should definitely not be able to crash.
> It sounds like Apache or mod_python is the issue here. What distro is this?
>
> Christian
>
> --
> Christian Hammond - chip...@chipx86.com
> Review Board -http://www.review-board.org
> VMware, Inc. -http://www.vmware.com
>
> On Thu, Feb 26, 2009 at 8:44 AM, Angela <angela.nava...@gmail.com> wrote:
>
> > On my reviewboard setup, post-review is throwing a
> > httplib.BadStatusLine.  After some digging, I discovered the failing
> > url. Whenever I access the url http://
> > [our-install-url]/api/json/repositories/1/info/,
> > I get back an empty page.  Looking in our apache logs, I see a
> > segementation fault after each access:
> > ' [notice] child pid 4596 exit signal Segmentation fault (11)'
>
> > I am completely new at reviewboard and django, so I'm having trouble
> > finding any additional information/logging.  We are using a SVN
> > repository, with sqlite, and file based caching.  I also tried with
> > mysql and memcached to the same ends.  Any insights to what process
> > may be segfaulting?
--~--~---------~--~----~------------~-------~--~----~
You received this message because you are subscribed to the Google Groups 
"reviewboard" group.
To post to this group, send email to reviewboard@googlegroups.com
To unsubscribe from this group, send email to 
reviewboard+unsubscr...@googlegroups.com
For more options, visit this group at 
http://groups.google.com/group/reviewboard?hl=en
-~----------~----~----~----~------~----~------~--~---

Reply via email to