Hmm - I'm not using apache, I'm using lighttpd.  There is no 000-
default.  There is a default document root however.  But lighttpd has
to have one in order to start.  lighttpd starts fine and is listening
at the right place but isn't connecting to the reviewboard django

I finally found that there is a command "manage" for rb-site and that
I can start the site via:
rb-site manage /home/azillia/webapps/reviewboard/ runfcgi
method=threaded daemonize=false host= port=13000.

So now the site comes up but there's an issue with the css and images
not being found.  Looks like I need to change the media_url or
something like that.

Cool. Almost there.


On Mar 16, 12:12 am, Christian Hammond <> wrote:
> The "guts" of the application are in the Python site-packages directory.
> Unlike .php files, we don't need to install files inside the htdocs
> directory. As long as you have your new server config set up properly (which
> may require disabling the "000-default" file if you have one, which sets
> /var/www as the htdocs for every subdomain), you're ready to go.
> Christian
> --
> Christian Hammond -
> Review Board -
> VMware, Inc. -
> On Sun, Mar 15, 2009 at 9:55 PM, Danny <> wrote:
> > I must be missing something simple (I hope).
> > Here are the steps I am taking to install latest 1.0alpha5 on Ubuntu
> > 8.04 with lighttpd:
> > installed all dependencies
> > sudo easy_install ReviewBoard
> > rb-site install --copy-media /home/user/webapps/reviewboard
> >  - specify domain, lighttpd, sqlite, and all others as defaults
> > this creates a site with the following files and dirs in  /home/user/
> > webapps/reviewboard :
> >  -conf/  db/  htdocs/  logs/  tmp/
> > This is where I am missing something.  Am I supposed to install this
> > into an existing django app?  Or did something go wrong?  Or did I
> > miss a step?  Where are the "guts" of the application?
> > If it's in the docs I must be blind as I've looked over them many
> > times.
> > Any help would be appreciated.
> > Thanks
> > Danny
You received this message because you are subscribed to the Google Groups 
"reviewboard" group.
To post to this group, send email to
To unsubscribe from this group, send email to
For more options, visit this group at

Reply via email to