Yeah yeah for sure

2009/3/20 Gary M. Josack <g...@byoteki.com>

>
> I'm going to guess you got that error because cleartool isn't installed.
>
> Laurent Dufrechou wrote:
> > Just tested under linux got this execption:
> >
> > Traceback (most recent call last):
> >   File "./post-review", line 2312, in <module>
> >     main(sys.argv[1:])
> >   File "./post-review", line 2253, in main
> >     repository_info, tool = determine_client()
> >   File "./post-review", line 2205, in determine_client
> >     repository_info = tool.get_repository_info()
> >   File "./post-review", line 744, in get_repository_info
> >     self.viewinfo = execute(["cleartool", "pwv", "-short"])
> >   File "./post-review", line 1897, in execute
> >     env=env)
> >   File "/usr/lib/python2.5/subprocess.py", line 594, in __init__
> >     errread, errwrite)
> >   File "/usr/lib/python2.5/subprocess.py", line 1147, in _execute_child
> >     raise child_exception
> > OSError: [Errno 2] No such file or directory
> >
> > So under linux it raise an OSError.
> >
> > To be clear I really misuse the script as I launch it on a directory
> > where there is nothing else, but well it should catch the exception I
> > think.
> >
> >
> > 2009/3/20 Laurent Dufrechou <laurent.dufrec...@gmail.com
> > <mailto:laurent.dufrec...@gmail.com>>
> >
> >     By the way .reviewboardrc for the filename of config name is not
> >     good for portability because under windows you can't '.reviewboardrc'
> >     It absolutely want somthin like "xxxx.yy" or "xxxx" :(
> >     perhaps alowing a second name for windows could be a good idea too.
> >
> >     somethong like reviewboardrc.conf.
> >
> >     If you want I can modify the script to work under windows (with
> >     .conf  + try catch for subprocess) and send it back to you.
> >
> >
> >     2009/3/20 Laurent Dufrechou <laurent.dufrec...@gmail.com
> >     <mailto:laurent.dufrec...@gmail.com>>
> >
> >         More like an active state like:
> >         http://www.pythonxy.com/foreword_fr.php
> >
> >         I think this is more because of i'm under vista business SP1.
> >         I've run in same bug under ipython wednesday.
> >         A subprocess couldn't be called due to UAC (other issue but
> >         related to subprocess) and it raised Windows Error.
> >         So seems subprocess rise this sort of error when it see that
> >         the subprocess call exist with failure.
> >
> >         Perhpas more related to Vista vs XP?
> >
> >
> >         2009/3/20 Christian Hammond <chip...@chipx86.com
> >         <mailto:chip...@chipx86.com>>
> >
> >             post-review doesn't require clearcase, and the code that
> >             was being run there is the test for whether or not you had
> >             it. What should have happened is that we'd see the failure
> >             (as a return code, not an exception) and then we'd just
> >             silently skip it. The thing is, on your Windows Python
> >             install for whatever reason, we're getting the exception
> >             instead of the return code.
> >
> >             We can definitely do a try/except around the
> >             subprocess.Popen call, and then just fake an error return
> >             code. I'm just wondering why this is happening in the
> >             first place on your system, since I know many other people
> >             use post-review on Windows and haven't complained about it.
> >
> >             When you say the python(x,y) distribution, do you mean
> >             specifically the Python installer on python.org
> >             <http://python.org>, or are you using something like
> >             ActiveState's Python install?
> >
> >
> >             Christian
> >
> >             --
> >             Christian Hammond - chip...@chipx86.com
> >             <mailto:chip...@chipx86.com>
> >             Review Board - http://www.review-board.org
> >             VMware, Inc. - http://www.vmware.com
> >
> >
> >             On Fri, Mar 20, 2009 at 1:24 PM, Laurent Dufrechou
> >             <laurent.dufrec...@gmail.com
> >             <mailto:laurent.dufrec...@gmail.com>> wrote:
> >
> >                 python -> from python(x,y) distribution. this is a
> >                 python 2.5.2.
> >                 Json as been installed from setuptools.
> >
> >                 The fact is as I don't have clearcase on my computer,
> >                 it could not detetc the tool, so it should warn the
> >                 user that it could'nt do the test I think.
> >                 This is not related to python, but more dur to the
> >                 fact taht my windows clinet knows nothing about
> clearcase.
> >                 (you can catch it with try: except WindowsError: but
> >                 then I don't now how to says there was a failure,
> >                 perhpas raisng another exeption and cathcing it in
> >                 higher level?)
> >
> >                 I will definitvely read the doc, and setup a property
> >                 for svn.
> >
> >                 will come after some tries.
> >
> >                 Laurent
> >
> >
> >                 2009/3/20 Christian Hammond <chip...@chipx86.com
> >                 <mailto:chip...@chipx86.com>>
> >
> >                     The .reviewboardrc is needed for specifying which
> >                     server to use, but really this should be done
> >                     through a property on the SVN server. See the docs
> >                     in the script for details on setting this up.
> >
> >                     However, .reviewboardrc isn't related to this. The
> >                     problem is that we're attempting to execute the
> >                     clearcase tool in order to see if 1) it's
> >                     available and 2) this is a clearcase repository.
> >                     We do these scans with lots of tools. What's odd
> >                     about this one is that we're actually getting an
> >                     error back that we don't expect. The call we use
> >                     *should* return an error code, not an exception.
> >
> >                     Where did you install your Python from?
> >
> >
> >                     Christian
> >
> >                     --
> >                     Christian Hammond - chip...@chipx86.com
> >                     <mailto:chip...@chipx86.com>
> >                     Review Board - http://www.review-board.org
> >                     VMware, Inc. - http://www.vmware.com
> >
> >
> >                     On Fri, Mar 20, 2009 at 12:29 PM, Laurent
> >                     Dufrechou <laurent.dufrec...@gmail.com
> >                     <mailto:laurent.dufrec...@gmail.com>> wrote:
> >
> >                         It means "File not found"
> >                         By the way taking  a look  @ python script
> >                         I've seen that it look after a .reviewboardrc
> >                         file.
> >
> >                         the fact is i use the script on windows pc
> >                         client that is not the server. So perhaps
> >                         someone could say me where i can find this
> >                         file that must me configured I think?
> >                         Sorry I fall in all the newbies trap....
> >                         :)
> >
> >
> >
> >                         2009/3/20 Christian Hammond
> >                         <chip...@chipx86.com
> >                         <mailto:chip...@chipx86.com>>
> >
> >                             I imagine we're trying to detect if it's a
> >                             clearcase repository and something with
> >                             the locale is causing us to fail
> >                             incorrectly. Possibly a locale-related
> >                             issue. What does "Le fichier spÚcifiÚ est
> >                             introuvable" translate to in English?
> >
> >                             Christian
> >
> >                             --
> >                             Christian Hammond - chip...@chipx86.com
> >                             <mailto:chip...@chipx86.com>
> >                             Review Board - http://www.review-board.org
> >                             VMware, Inc. - http://www.vmware.com
> >
> >
> >
> >                             On Fri, Mar 20, 2009 at 10:07 AM, Laurent
> >                             Dufréchou <laurent.dufrec...@gmail.com
> >                             <mailto:laurent.dufrec...@gmail.com>> wrote:
> >
> >
> >                                 Hum yeah...
> >                                 I've set up a svn repos in the web
> >                                 interface.
> >                                 But I access it usually via svn://
> >
> >                                 (I never heard of Clear Case SCM until
> >                                 now :) )
> >
> >                                 > -----Message d'origine-----
> >                                 > De : reviewboard@googlegroups.com
> >                                 <mailto:reviewboard@googlegroups.com>
> >                                 [mailto:reviewboard@googlegroups.com
> >                                 <mailto:reviewboard@googlegroups.com>]
> >                                 > De la part de Bartlomiej Celary
> >                                 > Envoyé : vendredi 20 mars 2009 14:33
> >                                 > À : reviewboard@googlegroups.com
> >                                 <mailto:reviewboard@googlegroups.com>
> >                                 > Objet : Re: Cleartool missing + Svn
> >                                 access issue ?
> >                                 >
> >                                 >
> >                                 > Are you using a Clear Case SCM?
> >                                 Cleartool is the tool needed to manage
> >                                 > this kind of repo.
> >                                 >
> >                                 > If not that means the post-review
> >                                 gives a false positive for a
> >                                 > clearcase repo instead of detecting
> >                                 subversion (I presume this is what
> >                                 > you actually need). Are you sure you
> >                                 are in a subversion repository?
> >                                 >
> >                                 > Bartek
> >                                 >
> >                                 > 2009/3/20
> >                                 laurent.dufrec...@gmail.com
> >                                 <mailto:laurent.dufrec...@gmail.com>
> >                                 <laurent.dufrec...@gmail.com
> >                                 <mailto:laurent.dufrec...@gmail.com>>:
> >                                 > >
> >                                 > > Hello ,
> >                                 > > in my quest to make reviewboard
> >                                 i've got these issues:
> >                                 > > 1)using post-review.py under
> >                                 windows got this:
> >                                 > >>>> cleartool pwv -short
> >                                 > > Traceback (most recent call last):
> >                                 > >  File
> >
> "C:\Users\ldufrechou\Desktop\post-review.py",
> >                                 line 2312, in
> >                                 > > <module>
> >                                 > >    main(sys.argv[1:])
> >                                 > >  File
> >
> "C:\Users\ldufrechou\Desktop\post-review.py",
> >                                 line 2253, in
> >                                 > > main
> >                                 > >    repository_info, tool =
> >                                 determine_client()
> >                                 > >  File
> >
> "C:\Users\ldufrechou\Desktop\post-review.py",
> >                                 line 2205, in
> >                                 > > determine_client
> >                                 > >    repository_info =
> >                                 tool.get_repository_info()
> >                                 > >  File
> >
> "C:\Users\ldufrechou\Desktop\post-review.py",
> >                                 line 744, in
> >                                 > > get_repository_info
> >                                 > >    self.viewinfo =
> >                                 execute(["cleartool", "pwv", "-short"])
> >                                 > >  File
> >
> "C:\Users\ldufrechou\Desktop\post-review.py",
> >                                 line 1888, in
> >                                 > > execute
> >                                 > >    env=env)
> >                                 > >  File
> >                                 "C:\python25\lib\subprocess.py", line
> >                                 594, in __init__
> >                                 > >    errread, errwrite)
> >                                 > >  File
> >                                 "C:\python25\lib\subprocess.py", line
> >                                 816, in _execute_child
> >                                 > >    startupinfo)
> >                                 > > WindowsError: [Error 2] Le fichier
> >                                 spÚcifiÚ est introuvable
> >                                 > >
> >                                 > > It don't know where is cleartool
> >                                 and I also don't get any idea too.
> >                                 > > Do I missed to install something?
> >                                 Looking on google I've something
> >                                 > > related to rational rose....
> >                                 > >
> >                                 > > 2) I've posted a review directly
> >                                 via the web interface giving a .diff
> >                                 > > file.
> >                                 > > Clicking on view diff, I get a
> >                                 blank page.
> >                                 > > I suspect that review board could
> >                                 not connect to svn repos.
> >                                 > > How can I check communication? Is
> >                                 there any log somewhere to see
> >                                 > > authentication failure?
> >                                 > > Does it support svn acces via :
> >                                 svn://svn.mycompany.com/xxx/xxxx
> >                                 <http://svn.mycompany.com/xxx/xxxx> ?
> >                                 > >
> >                                 > > Thx for any help  :)
> >                                 > >
> >                                 > >
> >                                 > >
> >                                 > >
> >                                 > >
> >                                 > > >
> >                                 > >
> >                                 >
> >                                 >
> >
> >
> >
> >
> >
> >
> >
> >
> >
> >
> >
> >
> >
> >
> >
> >
> >
> >
> >
> >
> >
> > >
>
>
> >
>

--~--~---------~--~----~------------~-------~--~----~
You received this message because you are subscribed to the Google Groups 
"reviewboard" group.
To post to this group, send email to reviewboard@googlegroups.com
To unsubscribe from this group, send email to 
reviewboard+unsubscr...@googlegroups.com
For more options, visit this group at 
http://groups.google.com/group/reviewboard?hl=en
-~----------~----~----~----~------~----~------~--~---

Reply via email to