Hey Sandy,

Couple questions. First, is "git-svn/branches/post-1.0-research" the name of
the actual branch in git?

The filename in that path definitely seems screwed up. It shows the filename
as the parent directory of itself. So maybe there's some processing that's
broken there.

That parent diff is generated by running:

git diff --no-color --no-prefix -r -u master..<yourparentbranch>

Does this look correct? If so, it's our processing. Would you mind sending
us the diff for that file (as an attachment) using the above, if you can
still get it?

Christian

-- 
Christian Hammond - chip...@chipx86.com
Review Board - http://www.review-board.org
VMware, Inc. - http://www.vmware.com


On Mon, Mar 23, 2009 at 5:26 PM, Sandy Armstrong <sanfordarmstr...@gmail.com
> wrote:

>
> Hello,
>
> I'm testing out the use of git-svn with an instance of Review Board
> 1.0 Alpha 4.  I'm currently getting an error from the server if my
> parent_diff contains the deletion of a file (because the file only
> exists in trunk/master, not in the branch/remote).  I don't have
> enough access to debug what's going on on the server (I can tomorrow),
> but this is my situation:
>
> 1. I have a module (uia2atk) in Mono SVN, with various branches and
> tags.
> 2. I am using git-svn to pull in the trunk, branches, and tags of this
> module.
> 3. I am primarily working out of a branch called "post-1.0-
> research" (this is a local branch of the remote svn branch "git-svn/
> branches/post-1.0-research").  There are new files in SVN trunk that
> have not been merged into the SVN branch.
> 4. I have made several commits in my local post-1.0-research branch.
> 5. When I run `post-review --parent=git-svn/branches/post-1.0-research
> -d` from within my local "post-1.0-research" branch, I receive this
> error:
>
> Error uploading diff: The file was not found in the repository (207)
> >>> {'stat': 'fail', 'file':
> '/branches/uia2atk/post-1.0-research/test/keystrokes/winforms/maskedtextbox.py/maskedtextbox.py',
> 'err': {'msg': 'The file was not found in the repository', 'code': 207},
> 'revision': '130088'}
> Your review request still exists, but the diff is not attached.
>
> The file in question was recently added in SVN trunk, but does not
> exist in the SVN post-1.0-research branch (and therefore it does not
> exist in the git remote branch that mirrors the SVN branch).  I do not
> know why reviewboard expects the file to exist.
>
> I have added a few debug statements into post-review, and both
> parent_diff (between master and git-svn/branches/post-1.0-research)
> and diff (between git-svn/branches/post-1.0-research and my local
> post-1.0-research branch) look completely correct.  Something is
> happening on the server when reviewrequests/*/diff/new is called.
>
> I am going to try merging the latest trunk changes into the branch
> again and see if I still have this problem.  Otherwise I'm not really
> sure what to do.
>
> Thanks,
> Sandy
> >
>

--~--~---------~--~----~------------~-------~--~----~
You received this message because you are subscribed to the Google Groups 
"reviewboard" group.
To post to this group, send email to reviewboard@googlegroups.com
To unsubscribe from this group, send email to 
reviewboard+unsubscr...@googlegroups.com
For more options, visit this group at 
http://groups.google.com/group/reviewboard?hl=en
-~----------~----~----~----~------~----~------~--~---

Reply via email to