The Apache config file is the key thing though. It defines where the media
paths are. The problem you're having is most likely just your configuration
aliasing your /media directory to the wrong place.

Try going to http://yoursite/reviewboard/media/ in your browser and looking
at the Apache log files to see what it's complaining about.

Alternately, you might need to do rb-site upgrade /path/to/site/. Check the
htdocs/media/ directory in your site dir and see if the symlinks there are
broken.

Christian

-- 
Christian Hammond - chip...@chipx86.com
Review Board - http://www.review-board.org
VMware, Inc. - http://www.vmware.com


On Wed, Mar 25, 2009 at 11:08 PM, Dev <devmeg...@gmail.com> wrote:

>
> Hi Christian sorry for the mess happened.
> Below i have pasted setting.py and settings_local.py file.
>
> FYI : I have installed Reviewboard 1.0 and starting my reviewboard
> server in the path "/usr/lib/python2.4/site-packages/
> ReviewBoard-1.0alpha2-py2.4.egg/reviewboard/" using ./manage.py
> runserver **.***.***.***:****
>
> Settings.py
> ----------------
> def dependency_error(string):
>    sys.stderr.write('%s\n' % string)
>    sys.stderr.write(install_help)
>    sys.exit(1)
>
> if os.path.split(os.path.dirname(__file__))[1] != 'reviewboard':
>    dependency_error('The directory containing manage.py must be named
> "reviewboard"')
>
> # Load local settings.  This can override anything in here, but at the
> very
> # least it needs to define database connectivity.
> try:
>    import settings_local
>    from settings_local import *
> except ImportError:
>    dependency_error('Unable to read settings_local.py.')
>
> TEMPLATE_DEBUG = DEBUG
>
> local_dir = os.path.dirname(settings_local.__file__)
>
> if local_dir == os.path.dirname(__file__):
>    # settings_local.py and settings.py are in the same place. This is
> probably
>    # an SVN checkout.
>    LOCAL_ROOT = local_dir
> else:
>    # This is likely a site install. Get the parent directory.
>    LOCAL_ROOT = os.path.dirname(local_dir)
>
> HTDOCS_ROOT = os.path.join(LOCAL_ROOT, 'htdocs')
> MEDIA_ROOT = os.path.join(HTDOCS_ROOT, 'media')
>
>
> # URL prefix for media -- CSS, JavaScript and images. Make sure to use
> a
> # trailing slash.
> #
> # Examples: "http://foo.com/media/";, "/media/".
> MEDIA_URL = getattr(settings_local, 'MEDIA_URL', SITE_ROOT + 'media/')
>
>
> # Base these on the user's SITE_ROOT.
> LOGIN_URL = SITE_ROOT + 'account/login/'
> ADMIN_MEDIA_PREFIX = MEDIA_URL + 'admin/'
>
> # Cookie settings
> LANGUAGE_COOKIE_NAME = "rblanguage"
> SESSION_COOKIE_NAME = "rbsessionid"
> SESSION_COOKIE_AGE = 365 * 24 * 60 * 60 # 1 year
> SESSION_COOKIE_PATH = SITE_ROOT
>
> # The list of directories that will be searched to generate a media
> serial.
> MEDIA_SERIAL_DIRS = ["admin", "djblets", "rb"]
>
>
> settings_local.py
> -------------------------
> # Site-specific configuration settings for Review Board
> # Definitions of these settings can be found at
> # http://docs.djangoproject.com/en/dev/ref/settings/
>
> # Database configuration
> DATABASE_ENGINE = 'mysql'
> DATABASE_NAME = 'reviewboard'
> DATABASE_USER = '*****'
> DATABASE_PASSWORD = '******'
> DATABASE_HOST = 'localhost'
> DATABASE_PORT = ''
>
> # Unique secret key. Don't share this with anybody.
> SECRET_KEY = 'd******************************
>
> # Cache backend settings.
> CACHE_BACKEND = 'file:///tmp/reviewboard_cache'
>
> # Extra site information.
> SITE_ID = 1
> SITE_ROOT = '/reviewboard/'
> FORCE_SCRIPT_NAME = ''
>
> I don't have any specific information in apache configuration file.So
> i have not pasted here.
>
> Pl let me know i am in the right way or not.
>
> Regards,
> dev
>
>
>
> On Mar 23, 12:44 pm, Christian Hammond <chip...@chipx86.com> wrote:
> > I didn't see the Apache file and settings_local.py file that was
> requested.
> > Perhaps I missed the e-mail, but gmail's not showing anything from you
> that
> > I can find.
> >
> > Christian
> >
> > --
> > Christian Hammond - chip...@chipx86.com
> > Review Board -http://www.review-board.org
> > VMware, Inc. -http://www.vmware.com
> >
> >
> >
> >
> >
> > On Mon, Mar 23, 2009 at 12:26 AM, Dev <devmeg...@gmail.com> wrote:
> >
> > > Hi just a reminder ..I am awaiting for reply ..
> >
> > > On Mar 19, 4:46 pm, Dev <devmeg...@gmail.com> wrote:
> > > > Hi,
> >
> > > > I amunableto seeanyimagesand .cssfilesarenotloaded.In log
> > > > file it shows '404Notfound' .But media directory available inside
> > > > reviewboard directory.
> >
> > > > Pl help me in this regard.
> >
> > > > Awaiting for reply.
> >
> > > > -Dev
> >
>

--~--~---------~--~----~------------~-------~--~----~
You received this message because you are subscribed to the Google Groups 
"reviewboard" group.
To post to this group, send email to reviewboard@googlegroups.com
To unsubscribe from this group, send email to 
reviewboard+unsubscr...@googlegroups.com
For more options, visit this group at 
http://groups.google.com/group/reviewboard?hl=en
-~----------~----~----~----~------~----~------~--~---

Reply via email to