Stefan,

I'm not entirely sure what you're trying to do.  My patch is designed
to allow reviews for changes to release branches on SVN.  So let's say
new development is in trunk, and 1.0 maintainenece is in a "1.0"
branch on SVN.  You have a Reviewboard server configured with your SVN
repository, and are using git-svn.  My patch adds a --gitsvnparent
option, which you can use to point to a branch in git that represents
an SVN branch.  So the way I use it is like this:

1. I have a remote branch for 1.0 in git-svn/branches/1.0
2. I have a local version of that branch in 1.0
3. I'm working on a feature branch called "my-1.0-feature", which I
branched off of 1.0.
4. After committing my cool changes in the feature branch, I run `post-
review --gitsvnparent=1.0`, which tells it to look at the 1.0 branch
in git when making the diff.

Trunk/master are not involved here in any way.

I don't know if this is what you want.  It sounds like you want to
work in a feature branch *in SVN*, mirror that into git, and then do a
review that diffs against trunk?  I'm not sure what the right way to
do that is, but I am pretty sure that "--parent=trunk" is an invalid
option unless you have a git branch called "trunk".

If you can describe your goal, we can probably figure out a way to do
it (or at least file a new bug).

Sandy

On Mar 30, 4:42 am, housemaister <housemais...@gmail.com> wrote:
> Hi,
>
> I'm in a similar (but not completely same) situation and I tried your
> patch, but it did not work for me.
> I have to admit I'm quite new to reviewboard and git, too, and I'm not
> sure if I use it the right way.
>
> My situation is the following:
> I have a svn trunk, a svn branch (let's call it mybranch) and a local
> git branch mybranch-local. In the trunk there is a file which was
> deleted in mybranch and therefore also in the local git branch. When
> trying to upload a diff with --parent=trunk I get the following error
> during upload of the parent diff:
> Error uploading diff: The file was not found in the repository (207)
>
> >>> {u'stat': u'fail', u'file': u'/branches/mybranch/filepath/filename.cpp', 
> >>> u'err': {u'msg': u'The file was not found in the repository', u'code': 
> >>> 207}, u'revision': u'66'}
>
> Do I have to configure reviewboard to use a git repository? (Currently
> I have it configured using the svn repository)
>
> --
> Stefan
>
> On Sun, Mar 29, 2009 at 18:22, Sandy Armstrong
>
> <sanfordarmstr...@gmail.com> wrote:
>
> > I think I have reduced this to a much simpler explanation in the
> > following new issue, if anybody is interested:
>
> >http://code.google.com/p/reviewboard/issues/detail?id=999
>
> > Conclusion: either --parent is slightly broken in how the server
> > processes it, or I'm using it wrong in the first place.  If I'm using
> > it wrong, either there's an option I'm missing or I need to add one
> > (thinking "--gitsvnparent") if I want to post reviews against SVN
> > branches using git-svn.
--~--~---------~--~----~------------~-------~--~----~
You received this message because you are subscribed to the Google Groups 
"reviewboard" group.
To post to this group, send email to reviewboard@googlegroups.com
To unsubscribe from this group, send email to 
reviewboard+unsubscr...@googlegroups.com
For more options, visit this group at 
http://groups.google.com/group/reviewboard?hl=en
-~----------~----~----~----~------~----~------~--~---

Reply via email to