Hello Christian,

Let me explain a little further and add the log:

1. If I post-review from command line in my checked out copy, it works
OK;

2. If I put post-review in the commit trigger (cvs commitinfo file),
it doesn't work and I get the following log:

The server reported an error while performing the "cvs commit"
command.
  CVSROOT_testing: Traceback (most recent call last):
  CVSROOT_testing:   File "/usr/bin/post-review", line 5, in ?
  CVSROOT_testing:     pkg_resources.run_script('RBTools==0.2beta1',
'post-review')
  CVSROOT_testing:   File "/usr/lib/python2.4/site-packages/
pkg_resources.py", line 448, in run_script
  CVSROOT_testing:     self.require(requires)[0].run_script
(script_name, ns)
  CVSROOT_testing:   File "/usr/lib/python2.4/site-packages/
pkg_resources.py", line 1173, in run_script
  CVSROOT_testing:     exec script_code in namespace, namespace
  CVSROOT_testing:   File "/usr/bin/post-review", line 2313, in ?
  CVSROOT_testing:
  CVSROOT_testing:   File "/usr/bin/post-review", line 2254, in main
  CVSROOT_testing:
  CVSROOT_testing:   File "/usr/bin/post-review", line 2206, in
determine_client
  CVSROOT_testing:
  CVSROOT_testing:   File "/usr/bin/post-review", line 744, in
get_repository_info
  CVSROOT_testing:
  CVSROOT_testing:   File "/usr/bin/post-review", line 1898, in
execute
  CVSROOT_testing:
  CVSROOT_testing:   File "/usr/lib/python2.4/subprocess.py", line
542, in __init__
  CVSROOT_testing:     errread, errwrite)
  CVSROOT_testing:   File "/usr/lib/python2.4/subprocess.py", line
975, in _execute_child
  CVSROOT_testing:     raise child_exception
  CVSROOT_testing: OSError: [Errno 2] No such file or directory
  CVSROOT_testing: cvs commit: Pre-commit check failed
  CVSROOT_testing: cvs [commit aborted]: correct above errors first!

In this case, my commitinfo has the following entry:

ALL       post-review -d --server=http://reviewboard --username=rb --
password=rb --submit-as=$USER --branch=TESTING

Thank you.
--~--~---------~--~----~------------~-------~--~----~
You received this message because you are subscribed to the Google Groups 
"reviewboard" group.
To post to this group, send email to reviewboard@googlegroups.com
To unsubscribe from this group, send email to 
reviewboard+unsubscr...@googlegroups.com
For more options, visit this group at 
http://groups.google.com/group/reviewboard?hl=en
-~----------~----~----~----~------~----~------~--~---

Reply via email to