Oh, didn't see this before the other e-mail.

In settings_local.py, try changing FORCE_SCRIPT_NAME to "" and see what
happens.

Christian

-- 
Christian Hammond - chip...@chipx86.com
Review Board - http://www.review-board.org
VMware, Inc. - http://www.vmware.com


On Fri, Apr 10, 2009 at 8:27 PM, joseph.pnc <joseph....@gmail.com> wrote:

>
> Hi all
>
> I'd really appreciate any kind help. I've spent many hours on this
> issue and yet to have a solution. I've searched forums (including
> this) and google. I'm a newbie to reviewboard so please bear with me.
> Here's my problem
>
> I'm running lighttpd and fastcgi. reviewboard can run fine through the
> manage.py command. But I need to run it thru lighttpd so I copied
> lighttpd.conf file from conf/ folder to my lighttpd config folder.
> When browsing, it gives me this error regardless of what link I click:
>
> "
> The page you were looking for does not exist.
>
> If you're pretty sure this page does exist, try logging in and trying
> again.
> "
>
> I could see reviewboard's logo and other links. (you may try visiting
> codereview.lionsoftwaresolutions.com to see what it's like)
>
> My config file:
> [code]
> server.modules += (
>    "mod_auth",
>    "mod_access",
>    "mod_rewrite",
>    "mod_expire",
>    "mod_fastcgi",
>    "mod_alias",
>    "mod_accesslog",
>    "mod_compress",
> )
>
> $HTTP["host"] =~ "codereview\.lionsoftwaresolutions\.com" {
>    # This is not used directly, it is superceded by our aliases
> below.
>    server.document-root = "/home/lss/
> codereview.lionsoftwaresolutions.com/htdocs"
>    server.errorlog      = "/home/lss/
> codereview.lionsoftwaresolutions.com/logs/lighttpd-error.log"
>    accesslog.filename   = "/home/lss/
> codereview.lionsoftwaresolutions.com/logs/lighttpd-access.log"
>
>    fastcgi.server = (
>        "/reviewboard.fcgi" => (
>            "main" => (
>                "bin-path" => "/home/lss/
> codereview.lionsoftwaresolutions.com/htdocs/reviewboard.fcgi",
>                "socket" => "/tmp/rb-fastcgi.sock",
>                "check-local" => "disable",
>            )
>        ),
>    )
>
>    alias.url = (
>        "/media" => "/home/lss/codereview.lionsoftwaresolutions.com/
> htdocs/media <http://codereview.lionsoftwaresolutions.com/%0Ahtdocs/media>
> ",
>        "/errordocs" => "/home/lss/
> codereview.lionsoftwaresolutions.com/htdocs/errordocs",
>    )
>
>    url.rewrite-once = (
>        "^(/media/.*)$" => "$1",
>        "^(/errordocs/.*)$" => "$1",
>        "^(/.*)$" => "/reviewboard.fcgi$1",
>    )
>
>    # Aggressively cache all static files
>    $HTTP["url"] =~ "\.(jpg|gif|png|css|js|htc)" {
>        expire.url = ( "" => "access 1 years" )
>    }
>
>
>    # Compress files for faster transfer
>    compress.filetype = (
>        "text/plain",
>        "text/html",
>        "text/javascript",
>        "text/css",
>        "text/xml"
>    )
>    compress.cache-dir = "/home/lss/
> codereview.lionsoftwaresolutions.com/tmp/"
>
>
>    mimetype.assign = (
>        ".gif"  => "image/gif",
>        ".jpg"  => "image/jpeg",
>        ".jpeg" => "image/jpeg",
>        ".ico"  => "image/png",
>        ".png"  => "image/png",
>        ".pdf"  => "application/pdf",
>        ".gz"   => "application/x-gzip",
>        ".css"  => "text/css",
>        ".html" => "text/html",
>        ".htm"  => "text/html",
>        ".txt"  => "text/plain",
>        ".js"   => "text/javascript",
>    )
> }
> [/code]
>
> My reviewboard.fcgi :
> [code]
> #!/usr/bin/env python
>
> import os, sys
>
> sys.path.insert(0, "/home/lss/codereview.lionsoftwaresolutions.com/
> conf")
> os.environ["DJANGO_SETTINGS_MODULE"] = "reviewboard.settings"
> os.environ["PYTHON_EGG_CACHE"] = "/home/lss/
> codereview.lionsoftwaresolutions.com/tmp/egg_cache"
>
> from django.core.servers.fastcgi import runfastcgi
> runfastcgi(method="threaded", daemonize="false")
> [/code]
>
> *I don't know where reviewboard.settings resides though.
>
> and here's my settings_local.py
> # Site-specific configuration settings for Review Board
> # Definitions of these settings can be found at
> # http://docs.djangoproject.com/en/dev/ref/settings/
>
> # Database configuration
> DATABASE_ENGINE = 'mysql'
> DATABASE_NAME = '<deleted when posting>'
> DATABASE_USER = '<deleted when posting>'
> DATABASE_PASSWORD = '<deleted when posting>'
> DATABASE_HOST = 'localhost'
> DATABASE_PORT = ''
>
> # Unique secret key. Don't share this with anybody.
> SECRET_KEY = '<deleted when posting>'
>
> # Cache backend settings.
> CACHE_BACKEND = 'memcached://localhost:11211/'
>
> # Extra site information.
> SITE_ID = 1
> SITE_ROOT = '/'
> FORCE_SCRIPT_NAME = '/'
> DEBUG = False
>
> ReviewBoard is installed at:
> $ ls /usr/lib/python2.4/site-packages/ReviewBoard-1.0beta2-py2.4.egg/
> EGG-INFO/    reviewboard/
>
> Please help! Thanks in advance.
> Joseph
> >
>

--~--~---------~--~----~------------~-------~--~----~
You received this message because you are subscribed to the Google Groups 
"reviewboard" group.
To post to this group, send email to reviewboard@googlegroups.com
To unsubscribe from this group, send email to 
reviewboard+unsubscr...@googlegroups.com
For more options, visit this group at 
http://groups.google.com/group/reviewboard?hl=en
-~----------~----~----~----~------~----~------~--~---

Reply via email to