Hi ,

I've been using post-review tool for posting reviews for Review Board
for a Perforce Repository. I've integrated the post-review tool into
P4V which is the GUI P4 Client For Windows. This worked fine till now.

But now i've created a new workspace and tried using post-review, but
the diff didn't fetch the file from my hard disk. It was fetching the
correct file from Repository, but not finding the correct edited file
on my Workspace.

I ran post-review with -d flag to get the debug logs and i noticed
that the path on the Workspace that the diff was trying to fetch was
completely wrong:

 diff -urNp c:\docume~1\rpius\locals~1\temp\tmpr_q3cf Transfer/

It should have been:

diff -urNp c:\docume~1\rpius\locals~1\temp\tmpr_q3cf C:\Unicode\jordan-
unicode\host\src\Assisted File Transfer/ConfigReader.cpp

I'm using post-review with the following arguments in the P4V Client:

python C:\Python26\post-review.py %c --p4-client $c --p4-port $p

Do i need to change something in the post-review Configuration for the
new workspace ?

You received this message because you are subscribed to the Google Groups 
"reviewboard" group.
To post to this group, send email to reviewboard@googlegroups.com
To unsubscribe from this group, send email to 
For more options, visit this group at 

Reply via email to