The e-mail settings being lost sounds like an issue we just fixed in a
nightly. If you set the e-mail settings and then restart your web server, do
they still disappear?

It's hard to say what's wrong with your e-mail settings. Can you check your
web server's error log and see if there's any backtraces?

Christian

-- 
Christian Hammond - chip...@chipx86.com
Review Board - http://www.review-board.org
VMware, Inc. - http://www.vmware.com


On Mon, Apr 13, 2009 at 4:07 PM, Ritesh Nadhani <rite...@gmail.com> wrote:

>
> Hello
>
> So I created 3 users and added them to default reviewer group. I then
> went to Admin section and added the Email settings. I added my gmail
> settings and checking use TLS authentication.
>
> According to docs at
>
> http://www.review-board.org/docs/manual/dev/admin/management/review-groups/#e-mail-and-review-groups
> ,
> since I dont have any mailing list attached to the repository so it
> will send mail to everybody in the review board.
>
> After doing the email settings, I went ahead and added a request. For
> some reason, the process got stuck when I click on Publish. The
> buttons are greyed out and nothing happened. Clicking on "View Diff"
> threw up some error for microsecond which I could not read. Then the
> publish/discard publish were gone and the patch was correctly
> submitted.
>
> Hoping that the mail was sent, I check my inbox and nothing there.
>
> I repeat the process using the same patch and test and same errors. I
> could not read the error :(
>
> Suddenly, it worked. But no mails. I went and checked the email
> settings and BAM and everything was gone. The settings were changed to
> the default localhost and port 25. Hmm.
>
> I edited the settings and tried to repeat the process and same thing.
> First 3-4 times (though I could not repeat the exact number of times)
> will give you an error (which will only stay for couple of
> microseconds and go off). Then suddenly it works and the email
> settings are lost.
>
> Setting the debug value to True as suggested at:
>
> http://groups.google.com/group/reviewboard/browse_thread/thread/42fd2fd6ee5285bd?pli=1
>
> Nothing special happened except that the error stayed for some more
> time and I was able to catch a  glimpse:
>
> Publishing of the draft has failed for some reason Error 0 (i think).
>
> Please contact your admin.
>
> If I go and remove the email, then everything works.
>
> Any idea how I can debug this problem?
>
> --
> Ritesh
> http://www.riteshn.com
>
> >
>

--~--~---------~--~----~------------~-------~--~----~
You received this message because you are subscribed to the Google Groups 
"reviewboard" group.
To post to this group, send email to reviewboard@googlegroups.com
To unsubscribe from this group, send email to 
reviewboard+unsubscr...@googlegroups.com
For more options, visit this group at 
http://groups.google.com/group/reviewboard?hl=en
-~----------~----~----~----~------~----~------~--~---

Reply via email to