Sorry for the late reply on this.

Give the latest RBTools nightlies a try (
http://downloads.review-board.org/nightlies/). I believe this bug is fixed
there.

I'll try to get a release out somewhat soon.

Christian

-- 
Christian Hammond - chip...@chipx86.com
Review Board - http://www.review-board.org
VMware, Inc. - http://www.vmware.com


On Tue, Jun 2, 2009 at 6:34 AM, mmorgan <mmor...@buzanonline.com> wrote:

>
> Hi,
>
> I pretty new to review board, but want to say firstly it is a great
> tool so keep up the good work!
> Ive managed to set up review board on my windows server, which also
> hosts my svn repository.
> Ive decided to try to get post-review set up so that we can
> automatically create reviews from the svn hooks, but im having a bit
> of trouble getting it to work.
> I apologise in advance if someone has answered the same question, ive
> search everywhere in the discussion groups but haven't had any luck
> finding an answer!
>
> Currently I have python and difftools all installed, and installed
> post-review as per the instructions using "easy_install -U RBTools",
> which seems to work. I have created a .bat file just to see if i can
> get post-review working before trying to get it working with the svn
> hooks. When i run the following from my .bat file:
>
> C:\Python25\Scripts>C:\Python25\python.exe C:\Python25\Scripts\post-
> review --repository-url==https://REPO_IP/svn/prototype --revision-
> range=r533:r534 --server=http://127.0.0.1:8080 --username=admin --
> password=rbAdminPass --debug
>
> I get the following error dump:
>
> >>> svn info =https://REPO_IP/svn/prototype
> >>> cleartool pwv -short
> Traceback (most recent call last):
>  File "C:\Python25\Scripts\post-review", line 5, in <module>
>    pkg_resources.run_script('rbtools==0.2beta1', 'post-review')
>  File "C:\Python25\Lib\site-packages\pkg_resources.py", line 448, in
> run_script
>    self.require(requires)[0].run_script(script_name, ns)
>  File "C:\Python25\Lib\site-packages\pkg_resources.py", line 1173, in
> run_script
>    exec script_code in namespace, namespace
>  File "C:\Python25\Scripts\post-review", line 2313, in <module>
>  File "C:\Python25\Scripts\post-review", line 2254, in main
>  File "C:\Python25\Scripts\post-review", line 2206, in
> determine_client
>  File "C:\Python25\Scripts\post-review", line 744, in
> get_repository_info
>  File "C:\Python25\Scripts\post-review", line 1889, in execute
>  File "C:\Python25\Lib\subprocess.py", line 594, in __init__
>    errread, errwrite)
>  File "C:\Python25\Lib\subprocess.py", line 822, in _execute_child
>    startupinfo)
> WindowsError: [Error 2] The system cannot find the file specified
>
> Any help would be much appreciated!
>
> Thanks
> >
>

--~--~---------~--~----~------------~-------~--~----~
You received this message because you are subscribed to the Google Groups 
"reviewboard" group.
To post to this group, send email to reviewboard@googlegroups.com
To unsubscribe from this group, send email to 
reviewboard+unsubscr...@googlegroups.com
For more options, visit this group at 
http://groups.google.com/group/reviewboard?hl=en
-~----------~----~----~----~------~----~------~--~---

Reply via email to