It says (with the ip replaced):

>>> svn info
>>> hg root
>>> hg svn info
>>> repository info: Path: http://12.345.678.912/hg, Base path: , Supports 
>>> changesets: False
>>> hg diff -r 8e4c07f8e1b8 -r tip
>>> Looking for '12.345.678.912 /reviews/' cookie in 
>>> /home/dportnoy/.post-review-cookies.txt
>>> Loaded valid cookie -- no login required
>>> Attempting to create review request for None
>>> HTTP POSTing to http://12.345.678.912/reviews/api/json/reviewrequests/new/: 
>>> {'repository_path': 'http://12.345.678.912/hg'}
Error creating review request: The repository path specified is not in
the list of known repositories (code 206)

Looks like the repo path it tries to use is http://12.345.678.912/hg ,
even though the repo I'm using the command from is actually
http://12.345.678.912/hg/dportnoy

On Jun 25, 12:25 am, Christian Hammond <chip...@chipx86.com> wrote:
> Can you run post-review with --debug?
>
> Christian
>
> --
> Christian Hammond - chip...@chipx86.com
> Review Board -http://www.review-board.org
> VMware, Inc. -http://www.vmware.com
>
> On Wed, Jun 24, 2009 at 9:23 PM, Dmitry Portnoy <dmp1...@gmail.com> wrote:
>
> > 'hg root' exactly matches the Path entry for the repo on the server.
>
> > On Jun 25, 12:11 am, Christian Hammond <chip...@chipx86.com> wrote:
> > > Hi,
>
> > > The result of 'hg root' needs to match either the Path or Mirror Path
> > > entries for the Repository on the server in order to work. You'll want to
> > > make sure they're identical.
>
> > > Christian
>
> > > --
> > > Christian Hammond - chip...@chipx86.com
> > > Review Board -http://www.review-board.org
> > > VMware, Inc. -http://www.vmware.com
>
> > > On Wed, Jun 24, 2009 at 8:56 PM, Dmitry Portnoy <dmp1...@gmail.com>
> > wrote:
>
> > > > I'm trying to get post-review working, but whenever I run it, I get
> > > > "Error creating review request: The repository path specified is not
> > > > in the list of known repositories (code 206)".
>
> > > > The exact command I run is:
>
> > > >  post-review --username=XXX --password=XXX --server=XXX --revision-
> > > > range=XXX:XXX
>
> > > > I run the command from inside the base directory of an hg repo and the
> > > > server address is a url, not a local path. Any help would be
> > > > appreciated.
--~--~---------~--~----~------------~-------~--~----~
You received this message because you are subscribed to the Google Groups 
"reviewboard" group.
To post to this group, send email to reviewboard@googlegroups.com
To unsubscribe from this group, send email to 
reviewboard+unsubscr...@googlegroups.com
For more options, visit this group at 
http://groups.google.com/group/reviewboard?hl=en
-~----------~----~----~----~------~----~------~--~---

Reply via email to