How did you install Review Board itself? It sounds like it didn't end up in
bitnami's Python path.

Christian

-- 
Christian Hammond - chip...@chipx86.com
Review Board - http://www.review-board.org
VMware, Inc. - http://www.vmware.com


On Fri, Jul 10, 2009 at 1:40 PM, wezyde <wes.bill...@gmail.com> wrote:

>
> I'm trying to install reviewboard on a djangostack from Bitnami.
> Currently, I'm getting the Review Board is taking a nap page.
>
> I did a "rb-site install ..." to apache2/htdocs/review.  All the files
> are present there now and I have modified httpd.conf to Include apache-
> modpython.conf.
>
> Here is my current configuration...
>
> <VirtualHost *:8089>
>        ServerName firmwarebackup
>        DocumentRoot "C:/Program Files/BitNami DjangoStack/apache2/htdocs/
> review/htdocs"
>
>        # Error handlers
>        ErrorDocument 500 /errordocs/500.html
>
>        # Serve django pages
>        <Location "/">
>                PythonPath "['C:/Program Files/BitNami
> DjangoStack/apache2/htdocs/
> review/conf'] + sys.path"
>                SetEnv DJANGO_SETTINGS_MODULE reviewboard.settings
>                SetEnv PYTHON_EGG_CACHE "C:/Program Files/BitNami
> DjangoStack/
> apache2/htdocs/review/tmp/egg_cache"
>                SetHandler mod_python
>                PythonHandler django.core.handlers.modpython
>                PythonAutoReload Off
>                PythonDebug Off
>                # Used to run multiple mod_python sites in the same apache
>                PythonInterpreter reviewboard_review
>        </Location>
>
>        # Serve static media without running it through mod_python
>        # (overrides the above)
>        <Location "/media">
>                SetHandler None
>        </Location>
>        <Location "/errordocs">
>                SetHandler None
>        </Location>
>
>        <Directory "C:/Program Files/BitNami DjangoStack/apache2/htdocs/
> review/htdocs">
>                AllowOverride All
>        </Directory>
>
>        # Alias static media requests to filesystem
>        Alias /media "C:/Program Files/BitNami DjangoStack/apache2/htdocs/
> review/htdocs/media"
>        Alias /errordocs "C:/Program Files/BitNami
> DjangoStack/apache2/htdocs/
> review/htdocs/errordocs"
> </VirtualHost>
>
>
> And this is my current error.log...
>
> [Fri Jul 10 13:32:26 2009] [notice] Child 7948: Child process is
> running
> [Fri Jul 10 13:32:26 2009] [notice] Child 7948: Acquired the start
> mutex.
> [Fri Jul 10 13:32:26 2009] [notice] Child 7948: Starting 250 worker
> threads.
> [Fri Jul 10 13:32:29 2009] [error] [client 10.0.0.153] mod_python
> (pid=7948, interpreter='reviewboard_review', phase='PythonHandler',
> handler='django.core.handlers.modpython'): Application error
> [Fri Jul 10 13:32:29 2009] [error] [client 10.0.0.153] ServerName:
> 'firmwarebackup'
> [Fri Jul 10 13:32:29 2009] [error] [client 10.0.0.153] DocumentRoot:
> 'C:/Program Files/BitNami DjangoStack/apache2/htdocs/review/htdocs'
> [Fri Jul 10 13:32:29 2009] [error] [client 10.0.0.153] URI: '/'
> [Fri Jul 10 13:32:29 2009] [error] [client 10.0.0.153] Location: '/'
> [Fri Jul 10 13:32:29 2009] [error] [client 10.0.0.153] Directory: None
> [Fri Jul 10 13:32:29 2009] [error] [client 10.0.0.153] Filename: 'C:/
> Program Files/BitNami DjangoStack/apache2/htdocs/review/htdocs/'
> [Fri Jul 10 13:32:29 2009] [error] [client 10.0.0.153] PathInfo: ''
> [Fri Jul 10 13:32:29 2009] [error] [client 10.0.0.153] Traceback (most
> recent call last):
> [Fri Jul 10 13:32:29 2009] [error] [client 10.0.0.153]   File "c:\
> \progra~1\\bitnam~2\\python\\lib\\site-packages\\mod_python-3.3.1-
> py2.4-win32.egg\\mod_python\\importer.py", line 1537, in
> HandlerDispatch\n    default=default_handler, arg=req,
> silent=hlist.silent)
> [Fri Jul 10 13:32:29 2009] [error] [client 10.0.0.153]   File "c:\
> \progra~1\\bitnam~2\\python\\lib\\site-packages\\mod_python-3.3.1-
> py2.4-win32.egg\\mod_python\\importer.py", line 1229, in
> _process_target\n    result = _execute_target(config, req, object,
> arg)
> [Fri Jul 10 13:32:29 2009] [error] [client 10.0.0.153]   File "c:\
> \progra~1\\bitnam~2\\python\\lib\\site-packages\\mod_python-3.3.1-
> py2.4-win32.egg\\mod_python\\importer.py", line 1128, in
> _execute_target\n    result = object(arg)
> [Fri Jul 10 13:32:29 2009] [error] [client 10.0.0.153]   File "C:\
> \Program Files\\BitNami DjangoStack\\apps\\django\\django\\core\
> \handlers\\modpython.py", line 228, in handler\n    return
> ModPythonHandler()(req)
> [Fri Jul 10 13:32:29 2009] [error] [client 10.0.0.153]   File "C:\
> \Program Files\\BitNami DjangoStack\\apps\\django\\django\\core\
> \handlers\\modpython.py", line 191, in __call__\n
> self.load_middleware()
> [Fri Jul 10 13:32:29 2009] [error] [client 10.0.0.153]   File "C:\
> \Program Files\\BitNami DjangoStack\\apps\\django\\django\\core\
> \handlers\\base.py", line 31, in load_middleware\n    for
> middleware_path in settings.MIDDLEWARE_CLASSES:
> [Fri Jul 10 13:32:29 2009] [error] [client 10.0.0.153]   File "C:\
> \Program Files\\BitNami DjangoStack\\apps\\django\\django\\conf\
> \__init__.py", line 28, in __getattr__\n    self._import_settings()
> [Fri Jul 10 13:32:29 2009] [error] [client 10.0.0.153]   File "C:\
> \Program Files\\BitNami DjangoStack\\apps\\django\\django\\conf\
> \__init__.py", line 59, in _import_settings\n    self._target =
> Settings(settings_module)
> [Fri Jul 10 13:32:29 2009] [error] [client 10.0.0.153]   File "C:\
> \Program Files\\BitNami DjangoStack\\apps\\django\\django\\conf\
> \__init__.py", line 94, in __init__\n    raise ImportError, "Could not
> import settings '%s' (Is it on sys.path? Does it have syntax errors?):
> %s" % (self.SETTINGS_MODULE, e)
> [Fri Jul 10 13:32:29 2009] [error] [client 10.0.0.153] ImportError:
> Could not import settings 'reviewboard.settings' (Is it on sys.path?
> Does it have syntax errors?): No module named reviewboard.settings
>
> >
>

--~--~---------~--~----~------------~-------~--~----~
You received this message because you are subscribed to the Google Groups 
"reviewboard" group.
To post to this group, send email to reviewboard@googlegroups.com
To unsubscribe from this group, send email to 
reviewboard+unsubscr...@googlegroups.com
For more options, visit this group at 
http://groups.google.com/group/reviewboard?hl=en
-~----------~----~----~----~------~----~------~--~---

Reply via email to