Hmm, I'm not aware of anything changing between RC2 and 1.0 that would
affect this. Did you by any chance upgrade Django in the process? Or
anything else?

Also, just to make sure, did you run rb-site upgrade /path/to/site?

Christian

-- 
Christian Hammond - chip...@chipx86.com
Review Board - http://www.review-board.org
VMware, Inc. - http://www.vmware.com


On Wed, Jul 15, 2009 at 11:17 AM, Paolo Borelli <paolo.bore...@gmail.com>wrote:

>
> Hi,
>
>        I am trying to install reviewboard so that pages get served from
> something like
>
> http://dev.mycompany.com/reviews
>
> And when I installed rc2 some time ago it was working correctly.
>
> Today I upgraded to 1.0 after the machine running rb was brought back up
> (it was down for some days) and rb does not work anymore: rb is up, but
> I get the following message
>
> "If you're pretty sure this page does exist, try logging in and trying
> again."
>
> If you click on "logging in" you are directed to
>
> http://dev.mycompany.com/reviews/reviews/account/login/
>
> (note the double 'reviews')
>
> As far as I know nothing else changed on the machine.
>
> Do you have any suggestion on how to achieve that and on why this
> stopped working after the upgrade?
>
> here is the relevant apache config I am using:
>
> ========================================
> ...
>        # ReviewBoard customization
>
>        # Serve django pages
>        <Location /reviews/>
>                PythonPath "['/var/www/reviews/conf'] + sys.path"
>                SetEnv DJANGO_SETTINGS_MODULE reviewboard.settings
>                SetEnv PYTHON_EGG_CACHE "/var/www/reviews/tmp/egg_cache"
>                SetHandler mod_python
>                PythonHandler django.core.handlers.modpython
>                PythonAutoReload Off
>                PythonDebug Off
>                # Used to run multiple mod_python sites in the same apache
>                PythonInterpreter reviewboard_reviewboard
>        </Location>
>
>        # Serve static media without running it through mod_python
>        # (overrides the above)
>        <Location "/reviews/media">
>                SetHandler None
>        </Location>
>        <Location "/reviews/errordocs">
>                SetHandler None
>        </Location>
>
>        <Directory "/var/www/reviews/htdocs">
>                AllowOverride All
>        </Directory>
>
>        # Alias static media requests to filesystem
>        Alias /reviews/media "/var/www/reviews/htdocs/media"
>        Alias /reviews/errordocs "/var/www/reviews/htdocs/errordocs"
> ...
> ========================================
>
>
> and in settings_local.py I have
>
> SITE_ROOT = '/reviews/'
>
>
>
> Thanks
>
>        Paolo
>
>
> >
>

--~--~---------~--~----~------------~-------~--~----~
You received this message because you are subscribed to the Google Groups 
"reviewboard" group.
To post to this group, send email to reviewboard@googlegroups.com
To unsubscribe from this group, send email to 
reviewboard+unsubscr...@googlegroups.com
For more options, visit this group at 
http://groups.google.com/group/reviewboard?hl=en
-~----------~----~----~----~------~----~------~--~---

Reply via email to