Hi,

The problem seems to be the DJANGO_SETTINGS_MODULE line. Change the value to
reviewboard.settings.

Christian

-- 
Christian Hammond - chip...@chipx86.com
Review Board - http://www.review-board.org
VMware, Inc. - http://www.vmware.com


On Mon, Aug 3, 2009 at 3:05 AM, dmpub...@gmail.com <dmpub...@gmail.com>wrote:

>
> Hi
>
> I have a problem with installing ReviewBoard on window 2003. I
> installed all necessary dependencies according to the Administration
> Guide.when i tried to open  (http://localhost/argosboard.com) in
> firefox , it shows 500.html (reviewboard is taking a nap page ).Please
> some one help me to setting up the reviewboard.
>
> here is the apache virtual host entry
>
> <VirtualHost *:80>
>
>        ServerName argosboard.com
>
>        DocumentRoot "C:/memcached/argosboard.com/htdocs"
>
>
>
>        # Error handlers
>
>        ErrorDocument 500 /errordocs/500.html
>
>
>
>        # Serve django pages
>
>        <Location "/">
>
>                PythonPath "['C:/memcached/argosboard.com/conf'] +
> sys.path"
>
>                SetEnv DJANGO_SETTINGS_MODULE argosboard.com.settings
>
>                SetEnv PYTHON_EGG_CACHE "C:/memcached/
> argosboard.com/tmp/egg_cache"
>
>                SetHandler mod_python
>
>                PythonHandler django.core.handlers.modpython
>
>                PythonAutoReload Off
>
>                PythonDebug Off
>
>                # Used to run multiple mod_python sites in the same apache
>
>                PythonInterpreter reviewboard_argosboard_com
>
>        </Location>
>
>
>
>        # Serve static media without running it through mod_python
>
>        # (overrides the above)
>
>        <Location "/media">
>
>                SetHandler None
>
>        </Location>
>
>        <Location "/errordocs">
>
>                SetHandler None
>
>        </Location>
>
>
>
>        <Directory "C:/memcached/argosboard.com/htdocs">
>
>                AllowOverride All
>
>        </Directory>
>
>
>
>        # Alias static media requests to filesystem
>
>        Alias /media "C:/memcached/argosboard.com/htdocs/media"
>
>        Alias /errordocs "C:/memcached/argosboard.com/htdocs/errordocs"
>
> </VirtualHost>
>
>
>
>  What the Apache log says is....
>
>
> [Mon Aug 03 15:23:14 2009] [notice] Apache/2.0.63 (Win32) SVN/1.4.5
> DAV/2 configured -- resuming normal operations
>
> [Mon Aug 03 15:23:14 2009] [notice] Server built: Jan 17 2008 22:58:29
>
> [Mon Aug 03 15:23:14 2009] [notice] Parent: Created child process 2044
>
> [Mon Aug 03 15:23:15 2009] [error] python_init: Python version
> mismatch, expected '2.5', found '2.5.4'.
>
> [Mon Aug 03 15:23:15 2009] [error] python_init: Python executable
> found 'C:\\Program Files\\Apache Group\\Apache2\\bin\\Apache.exe'.
>
> [Mon Aug 03 15:23:15 2009] [error] python_init: Python path being used
> 'C:\\WINDOWS\\system32\\python25.zip;C:\\Python25\\Lib;C:\\Python25\
> \DLLs;C:\\Python25\\Lib\\lib-tk;;C:\\Program Files\\Apache Group\
> \Apache2\\bin'.
>
> [Mon Aug 03 15:23:15 2009] [notice] mod_python: Creating 8 session
> mutexes based on 0 max processes and 250 max threads.
>
> [Mon Aug 03 15:23:15 2009] [notice] Child 2044: Child process is
> running
>
> [Mon Aug 03 15:23:15 2009] [notice] Child 2044: Acquired the start
> mutex.
>
> [Mon Aug 03 15:23:15 2009] [notice] Child 2044: Starting 250 worker
> threads.
>
> [Mon Aug 03 15:23:21 2009] [error] [client 127.0.0.1] mod_python
> (pid=2044, interpreter='reviewboard_argosboard_com',
> phase='PythonHandler', handler='django.core.handlers.modpython'):
> Application error
>
> [Mon Aug 03 15:23:21 2009] [error] [client 127.0.0.1] ServerName:
> 'argosboard.com'
>
> [Mon Aug 03 15:23:21 2009] [error] [client 127.0.0.1] DocumentRoot:
> 'C:/memcached/argosboard.com/htdocs'
>
> [Mon Aug 03 15:23:21 2009] [error] [client 127.0.0.1] URI: '/
> argosboard.com'
>
> [Mon Aug 03 15:23:21 2009] [error] [client 127.0.0.1] Location: '/'
>
> [Mon Aug 03 15:23:21 2009] [error] [client 127.0.0.1] Directory: None
>
> [Mon Aug 03 15:23:21 2009] [error] [client 127.0.0.1] Filename: 'C:/
> memcached/argosboard.com/htdocs/argosboard.com'
>
> [Mon Aug 03 15:23:21 2009] [error] [client 127.0.0.1] PathInfo: ''
>
> [Mon Aug 03 15:23:21 2009] [error] [client 127.0.0.1] Traceback (most
> recent call last):
>
> [Mon Aug 03 15:23:21 2009] [error] [client 127.0.0.1]   File "C:\
> \Python25\\Lib\\site-packages\\mod_python\\importer.py", line 1537, in
> HandlerDispatch\n    default=default_handler, arg=req,
> silent=hlist.silent)
>
> [Mon Aug 03 15:23:21 2009] [error] [client 127.0.0.1]   File "C:\
> \Python25\\Lib\\site-packages\\mod_python\\importer.py", line 1229, in
> _process_target\n    result = _execute_target(config, req, object,
> arg)
>
> [Mon Aug 03 15:23:21 2009] [error] [client 127.0.0.1]   File "C:\
> \Python25\\Lib\\site-packages\\mod_python\\importer.py", line 1128, in
> _execute_target\n    result = object(arg)
>
> [Mon Aug 03 15:23:21 2009] [error] [client 127.0.0.1]   File "c:\
> \python25\\lib\\site-packages\\django-1.1-py2.5.egg\\django\\core\
> \handlers\\modpython.py", line 228, in handler\n    return
> ModPythonHandler()(req)
>
> [Mon Aug 03 15:23:21 2009] [error] [client 127.0.0.1]   File "c:\
> \python25\\lib\\site-packages\\django-1.1-py2.5.egg\\django\\core\
> \handlers\\modpython.py", line 191, in __call__\n
> self.load_middleware()
>
> [Mon Aug 03 15:23:21 2009] [error] [client 127.0.0.1]   File "c:\
> \python25\\lib\\site-packages\\django-1.1-py2.5.egg\\django\\core\
> \handlers\\base.py", line 33, in load_middleware\n    for
> middleware_path in settings.MIDDLEWARE_CLASSES:
>
> [Mon Aug 03 15:23:21 2009] [error] [client 127.0.0.1]   File "c:\
> \python25\\lib\\site-packages\\django-1.1-py2.5.egg\\django\\utils\
> \functional.py", line 269, in __getattr__\n    self._setup()
>
> [Mon Aug 03 15:23:21 2009] [error] [client 127.0.0.1]   File "c:\
> \python25\\lib\\site-packages\\django-1.1-py2.5.egg\\django\\conf\
> \__init__.py", line 40, in _setup\n    self._wrapped = Settings
> (settings_module)
>
> [Mon Aug 03 15:23:21 2009] [error] [client 127.0.0.1]   File "c:\
> \python25\\lib\\site-packages\\django-1.1-py2.5.egg\\django\\conf\
> \__init__.py", line 75, in __init__\n    raise ImportError, "Could not
> import settings '%s' (Is it on sys.path? Does it have syntax errors?):
> %s" % (self.SETTINGS_MODULE, e)
>
> [Mon Aug 03 15:23:21 2009] [error] [client 127.0.0.1] ImportError:
> Could not import settings 'argosboard.com.settings' (Is it on
> sys.path? Does it have syntax errors?): No module named
> argosboard.com.settings
>
>
> Thanks.
>
> Pubudu
>
> >
>

--~--~---------~--~----~------------~-------~--~----~
You received this message because you are subscribed to the Google Groups 
"reviewboard" group.
To post to this group, send email to reviewboard@googlegroups.com
To unsubscribe from this group, send email to 
reviewboard+unsubscr...@googlegroups.com
For more options, visit this group at 
http://groups.google.com/group/reviewboard?hl=en
-~----------~----~----~----~------~----~------~--~---

Reply via email to