One more thing, does this mean something wrong with the client side or
the server side? I have 2 clients and they behave the same.

On Aug 7, 9:38 am, chihangid <chihan...@gmail.com> wrote:
> Hi Christian,
>
> after I add the debig(data), it's printing some characters that
> doesn't make sense. Looks like reading some binary file.
>
> Here is what I did:
>     def process_json(self, data):
>         """
>         Loads in aJSONfile and returns the data if successful. On
> failure,
>         APIError is raised.
>         """
>         debug(data)
>         rsp = simplejson.loads(data)
>
>         if rsp['stat'] == 'fail':
>             raise APIError, rsp
>
>         return rsp
>
> Thanks,
> Steven
>
> On Aug 6, 4:53 pm, Christian Hammond <chip...@chipx86.com> wrote:
>
> > Well.. That's new.
>
> > We need more debugging information in order to figure this out. This will
> > require manually editing the post-review script.
>
> > First, you'll need to locate the post-review.py file you installed (I assume
> > you installed via easy_install RBTools, in which case it's in going to be in
> > a site-packages/RBTools-*/scripts directory somewhere).
>
> > Then locate the process_json function (def process_json(self, data):).
>
> > Before the "rsp =json.loads(data)" function, add:
>
> >         debug(data)
>
> > Make sure to use spaces for indentation.
>
> > Then try again, and there should be more debugging information.
>
> > Christian
>
> > --
> > Christian Hammond - chip...@chipx86.com
> > Review Board -http://www.review-board.org
> > VMware, Inc. -http://www.vmware.com
>
> > On Thu, Aug 6, 2009 at 3:42 PM, chihangid <chihan...@gmail.com> wrote:
>
> > > I am using post-review to create a review. I did not change anything
> > > on the server and it suddenly stops working.
>
> > > Here is the log with --debug on, I am using perforce. Any idea what
> > > went wrong?
>
> > > C:\singe\depot>python post-review 36074 --debug
> > > >>> p4 info
> > > >>> repository info: Path: XXXX:1666, Base path: None, Supports 
> > > >>> changesets:
> > > True
> > > >>> p4 counters
> > > >>> Generating diff for changenum 36074
> > > >>> p4 describe -s 36074
> > > >>> Processing edit of //depot/wcm/dev/releng/1
> > > >>> Writing "//depot/wcm/dev/releng/1#25" to
> > > "c:\docume~1\XXXX\locals~1\temp\tmpeuzeqx"
> > > >>> p4 print -q //depot/wcm/dev/releng/1#25
> > > >>> p4 where //depot/wcm/dev/releng/1
> > > >>> diff -urNp c:\docume~1\XXXX\locals~1\temp\tmpeuzeqx
> > > c:\singe\depot\wcm\dev\releng\1
> > > >>> Looking for 'pfwebal01 /' cookie in C:\Documents and
> > > Settings\XXXX\Local Settings\Application Data\.post-review-cookies.txt
> > > >>> Cookie file loaded, but no cookie for this server
> > > ==> Review Board Login Required
> > > Enter username and password for Review Board athttp://XXXX/
> > > Username: XXXX
> > > Password:
> > > >>> Logging in with username "XXXX"
> > > >>> HTTP POSTing tohttp://XXXX/api/json/accounts/login/:{'username':
> > > XXXX, 'password': '**************'}
> > > >>> Logged in.
> > > >>> Attempting to create review request for 36074
> > > >>> HTTP POSTing tohttp://XXXX/api/json/reviewrequests/new/:
> > > {'repository_path': XXXX:1666', 'ch
> > > angenum': '36074'}
> > > Traceback (most recent call last):
> > >  File "post-review", line 5, in <module>
> > >    pkg_resources.run_script('rbtools==0.2beta1', 'post-review')
> > >  File "C:\Python25\Lib\site-packages\pkg_resources.py", line 448, in
> > > run_script
> > >    self.require(requires)[0].run_script(script_name, ns)
> > >  File "C:\Python25\Lib\site-packages\pkg_resources.py", line 1173, in
> > > run_script
> > >    exec script_code in namespace, namespace
> > >  File "C:\singe\depot\post-review", line 2313, in <module>
>
> > >  File "C:\singe\depot\post-review", line 2295, in main
>
> > >  File "C:\singe\depot\post-review", line 1965, in tempt_fate
>
> > >  File "C:\singe\depot\post-review", line 372, in new_review_request
>
> > >  File "C:\singe\depot\post-review", line 569, in api_post
>
> > >  File "C:\singe\depot\post-review", line 480, in process_json
>
> > >  File "C:\Python25\lib\site-packages\simplejson-2.0.9-py2.5-win32.egg
> > > \simplejson\__init__.py", line 307, in loads
> > >  File "C:\Python25\lib\site-packages\simplejson-2.0.9-py2.5-win32.egg
> > > \simplejson\decoder.py", line 335, in decode
> > >  File "C:\Python25\lib\site-packages\simplejson-2.0.9-py2.5-win32.egg
> > > \simplejson\decoder.py", line 353, in raw_decode
> > > ValueError: NoJSONobject could be decoded
--~--~---------~--~----~------------~-------~--~----~
You received this message because you are subscribed to the Google Groups 
"reviewboard" group.
To post to this group, send email to reviewboard@googlegroups.com
To unsubscribe from this group, send email to 
reviewboard+unsubscr...@googlegroups.com
For more options, visit this group at 
http://groups.google.com/group/reviewboard?hl=en
-~----------~----~----~----~------~----~------~--~---

Reply via email to