Hi Dan,

Are you guys behind a proxy server, by any chance? I could see that
potentially causing this to fail.

What do you have listed in your e-mail settings for Review Board?


Christian Hammond - chip...@chipx86.com
Review Board - http://www.review-board.org
VMware, Inc. - http://www.vmware.com

On Tue, Sep 8, 2009 at 8:13 AM, Dan Myung <dmy...@dimagi.com> wrote:

> I've got 1.0.1 setup on my Ubuntu box, and seem to have trouble with
> the email settings.
> I've input all the TLS settings for gmail smtp using a email in our
> hosted account, setup all the TLS and ports for it.
> However, whenever we try to submit/publish a new review request, the
> publish spinny just spins indefinitely.
> For kicks, I tried to run the email code from the command line:
> from reviewboard.reviews import email
> from reviewboard.reviews.models import *
> from django.contrib.auth.models import User #our admin user with a
> valid email address
> email.send_review_email(User.objects.all()[0],
> ReviewRequest.objects.all()[0], 'test email from command
> line','m...@emaildomain.com', [], 'reviews/review_request_email.txt')
> When I first ran it, it would fail because it would be trying to find
> email login/server information from the django settings, which is
> consistent with the EMAIL_* settings builtin to django (http://
> docs.djangoproject.com/en/dev/ref/settings/#email-host) that the
> standard email API will try to call.  Because those settings don't
> exist in the settings, it tries to default use localhost smtp which is
> not installed on the box.
> What confuses me is why the settings I just set in the review admin is
> completely ignored.
> Seeking a workaround, I manually set all the django EMAIL_* settings
> and the above command line code worked to send an email out.
> Once the settings were manually set, I went back to the web interface
> to try a new submit, but I got the same spinning Loading indicator
> that spins indefinitely.
> So far, we've never gotten a single review request submission ever to
> email out from the web interface.  Any suggestions on how to get our
> email alerts going out?
> >

You received this message because you are subscribed to the Google Groups 
"reviewboard" group.
To post to this group, send email to reviewboard@googlegroups.com
To unsubscribe from this group, send email to 
For more options, visit this group at 

Reply via email to