We actually got it working.  To make a long story short, I was using
the wrong gmail smtp port (587 good, 465 bad).  I'm putting our full
thought process down just in case it might be useful.

No proxy in our network.  The host has a direct route out.  Clients
accessing it directly also have no machinery between it.

on the email settings tab we got:

server: smtp.gmail.com
port: 465
username: rev...@dimagi.com

use TLS is checked.

When i ran the command (which is send_review_mail, not
send_review_email as i have in error in the original post), here's the

Traceback (most recent call last):
  File "<console>", line 1, in <module>
  File "/usr/local/lib/python2.6/dist-packages/ReviewBoard-1.0.1-
py2.6.egg/reviewboard/reviews/email.py", line 114, in send_review_mail
  File "/usr/local/lib/python2.6/dist-packages/Django-1.0.2_final-
py2.6.egg/django/core/mail.py", line 271, in send
    return self.get_connection(fail_silently).send_messages([self])
  File "/usr/local/lib/python2.6/dist-packages/Django-1.0.2_final-
py2.6.egg/django/core/mail.py", line 166, in send_messages
    new_conn_created = self.open()
  File "/usr/local/lib/python2.6/dist-packages/Django-1.0.2_final-
py2.6.egg/django/core/mail.py", line 131, in open
  File "/usr/lib/python2.6/smtplib.py", line 239, in __init__
    (code, msg) = self.connect(host, port)
  File "/usr/lib/python2.6/smtplib.py", line 295, in connect
    self.sock = self._get_socket(host, port, self.timeout)
  File "/usr/lib/python2.6/smtplib.py", line 273, in _get_socket
    return socket.create_connection((port, host), timeout)
  File "/usr/lib/python2.6/socket.py", line 512, in create_connection
    raise error, msg
error: [Errno 111] Connection refused

Upon testing some more, I was actually able to get it working
actually.  Turns out port 465 was the culprit actually for the hanging
loading on the web interface.  My command line testing with the
local_settings.py worked fine with port 587, and I didn't bother to
test 465 from the command line, which reproduced a hanging state from
the command line.

So, I cleared the settings.EMAIL_* properties to let reviewboard work
as native, and the web interface worked as expected.

I then tried the command line email again, and was able to reproduce
the same exception.  How are the email settings loaded when an email
is initiated from the web interface, as it differs from the command
line.  We are interested in this because we'd like some additional
emails to go out on comments and such, and thought we might just run
the email code ourselves via some signal or something.


On Sep 8, 7:09 pm, Christian Hammond <chip...@chipx86.com> wrote:
> Hi Dan,
> Are you guys behind a proxy server, by any chance? I could see that
> potentially causing this to fail.
> What do you have listed in your e-mail settings for Review Board?
> Christian
> --
> Christian Hammond - chip...@chipx86.com
> Review Board -http://www.review-board.org
> VMware, Inc. -http://www.vmware.com
> On Tue, Sep 8, 2009 at 8:13 AM, Dan Myung <dmy...@dimagi.com> wrote:
> > I've got 1.0.1 setup on my Ubuntu box, and seem to have trouble with
> > the email settings.
> > I've input all the TLS settings for gmail smtp using a email in our
> > hosted account, setup all the TLS and ports for it.
> > However, whenever we try to submit/publish a new review request, the
> > publish spinny just spins indefinitely.
> > For kicks, I tried to run the email code from the command line:
> > from reviewboard.reviews import email
> > from reviewboard.reviews.models import *
> > from django.contrib.auth.models import User #our admin user with a
> > valid email address
> > email.send_review_email(User.objects.all()[0],
> > ReviewRequest.objects.all()[0], 'test email from command
> > line','....@emaildomain.com', [], 'reviews/review_request_email.txt')
> > When I first ran it, it would fail because it would be trying to find
> > email login/server information from the django settings, which is
> > consistent with the EMAIL_* settings builtin to django (http://
> > docs.djangoproject.com/en/dev/ref/settings/#email-host) that the
> > standard email API will try to call.  Because those settings don't
> > exist in the settings, it tries to default use localhost smtp which is
> > not installed on the box.
> > What confuses me is why the settings I just set in the review admin is
> > completely ignored.
> > Seeking a workaround, I manually set all the django EMAIL_* settings
> > and the above command line code worked to send an email out.
> > Once the settings were manually set, I went back to the web interface
> > to try a new submit, but I got the same spinning Loading indicator
> > that spins indefinitely.
> > So far, we've never gotten a single review request submission ever to
> > email out from the web interface.  Any suggestions on how to get our
> > email alerts going out?

You received this message because you are subscribed to the Google Groups 
"reviewboard" group.
To post to this group, send email to reviewboard@googlegroups.com
To unsubscribe from this group, send email to 
For more options, visit this group at 

Reply via email to