Yes, I realized this after I posted. I had accidentally pulled in a
nightly build at one point due to my .pydistutils.cfg, but I had since
downgraded to 1.0.1. Is there any way to get rid of the issue, or am I
stuck with the warning forever? :)

Dan

On Sep 17, 3:44 pm, Christian Hammond <chip...@chipx86.com> wrote:
> Hi Dan,
>
> Were you at any point running a 1.1 nightly or out of a Git tree? This is a
> field introduced in the 1.1 branch, so I don't know why you would see this
> in 1.0.x. It doesn't appear that the 1.0.x releases mention this at all in
> the codebase. If you went from a 1.1 to a 1.0.3, then you would definitely
> hit this error, as the field would be introduced and then removed without an
> evolution rule.
>
> Christian
>
> --
> Christian Hammond - chip...@chipx86.com
> Review Board -http://www.review-board.org
> VMware, Inc. -http://www.vmware.com
>
>
>
> On Thu, Sep 17, 2009 at 8:52 AM, Dan Savilonis <d...@n-cube.org> wrote:
>
> > I got the following error during the evolution:
>
> > # rb-site upgrade /home/reviewboard_head
> > Rebuilding directory structure
> > Updating database. This may take a while.
> > There are unapplied evolutions for diffviewer.
> > Project signature has changed - an evolution is required
> > /usr/lib/python2.5/site-packages/ReviewBoard-1.0.3-py2.5.egg/
> > reviewboard/scmtools/bzr.py:6: ImportWarning: Not importing directory
> > '/usr/lib/python2.5/site-packages/bzrlib': missing __init__.py
> >  from bzrlib import bzrdir, revisionspec
> > The stored evolutions do not completely resolve all model changes.
> > Run `./manage.py evolve --hint` to see a suggestion for the changes
> > required.
>
> > The following are the changes that could not be resolved:
> > In model scmtools.Repository:
> >    Field 'raw_file_url' has been deleted
>
> > It appears to be working okay, though. Other thing I noticed is that
> > the admin dashboard has CSS applied but appears very basic and has no
> > images. Other pages look okay, and the same as they used to.
>
> > Dan
>
> > On Sep 16, 8:38 pm, Christian Hammond <chip...@chipx86.com> wrote:
> > > Last night's 1.0.2 release was pretty broken in two major ways. The web
> > > server configuration templates were no longer bundled in the package, due
> > to
> > > a change in the structure of our code tree, and users using Django 1.0.2
> > > would hit a bug, as we needed functionality only present in 1.0.3 and
> > > higher.
>
> > > The new 1.0.3 release should address these problems. If you've been
> > bitten
> > > by 1.0.2 (our deepest apologies), please give this release a try and let
> > us
> > > know how it works.
>
> > > Full release notes are available athttp://
> >www.review-board.org/docs/releasenotes/dev/reviewboard/1.0.3/
>
> > > Christian
>
> > > --
> > > Christian Hammond - chip...@chipx86.com
> > > Review Board -http://www.review-board.org
> > > VMware, Inc. -http://www.vmware.com
--~--~---------~--~----~------------~-------~--~----~
You received this message because you are subscribed to the Google Groups 
"reviewboard" group.
To post to this group, send email to reviewboard@googlegroups.com
To unsubscribe from this group, send email to 
reviewboard+unsubscr...@googlegroups.com
For more options, visit this group at 
http://groups.google.com/group/reviewboard?hl=en
-~----------~----~----~----~------~----~------~--~---

Reply via email to