Hi all,

I have difficulties with post-review's parent option and mercurial.   
Christian told me that it should work for the latest revision of  
RBTools (0.2 beta 2), however, I get the following:

* If I try to post a working directory diff for a repository with  
outgoing changes, this doesn't work:

Here's the repository status:

> balla...@willie:~/work/testserver> hg log -l2
> changeset:   40:fda8ff0217d0
> tag:         tip
> user:        Clemens Ballarin <balla...@aicas.de>
> date:        Tue Sep 22 11:44:55 2009 +0200
> summary:     Test mod for review board.
>
> changeset:   39:649739e2c622
> parent:      38:a8c1a51ce0e0
> parent:      37:a527accbc8ca
> user:        Clemens Ballarin <balla...@aicas.com>
> date:        Thu Sep 17 15:52:50 2009 +0200
> summary:     Merged.
>
> balla...@willie:~/work/testserver> hg out
> comparing with /home/ballarin/public/testserver
> searching for changes
> changeset:   40:fda8ff0217d0
> tag:         tip
> user:        Clemens Ballarin <balla...@aicas.de>
> date:        Tue Sep 22 11:44:55 2009 +0200
> summary:     Test mod for review board.
>
> balla...@willie:~/work/testserver> hg st
> M jamaica/Makefile

Now the post:

> balla...@willie:~/work/testserver> /usr/lib64/python2.6/site-
> packages/post-review --server=http://willie --parent=39
> ==> Review Board Login Required
> Enter username and password for Review Board at http://willie/
> Username: ballarin
> Password:
> Error uploading diff: The file was not found in the repository (207)
> Your review request still exists, but the diff is not attached.

* My general setup seems to be OK, though.  Posting a working  
directory diff for a repository without outgoing changes works:

> balla...@willie:~/work/testserver> hg out
> comparing with /home/ballarin/public/testserver
> searching for changes
> no changes found
> balla...@willie:~/work/testserver> hg st
> M jamaica/Makefile
> balla...@willie:~/work/testserver> /usr/lib64/python2.6/site-
> packages/post-review --server=http://willie
> ==> Review Board Login Required
> Enter username and password for Review Board at http://willie/
> Username: ballarin
> Password:
> Review request #57 posted.
>
> http://willie/r/57

Is this a bug in RBTools or am I using "post-review --parent x" the  
wrong way?  Any help appreciated.

Cheers,

Clemens

--
Dr. Clemens Ballarin -- Senior Software Engineer

aicas Allerton Interworks Computer Automated Systems GmbH
Haid-und-Neu-Straße 18 * D-76131 Karlsruhe  * Germany
http://www.aicas.com   * phone +49 721 663 968-35  * fax -99

USt-Id: DE216375633, Handelsregister HRB 109481, AG Mannheim
Geschäftsführer: Dr. James J. Hunt


--~--~---------~--~----~------------~-------~--~----~
You received this message because you are subscribed to the Google Groups 
"reviewboard" group.
To post to this group, send email to reviewboard@googlegroups.com
To unsubscribe from this group, send email to 
reviewboard+unsubscr...@googlegroups.com
For more options, visit this group at 
http://groups.google.com/group/reviewboard?hl=en
-~----------~----~----~----~------~----~------~--~---

Reply via email to