Hi there,

I was attempting to use review board with svn.

1. I added a repository, say svn://localhost, with name, path and type
fields filled.

2. But when I want to create a new review request through the web UI,
I can't see the repository name in the repository name drop list. Thus
I can't create any request through the web UI.

3. And I also tried to use post-review.py --debug, it failed to pass
all the steps:

D:\ttsdata>post-review-script.py --debug
>>> svn info
>>> repository info: Path: svn://localhost, Base path: /, Supports changesets: 
>>> False
>>> svn diff --diff-cmd=diff
>>> svn info Raw/test/Word.cs
>>> svn info Raw/test/Word.cs
>>> svn info Raw/test/Word.cs
>>> svn info Raw/test/Word.cs
>>> Looking for 'localhost /reviews/' cookie in C:\Documents and 
>>> Settings\Administrator\Local Settings\Application Data\
.post-review-cookies.txt
>>> Cookie file loaded, but no cookie for this server
==> Review Board Login Required
Enter username and password for Review Board at http://localhost/reviews/
Username: yanpengju
Password:
>>> Logging in with username "yanpengju"
>>> HTTP POSTing to http://localhost/reviews/api/json/accounts/login/: 
>>> {'username': 'yanpengju', 'password': '**********
****'}
>>> Logged in.
>>> Attempting to create review request for None
>>> HTTP GETting /api/json/repositories/
>>> HTTP GETting /api/json/repositories/1/info/
>>> HTTP GETting /api/json/repositories/2/info/
>>> HTTP POSTing to http://localhost/reviews/api/json/reviewrequests/new/: 
>>> {'repository_path': 'svn://localhost'}
>>> Review request created
>>> Uploading diff, size: 378
>>> HTTP POSTing to 
>>> http://localhost/reviews/api/json/reviewrequests/7/diff/new/: {'basedir': 
>>> '/'}
>>> <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN"
 "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd";>

<html xmlns="http://www.w3.org/1999/xhtml"; xml:lang="en" lang="en">
 <head>
  <title>500 - Internal Server Error | Review Board</title>
 </head>
 <body>
  <h1>Something broke! (Error 500)</h1>
  <p>
   It appears something broke when you tried to go to here. This is
either
   a bug in Review Board or a server configuration error. Please
report
   this to your administrator.
  </p>
 </body>
</title>

Unable to access http://localhost/reviews/api/json/reviewrequests/7/diff/new/.
The host path may be invalid
HTTP Error 500: Internal Server Error

Although it failed eventually, but I can still see there some outgoing
draft review requests created by post-review, although the link points
to a error page "Something broke! (Error 500)":

It appears something broke when you tried to go to here. This is
either a bug in Review Board or a server configuration error. Please
report this to your administrator.

4. I'm using Python 2.5, Apache2.2, Review Board 1.0.5.1 and svn 1.6.6
on Windows Server 2003.

Can someone help me?

Pengju.

-- 
Want to help the Review Board project? Donate today at 
http://www.reviewboard.org/donate/
Happy user? Let us know at http://www.reviewboard.org/users/
-~----------~----~----~----~------~----~------~--~---
To unsubscribe from this group, send email to 
reviewboard+unsubscr...@googlegroups.com
For more options, visit this group at 
http://groups.google.com/group/reviewboard?hl=en

Reply via email to