Hi all,

I'm trying to setup a local development installation of Review Board.
As per 
I ran "python ./contrib/internal/prepare-dev.py".  However, when I
started the development server and tried to add a repository via the
admin ui I ran into a couple of problems.

First, there was no "Repository type" option to select (the drop-down
is empty).  I tracked this down to the scmtools_tool table being
empty.  So, I inserted ('Git', 'reviewboard.scmtools.git.GitTool') via
the sqlite3 cli (I copied this info from my production installation).
Upon reload of the admin ui, Git now shows up in the "Repository type"
drop-down.  Upon submission, though, I am met with a "global name '_'
is not defined" error.  It appears that this error is being caught
somewhere upstream, as this error is returned as a validation error
(it's prefaced with a "Please correct the error below." message).

It seems that scmtools_tool should be populated when prepare-dev.py is
executed.  Currently, the data for scmtools_tool resides in /
setup.py.  Any thoughts on how this data could be refactored so that
it is inserted when prepare-dev.py is ran?

Regarding the "global name '_' is not defined" error, I found this:
Any ideas on how to resolve this error?


Want to help the Review Board project? Donate today at 
Happy user? Let us know at http://www.reviewboard.org/users/
To unsubscribe from this group, send email to 
For more options, visit this group at 

Reply via email to