Hi, Christian,
   Thanks for replay. I said "rebuild" because I am using the directly
installed ReviewBoard, I don't know it's compiling form souce process.
If I want to change some python source code of ReviewBoard, Then how
to compile the ReviewBoard again, and do I need to reinstall the
compile result again for use? Sorry for my bad English expression.

Best Regards!
On Dec 15, 1:50 pm, Christian Hammond <chip...@chipx86.com> wrote:
> The getfqdn call essentially gets the fully-qualified domain (so,
> foo.example.com instead of just foo, for instance)....
>
> read more >>
>
> We recently added support for Perforce to check against all aliases,
> including what's reported locally. We should add this for CVS as well.
>
> I don't really know what you mean by rebuild method. Do you mean you want to
> know how to update a review request when you change the code you're writing
> for your project? If so, then you can use the -r parameter of post-review.
> For example, to update review request #42 with your latest code changes,
> run:
>
>     post-review -r 42
>
> Christian
>
> --
> Christian Hammond - chip...@chipx86.com
> Review Board -http://www.reviewboard.org
> VMware, Inc. -http://www.vmware.com
>
> 2009/12/14 JohnHenry <qhlonl...@163.com>
>
>
>
>
>
> > Hi, Christian,
> >    I have changed the source of Postreview.py, and now the post-
> > review can work fine. I found that in class CVSClient, the function
> > get_repository_info, It use socket.getfqdn(host) to replace the host
> > of repository_path; So I managed to keep the repository_path
> > unchanged. Though I don't quite catche what the "socket.getfqdn(host)"
> > mean, But keep the repository_path will finally works. Now I can use
> > post-review to generate reviewrequest. But if you can give me more
> > guidance about the reason, I will be much thanks. And I need your help
> > about ReviewBoard rebuild method, If I changed some source of
> > reviewboard, then how to rebuild this project to apply my change? I
> > think Reviewboard is a server application based on Django, There must
> > be some difference between it's rebuild and the change on post-review
> > code. Need your suggestion.
>
> > Best Regards!
> > > Hi,...
>
> > > read more >>
>
> > > You will need cvs on the server, definitely. The 1.1 alpha series won't
> > let
> > > you create a CVS repository without having it. You'll also need it on the
> > > client running post-review.
>
> > > The base path should be None in this case. It's really only needed for
> > > Subversion.
>
> > > Can you show me the Repository entries you have configured in the
> > > administration UI in Review Board?
>
> > > Christian
>
> > > --
> > > Christian Hammond - chip...@chipx86.com
> > > Review Board -http://www.reviewboard.org
> > > VMware, Inc. -http://www.vmware.com
>
> > > 2009/12/14 JohnHenry <qhlonl...@163.com>
>
> > > > Hi,
> > > > The detailed error info is:
> > > > -----------------------------------------------------
> > > > [jo...@dev2 test]$ post-review --debug --username=Johnl1 --
> > > > password=Johnl1 myTestCode.c
> > > > >>> svn info
> > > > >>> repository info: Path: cvs_gz:/export/home/cvsroot, Base path:
> > None,
> > > > Supports changesets: False
> > > > >>> cvs diff -uN myTestCode.c
> > > > >>> Looking for '192.168.3.20 /' cookie in
> > > > /data1/John1/.post-review-cookies.txt
> > > > >>> Couldn't load cookie file: '/data1/John1/.post-review-cookies.txt'
> > does
> > > > not look like a Netscape format cookies file
> > > > ==> Review Board Login Required
> > > > Enter username and password for Review Board athttp://
> > 192.168.3.20:8080/
> > > > >>> Logging in with username "John1"
> > > > >>> HTTP POSTing tohttp://192.168.3.20:8080/api/json/accounts/login/:
> > > > {'username': 'John1', 'password': '**************'}
> > > > >>> Logged in.
> > > > >>> Attempting to create review request for None
> > > > >>> HTTP POSTing tohttp://
> > 192.168.3.20:8080/api/json/reviewrequests/new/:
> > > > {'repository_path': 'cvs_gz:/export/home/cvsroot'}
> > > > Error creating review request: The repository path specified is not in
> > > > the list of known repositories (code 206)
>
> > -------------------------------------------------------------------------------
> > > > My question is : Why the "Base path" value of mine  is "None"? does it
> > > > have relationship with my problem "code 206"? if it does, Then how to
> > > > set this "Base path" in Review Board?
> > > > I have not installed CVS or SVN, I am using an account on an exist CVS
> > > > server. Must I have to install a independent CVS for the ReviewBoard?
>
> > > > Best Regards!
>
> > > > On 12月14日, 下午5时53分, Christian Hammond <chip...@chipx86.com> wrote:
> > > > > Hi,
>
> > > > > The Path or Mirror Path for the Repository entry in the admin UI in
> > > > Review
> > > > > Board must be exactly what post-review is trying to report. So, in
> > your
> > > > > case, it should be "cvs_gz/export/home/cvsoot". I'm hoping to add
> > fuzzy
> > > > > matching in the future (so as to make it possible to use aliases for
> > > > > domains, be more flexible with IP addresses and usernames, etc.), but
> > for
> > > > > now it must be an exact match.
>
> > > > > Christian
>
> > > > > --
> > > > > Christian Hammond - chip...@chipx86.com
> > > > > Review Board -http://www.reviewboard.org
> > > > > VMware, Inc. -http://www.vmware.com
>
> > > > > 2009/12/14 JohnHenry <qhlonl...@163.com>
>
> > > > > > Hi,
> > > > > >   This problem has been resolved; in the .reviewboardrc , I set the
> > > > > > REVIEWBOARD_URL ashttp://192.168.3.20:8080/reviewboard;afterI
> > > > > > delete the "reviewboard" ,login is successful now. But I stil can
> > not
> > > > > > use RB yet, Error info:
> > > > > > Error creating review request: The repository path specified is not
> > in
> > > > > > the list of known repositories (code 206);
> > > > > >   I found my previous Repository setting is the parent dir of
> > actual
> > > > > > Repository dir. So I have reset the Repository path on web
> > > > > > UI: :pserver:myn...@192.168.3.151:/export/home/cvsroot/test
> > > > > >   But still, The info is : "{'repository_path':
> > 'cvs_gz:/export/home/
> > > > > > cvsroot'}" the cvs_gz value is not changed at all, Why?
>
> > > > > > Best Regards!
>
> > > > > > On Dec 12, 5:25 pm, Christian Hammond <chip...@chipx86.com> wrote:
> > > > > > > The .post-review-cookies.txt file is where the HTTP cookie with
> > the
> > > > > > > authentication token is stored. This prevents needing to log in
> > after
> > > > the
> > > > > > > first post-review (generally)....
>
> > > > > > > read more >>
>
> > > > > > > If you go tohttp://192.168.3.20:8080/reviewboard/api/json/inyour
> > > > > > browser,
> > > > > > > what do you see?
>
> > > > > > > The two paths you saw should be correct (though, there shouldn't
> > be a
> > > > > > period
> > > > > > > at the end). One is the page you go to in your browser for
> > logging in
> > > > > > with
> > > > > > > the web UI. The other is the one that tools like post-review can
> > call
> > > > to
> > > > > > log
> > > > > > > in programatically.
>
> > > > > > > Christian
>
> > > > > > > --
> > > > > > > Christian Hammond - chip...@chipx86.com
> > > > > > > Review Board -http://www.reviewboard.org
> > > > > > > VMware, Inc. -http://www.vmware.com
>
> > > > > > > 2009/12/11 JohnHenry <qhlonl...@163.com>
>
> > > > > > > > more detailed infomation from " debug(data)"  in
> > RBTools-02.beta2-
> > > > > > > > py2.5.egg, process_json function:
> > > > > > > > >>> svn info
> > > > > > > > >>> repository info: Path: cvs_gz:/export/home/cvsroot, Base
> > path:
> > > > > > None,
> > > > > > > > Supports changesets: False
> > > > > > > > >>> cvs diff -uN myUCMobile.c reviewboard.jpg
> > > > > > > > >>> Looking for '192.168.2.20 /reviewboard/' cookie in
> > > > > > > > /data/John1/.post-review-cookies.txt
> > > > > > > > >>> Couldn't load cookie file: [Errno 2] No such file or
> > directory:
> > > > > > > > '/data/John1/.post-review-cookies.txt'
> > > > > > > > ==> Review Board Login Required
> > > > > > > > Enter username and password for Review Board at
> > > > > > > >http://192.168.3.20:8080/reviewboard/
> > > > > > > > >>> Logging in with username "John1"
> > > > > > > > >>> HTTP POSTing to
> > > > > > > >http://192.168.3.20:8080/reviewboard/api/json/accounts/login/:
> > > > > > > > {'username': 'John1', 'password': '**************'}
>
> > > > > > > > What is the ".post-review-cookies.txt" file?
>
> > > > > > > > On 12月11日, 下午7时12分, Christian Hammond <chip...@chipx86.com>
> > wrote:
> > > > > > > > > Using just the REVIEWBOARD_URL setting is fine. You can put
> > that
> > > > > > > > > .reviewboardrc file right in the CVS checkout directory if
> > you
> > > > want.
>
> > > > > > > > > It sounds like the directory you've specified actually isn't
> > a
> > > > > > working
> > > > > > > > path
> > > > > > > > > to Review Board. That, or what you have specified is
> > redirecting
> > > > to
> > > > > > the
> > > > > > > > > wrong place. What do you have for REVIEWBOARD_URL?
>
> > > > > > > > > Christian
>
> > > > > > > > > --
> > > > > > > > > Christian Hammond - chip...@chipx86.com
> > > > > > > > > Review Board -http://www.reviewboard.org
> > > > > > > > > VMware, Inc. -http://www.vmware.com
>
> > > > > > > > > On Fri, Dec 11, 2009 at 2:49 AM, JohnHenry <
> > qhlonl...@163.com>
> > > > > > wrote:
> > > > > > > > > > I had edit the .reviewboardrc file as the type(I have
> > changed
> > > > the
> > > > > > url
> > > > > > > > > > or cvs path to the site of mine):
> > > > > > > > > > TREES = {
> > > > > > > > > >    'http://svn.example.com':{
> > > > > > > > > >        'REVIEWBOARD_URL': 'http://reviewboard.example.com
> > ',
> > > > > > > > > >    },
> > > > > > > > > >    'usern...@cvs.example.com:/cvsroot/cvs': {
> > > > > > > > > >        'REVIEWBOARD_URL': 'http://reviewboard.example.com
> > ',
> > > > > > > > > >    },
> > > > > > > > > > }
> > > > > > > > > > But when I use post-review , it report :
> > > > > > > > > > "Unable to find a Review Board server for this source code
> > > > tree."
> > > > > > > > > > Then I had used the second method, I edit the file as the
> > type:
> > > > > > > > > > REVIEWBOARD_URL = "http://reviewboard.example.com";
> > > > > > > > > > this time, I can load and then I type username and password
> > of
> > > > RB
> > > > > > user
> > > > > > > > > > to login, But that returns:
> > > > > > > > > > "Unable to access- Hide quoted text -
>
> - Show quoted text -

-- 
Want to help the Review Board project? Donate today at 
http://www.reviewboard.org/donate/
Happy user? Let us know at http://www.reviewboard.org/users/
-~----------~----~----~----~------~----~------~--~---
To unsubscribe from this group, send email to 
reviewboard+unsubscr...@googlegroups.com
For more options, visit this group at 
http://groups.google.com/group/reviewboard?hl=en

Reply via email to