Hi, All.
   I had tried to use post-review to product a ReviewRequest after the code has 
been commited to CVS Repository. The original version of source file is 1.1, I 
chengd the file and commited again, The version on CVS repository then is 1.2; 
So I use the command:
#post-review revision-range=1.1:1.2  --username=A1 --password=A1Pass 
--target-people=B1 --summary=NoSummary -p test.c
But the execution of this command reports:
Error Uploading diff: One or more fields has errors: (105)
Your review requests is still exists, But the diff is not attached
Then I tried to use --revision-range=0:1 , This time the commit is well, But 
When I open the review board WebUI, It shows the list:
Diff revision 1 (Latest)

Files Changed:

/tmp/cvs0u9OUY: 1 change [ new content ] 
/tmp/cvs2PY2EF: 1 change [ new content ] 
/tmp/cvs4c1jWh: 1 change [ new content ] 
/tmp/cvs4s3h8n: 1 change [ new content ] 
/tmp/cvs4yGoXf: 1 change [ new content ] 
/tmp/cvs6BEFdG: 1 change [ new content ] 
/tmp/cvs6JH9h6: 1 change [ new content ]


But not the diff of file "test.c" Which is my designed to show. My questions 
are :

(1) What is the "--Revision-range" mean?  (Is the Revision means the source 
code version on Repostitory?)

(2) How to make post-commit review request for one or more specific files? 

(3) If there are more then one files needing to be reviewed, But they are in 
different version in the Repository, Can I create a post-commit ReviewRequest 
for those files? (All those file diffs are in one diff file ) and How?

Best Regards!

Want to help the Review Board project? Donate today at 
Happy user? Let us know at http://www.reviewboard.org/users/
To unsubscribe from this group, send email to 
For more options, visit this group at 

Reply via email to