Hi,

Do you know what URL they were on? Is this when posting a review, or a
review request?

If done from post-review, can you run with --debug and show what request was
causing that?

Christian

-- 
Christian Hammond - chip...@chipx86.com
Review Board - http://www.reviewboard.org
VMware, Inc. - http://www.vmware.com


On Sat, Jan 9, 2010 at 6:29 PM, Kunjal <kunjal.par...@gmail.com> wrote:

> Hello Chris,
>
> With your great help we could release RB 1.0.5 to 300 + developers and
> it is working quite well.
> Suddenly from yesterday, some of the users (3 of them) are seeing
> below errors when they post the review.
>
> Do you know what can cause such errors?
>
>
> Traceback (most recent call last):
>
>  File "/projects/mob_reviewboard/xampp/1.6.4-brcm-v2/lib/python2.5/
> site-packages/Django-1.1.1-py2.5.egg/django/core/handlers/base.py",
> line 92, in get_response
>    response = callback(request, *callback_args, **callback_kwargs)
>
>  File "/projects/mob_reviewboard/xampp/1.6.4-brcm-v2/lib/python2.5/
> site-packages/Django-1.1.1-py2.5.egg/django/views/decorators/
> cache.py", line 45, in _wrapped_view_func
>    add_never_cache_headers(response)
>
>  File "/projects/mob_reviewboard/xampp/1.6.4-brcm-v2/lib/python2.5/
> site-packages/Django-1.1.1-py2.5.egg/django/utils/cache.py", line 119,
> in add_never_cache_headers
>    patch_response_headers(response, cache_timeout=-1)
>
>  File "/projects/mob_reviewboard/xampp/1.6.4-brcm-v2/lib/python2.5/
> site-packages/Django-1.1.1-py2.5.egg/django/utils/cache.py", line 108,
> in patch_response_headers
>    response['ETag'] = '"%s"' % md5_constructor
> (response.content).hexdigest()
>
>  File "/projects/mob_reviewboard/xampp/1.6.4-brcm-v2/lib/python2.5/
> site-packages/Djblets-0.5.6-py2.5.egg/djblets/webapi/core.py", line
> 264, in _get_content
>    content = adapter.encode(self.api_data)
>
>  File "build/bdist.linux-i686/egg/simplejson/encoder.py", line 200,
> in encode
>    chunks = self.iterencode(o, _one_shot=True)
>
>  File "build/bdist.linux-i686/egg/simplejson/encoder.py", line 260,
> in iterencode
>    return _iterencode(o, 0)
>
> UnicodeDecodeError: 'utf8' codec can't decode byte 0x93 in position
> 277: unexpected code byte
>
> --
> Want to help the Review Board project? Donate today at
> http://www.reviewboard.org/donate/
> Happy user? Let us know at http://www.reviewboard.org/users/
> -~----------~----~----~----~------~----~------~--~---
> To unsubscribe from this group, send email to
> reviewboard+unsubscr...@googlegroups.com<reviewboard%2bunsubscr...@googlegroups.com>
> For more options, visit this group at
> http://groups.google.com/group/reviewboard?hl=en
>
-- 
Want to help the Review Board project? Donate today at 
http://www.reviewboard.org/donate/
Happy user? Let us know at http://www.reviewboard.org/users/
-~----------~----~----~----~------~----~------~--~---
To unsubscribe from this group, send email to 
reviewboard+unsubscr...@googlegroups.com
For more options, visit this group at 
http://groups.google.com/group/reviewboard?hl=en

Reply via email to