We're checking to make sure it's a valid repository. That's a large CVSROOT,
but shouldn't take that long, certainly. Sounds more like something is hung
and not finishing. It may be failing to see the stored certificate and is
asking for input.

Try to reproduce it and see if the cvs process sticks around. If so, we'll
need to figure out the cause.

Is there a $HOME set up for Apache's user? And is this on Windows or Linux?

Christian

-- 
Christian Hammond - chip...@chipx86.com
Review Board - http://www.reviewboard.org
VMware, Inc. - http://www.vmware.com


On Wed, Feb 24, 2010 at 9:17 PM, CMOS <manusha1...@gmail.com> wrote:

> hi,
> sorry i should have mentioned this in the first post. When i fist did
> it, it presented me the certificate information. (it asked me whether
> i trust that host as usual ssh and i said yes.) The hang happens after
> words!
> i checked out the source and saw that it tries to cat CVSROOT/modules.
> What exactly does it try to do there? Our cvs root has around 1000
> modules. Could that be a reason. (anyway i waited around 12 hours for
> a response, but it did not succeed).
>
>
> thanks
> CMOS
>
> On Feb 25, 8:46 am, Christian Hammond <chip...@chipx86.com> wrote:
> > Hi,
> >
> > When using :ext:, we attempt to connect to the host through ssh to get
> the
> > certificate information and present it to the user. It sounds like this
> is
> > somehow failing. We're using the paramiko Python module for this. It's
> > possible that this is having some issues.
> >
> > You can verify this by typing:
> >
> > $ rb-site manage /path/to/your/site shell
> >
> > And then at the Python prompt:
> >
> > >>> from reviewboard.scmtools.sshutils import check_host
> > >>> check_host("yourcvsserver")
> >
> > That might report some error, or it might just simply return. If it
> returns
> > without printing anything, then it verified the host certificate. If it
> > hangs indefinitely, then we'll need to figure that out. In theory, it
> would
> > timeout eventually.
> >
> > If that turns out to not be the problem, then it has to do with
> attempting
> > to cat CVSROOT/modules from that repository.
> >
> > Christian
> >
> > --
> > Christian Hammond - chip...@chipx86.com
> > Review Board -http://www.reviewboard.org
> > VMware, Inc. -http://www.vmware.com
> >
> > On Wed, Feb 24, 2010 at 8:25 AM, CMOS <manusha1...@gmail.com> wrote:
> > > hello,
> >
> > > i installed 1.5 beta version of review board in windows and it works
> > > fine, but when i try to add a cvs repository with mode ext, it got
> > > stuck. (the browser is indefinitely waiting for response).
> > > i use plink for security.
> > > CVS works fine in the shell.
> >
> > > could anyone guess the reason?
> >
> > > thanks
> >
> > > --
> > > Want to help the Review Board project? Donate today at
> > >http://www.reviewboard.org/donate/
> > > Happy user? Let us know athttp://www.reviewboard.org/users/
> > > -~----------~----~----~----~------~----~------~--~---
> > > To unsubscribe from this group, send email to
> > > reviewboard+unsubscr...@googlegroups.com<reviewboard%2bunsubscr...@googlegroups.com>
> <reviewboard%2bunsubscr...@googlegroups.com<reviewboard%252bunsubscr...@googlegroups.com>
> >
> > > For more options, visit this group at
> > >http://groups.google.com/group/reviewboard?hl=en
>
> --
> Want to help the Review Board project? Donate today at
> http://www.reviewboard.org/donate/
> Happy user? Let us know at http://www.reviewboard.org/users/
> -~----------~----~----~----~------~----~------~--~---
> To unsubscribe from this group, send email to
> reviewboard+unsubscr...@googlegroups.com<reviewboard%2bunsubscr...@googlegroups.com>
> For more options, visit this group at
> http://groups.google.com/group/reviewboard?hl=en
>

-- 
Want to help the Review Board project? Donate today at 
http://www.reviewboard.org/donate/
Happy user? Let us know at http://www.reviewboard.org/users/
-~----------~----~----~----~------~----~------~--~---
To unsubscribe from this group, send email to 
reviewboard+unsubscr...@googlegroups.com
For more options, visit this group at 
http://groups.google.com/group/reviewboard?hl=en

Reply via email to