Yeah, this is going to remain a problem. When using :ext:, cvs is going to
ask for verification on the credentials. That's what we're trying to solve
in 1.5, but it seems it's breaking for your setup. It could be something
specific with a Windows host. I would have to do some further research.

What would really help me is if you can figure out where it's storing the
verification with a normal user. It's assumed to be in $HOME/.ssh somewhere,
but maybe this isn't true with cvs/plink on Windows?

Christian

-- 
Christian Hammond - chip...@chipx86.com
Review Board - http://www.reviewboard.org
VMware, Inc. - http://www.vmware.com


On Mon, Mar 1, 2010 at 1:34 AM, CMOS <manusha1...@gmail.com> wrote:

> now the post-review hangs with following message:
>
> HTTP POSTing to http://<the server>:88/api/json/reviewrequests/2/diff/
> new/: {}
>
> and as before, the process tree (httpd- > cvs -> cmd -> plink) seem to
> run without ending.
>
>
> On Mar 1, 2:26 pm, CMOS <manusha1...@gmail.com> wrote:
> > adding the path to mirror path solved it.
> >
> > On Mar 1, 2:12 pm, CMOS <manusha1...@gmail.com> wrote:
> >
> > > tried that but did not work. still it hangs.
> > > i removed that line from the source and tried it and now repo gets
> > > added, but not sure whether it will work.
> >
> > > To see if it works, i tried to post a review request using post-review
> > > and it gives this error:
> >
> > > "The repository path specified is not in the list of known
> > > repositories (HTTP 200, API Error 206)"
> >
> > > the repository path it looks for is the same path except the user/
> > > protocol information. i.e <server name>:/cvs. When adding the repo to
> > > RB, i used the same path but with protocol (:ext) and user
> > > information.
> > > Am i doing things right?
> >
> > > CMOS
> >
> > > On Mar 1, 1:14 pm, Christian Hammond <chip...@chipx86.com> wrote:
> >
> > > > The HOME issue is something I'm hoping to address before 1.5 is out
> the
> > > > door.
> >
> > > > For now, try adding a new SetEnv directive in the Apache config for
> the site
> > > > that points HOME to some directory in your RB site directory. You'll
> need to
> > > > create this directory and make sure that Apache can write to it.
> >
> > > > Christian
> >
> > > > --
> > > > Christian Hammond - chip...@chipx86.com
> > > > Review Board -http://www.reviewboard.org
> > > > VMware, Inc. -http://www.vmware.com
> >
> > > > On Sun, Feb 28, 2010 at 11:53 PM, CMOS <manusha1...@gmail.com>
> wrote:
> > > > > hi,
> > > > > i checked the process tree during hang and saw that httpd
> startscvs,
> > > > > which in turn starts plink through a new shell. All these processes
> > > > > does not terminate during the hang.
> > > > > to see if i can try it manually, i invokedcvsdirectly with the same
> > > > > command line and it finished in a second. It produces an out put as
> > > > > below:
> >
> > > > > ===================================================================
> > > > > Checking out CVSROOT/modules
> > > > > RCS:  /cvs/CVSROOT/modules,v
> > > > > VERS: 1.5
> > > > > ***************
> >
> > > > > ... more stuff ...
> >
> > > > > there is no HOME user specific envt variable set for Apache user,
> but
> > > > > there is a system wide variable called HOME (which is created for a
> > > > > different purpose though). I use windows.
> >
> > > > > Thanks
> > > > > CMOS
> >
> > > > > On Feb 25, 10:52 am, Christian Hammond <chip...@chipx86.com>
> wrote:
> > > > > > We're checking to make sure it's a valid repository. That's a
> large
> > > > > CVSROOT,
> > > > > > but shouldn't take that long, certainly. Sounds more like
> something is
> > > > > hung
> > > > > > and not finishing. It may be failing to see the stored
> certificate and is
> > > > > > asking for input.
> >
> > > > > > Try to reproduce it and see if thecvsprocess sticks around. If
> so,
> > > > > we'll
> > > > > > need to figure out the cause.
> >
> > > > > > Is there a $HOME set up for Apache's user? And is this on Windows
> or
> > > > > Linux?
> >
> > > > > > Christian
> >
> > > > > > --
> > > > > > Christian Hammond - chip...@chipx86.com
> > > > > > Review Board -http://www.reviewboard.org
> > > > > > VMware, Inc. -http://www.vmware.com
> >
> > > > > > On Wed, Feb 24, 2010 at 9:17 PM, CMOS <manusha1...@gmail.com>
> wrote:
> > > > > > > hi,
> > > > > > > sorry i should have mentioned this in the first post. When i
> fist did
> > > > > > > it, it presented me the certificate information. (it asked me
> whether
> > > > > > > i trust that host as usual ssh and i said yes.) The hang
> happens after
> > > > > > > words!
> > > > > > > i checked out the source and saw that it tries to cat
> CVSROOT/modules.
> > > > > > > What exactly does it try to do there? Ourcvsroot has around
> 1000
> > > > > > > modules. Could that be a reason. (anyway i waited around 12
> hours for
> > > > > > > a response, but it did not succeed).
> >
> > > > > > > thanks
> > > > > > > CMOS
> >
> > > > > > > On Feb 25, 8:46 am, Christian Hammond <chip...@chipx86.com>
> wrote:
> > > > > > > > Hi,
> >
> > > > > > > > When using :ext:, we attempt to connect to the host through
> ssh to
> > > > > get
> > > > > > > the
> > > > > > > > certificate information and present it to the user. It sounds
> like
> > > > > this
> > > > > > > is
> > > > > > > > somehow failing. We're using the paramiko Python module for
> this.
> > > > > It's
> > > > > > > > possible that this is having some issues.
> >
> > > > > > > > You can verify this by typing:
> >
> > > > > > > > $ rb-site manage /path/to/your/site shell
> >
> > > > > > > > And then at the Python prompt:
> >
> > > > > > > > >>> from reviewboard.scmtools.sshutils import check_host
> > > > > > > > >>> check_host("yourcvsserver")
> >
> > > > > > > > That might report some error, or it might just simply return.
> If it
> > > > > > > returns
> > > > > > > > without printing anything, then it verified the host
> certificate. If
> > > > > it
> > > > > > > > hangs indefinitely, then we'll need to figure that out. In
> theory, it
> > > > > > > would
> > > > > > > > timeout eventually.
> >
> > > > > > > > If that turns out to not be the problem, then it has to do
> with
> > > > > > > attempting
> > > > > > > > to cat CVSROOT/modules from that repository.
> >
> > > > > > > > Christian
> >
> > > > > > > > --
> > > > > > > > Christian Hammond - chip...@chipx86.com
> > > > > > > > Review Board -http://www.reviewboard.org
> > > > > > > > VMware, Inc. -http://www.vmware.com
> >
> > > > > > > > On Wed, Feb 24, 2010 at 8:25 AM, CMOS <manusha1...@gmail.com>
> wrote:
> > > > > > > > > hello,
> >
> > > > > > > > > i installed 1.5 beta version of review board in windows and
> it
> > > > > works
> > > > > > > > > fine, but when i try to add acvsrepository with modeext, it
> got
> > > > > > > > > stuck. (the browser is indefinitely waiting for response).
> > > > > > > > > i use plink for security.
> > > > > > > > >CVSworks fine in the shell.
> >
> > > > > > > > > could anyone guess the reason?
> >
> > > > > > > > > thanks
> >
> > > > > > > > > --
> > > > > > > > > Want to help the Review Board project? Donate today at
> > > > > > > > >http://www.reviewboard.org/donate/
> > > > > > > > > Happy user? Let us know athttp://
> www.reviewboard.org/users/
> > > > > > > > > -~----------~----~----~----~------~----~------~--~---
> > > > > > > > > To unsubscribe from this group, send email to
> > > > > > > > > reviewboard+unsubscr...@googlegroups.com<reviewboard%2bunsubscr...@googlegroups.com>
> <reviewboard%2bunsubscr...@googlegroups.com<reviewboard%252bunsubscr...@googlegroups.com>
> >
> > > > > <reviewboard%2bunsubscr...@googlegroups.com<reviewboard%252bunsubscr...@googlegroups.com>
> <reviewboard%252bunsubscr...@googlegroups.com<reviewboard%25252bunsubscr...@googlegroups.com>
> >
> >
> > > > > > > <reviewboard%2bunsubscr...@googlegroups.com<reviewboard%252bunsubscr...@googlegroups.com>
> <reviewboard%252bunsubscr...@googlegroups.com<reviewboard%25252bunsubscr...@googlegroups.com>
> >
> > > > > <reviewboard%252bunsubscr...@googlegroups.com<reviewboard%25252bunsubscr...@googlegroups.com>
> <reviewboard%25252bunsubscr...@googlegroups.com<reviewboard%2525252bunsubscr...@googlegroups.com>
> >
> >
> > > > > > > > > For more options, visit this group at
> > > > > > > > >http://groups.google.com/group/reviewboard?hl=en
> >
> > > > > > > --
> > > > > > > Want to help the Review Board project? Donate today at
> > > > > > >http://www.reviewboard.org/donate/
> > > > > > > Happy user? Let us know athttp://www.reviewboard.org/users/
> > > > > > > -~----------~----~----~----~------~----~------~--~---
> > > > > > > To unsubscribe from this group, send email to
> > > > > > > reviewboard+unsubscr...@googlegroups.com<reviewboard%2bunsubscr...@googlegroups.com>
> <reviewboard%2bunsubscr...@googlegroups.com<reviewboard%252bunsubscr...@googlegroups.com>
> >
> > > > > <reviewboard%2bunsubscr...@googlegroups.com<reviewboard%252bunsubscr...@googlegroups.com>
> <reviewboard%252bunsubscr...@googlegroups.com<reviewboard%25252bunsubscr...@googlegroups.com>
> >
> >
> > > > > > > For more options, visit this group at
> > > > > > >http://groups.google.com/group/reviewboard?hl=en
> >
> > > > > --
> > > > > Want to help the Review Board project? Donate today at
> > > > >http://www.reviewboard.org/donate/
> > > > > Happy user? Let us know athttp://www.reviewboard.org/users/
> > > > > -~----------~----~----~----~------~----~------~--~---
> > > > > To unsubscribe from this group, send email to
> > > > > reviewboard+unsubscr...@googlegroups.com<reviewboard%2bunsubscr...@googlegroups.com>
> <reviewboard%2bunsubscr...@googlegroups.com<reviewboard%252bunsubscr...@googlegroups.com>
> >
> > > > > For more options, visit this group at
> > > > >http://groups.google.com/group/reviewboard?hl=en
>
> --
> Want to help the Review Board project? Donate today at
> http://www.reviewboard.org/donate/
> Happy user? Let us know at http://www.reviewboard.org/users/
> -~----------~----~----~----~------~----~------~--~---
> To unsubscribe from this group, send email to
> reviewboard+unsubscr...@googlegroups.com<reviewboard%2bunsubscr...@googlegroups.com>
> For more options, visit this group at
> http://groups.google.com/group/reviewboard?hl=en
>

-- 
Want to help the Review Board project? Donate today at 
http://www.reviewboard.org/donate/
Happy user? Let us know at http://www.reviewboard.org/users/
-~----------~----~----~----~------~----~------~--~---
To unsubscribe from this group, send email to 
reviewboard+unsubscr...@googlegroups.com
For more options, visit this group at 
http://groups.google.com/group/reviewboard?hl=en

Reply via email to