Well, not in the web interface. The log had the details that I needed
(turns our I was embarrassingly looking in the wrong location for the
log):

2010-03-03 22:51:05,394 - ERROR - Git: Failed to find valid repository
ssh://g...@github.com/foodzie/foodzie.git: Host key verification
failed.
fatal: The remote end hung up unexpectedly


On Mar 4, 2:05 am, Christian Hammond <chip...@chipx86.com> wrote:
> Glad you solved it :)
>
> Did it ask you for any SSH verification when you first tried to save the
> repository?
>
> Christian
>
> --
> Christian Hammond - chip...@chipx86.com
> Review Board -http://www.reviewboard.org
> VMware, Inc. -http://www.vmware.com
>
>
>
> On Wed, Mar 3, 2010 at 10:55 PM, Nik Bauman <n...@foodzie.com> wrote:
> > Aha!
>
> > I figured it out. It was a public key issue. My apache user (www-data)
> > needed to authenticate with github using my public key and my key was
> > only in my user's account. So when the web app tried authenticating,
> > it was puking.
>
> > On Mar 4, 1:40 am, Christian Hammond <chip...@chipx86.com> wrote:
> > > Is logging turned on? If not, try turning it on in Settings and
> > restarting
> > > Apache. When the ls-remote fails, it should log the reason why.
>
> > > I committed a change to bump up the max length for the raw URL field, so
> > in
> > > the next nightly rebuild (in about 2.5 hours) you may want to upgrade.
>
> > > Christian
>
> > > --
> > > Christian Hammond - chip...@chipx86.com
> > > Review Board -http://www.reviewboard.org
> > > VMware, Inc. -http://www.vmware.com
>
> > > On Wed, Mar 3, 2010 at 10:19 PM, Nik Bauman <n...@foodzie.com> wrote:
> > > > Correct,
>
> > > > CLI output:
> > > > >:/home/nbauman$ git ls-remote g...@github.com:foodzie/foodzie.git
> > HEAD
> > > > f5546a2deeeeea7746f7670f04ddc5d94c814f4c        HEAD
> > > > >:/home/nbauman$
>
> > > > App response:
> > > >http://skitch.com/nbauman/n28se/screen-shot-2010-03-04-at-1.17.48-am
>
> > > > :(
> > > > -Nik
>
> > > > On Mar 4, 1:13 am, Christian Hammond <chip...@chipx86.com> wrote:
> > > > > So if you call that on the server, it works?
>
> > > > > That's the check we're actually performing when it comes down to it.
> > If
> > > > it
> > > > > fails, we report that the repository is invalid. Otherwise, it should
> > > > allow
> > > > > it to continue.
>
> > > > > Christian
>
> > > > > --
> > > > > Christian Hammond - chip...@chipx86.com
> > > > > Review Board -http://www.reviewboard.org
> > > > > VMware, Inc. -http://www.vmware.com
>
> > > > > On Wed, Mar 3, 2010 at 10:09 PM, Nik Bauman <n...@foodzie.com>
> > wrote:
> > > > > > Good thought! I investigated the git setup - everything looks fine
> > > > > > though.
>
> > > > > > git ls-remote g...@github.com:user/repo.git HEAD works fine.
>
> > > > > > On Mar 3, 9:14 pm, Christian Hammond <chip...@chipx86.com> wrote:
> > > > > > > Oh, is Git installed on the server? Maybe it's failing its `git
> > > > ls-remote
> > > > > > > <repository path> HEAD` check.
>
> > > > > > > Christian
>
> > > > > > > --
> > > > > > > Christian Hammond - chip...@chipx86.com
> > > > > > > Review Board -http://www.reviewboard.org
> > > > > > > VMware, Inc. -http://www.vmware.com
>
> > > > > > > On Wed, Mar 3, 2010 at 6:12 PM, Nik Bauman <n...@foodzie.com>
> > wrote:
> > > > > > > > Grr. Actually I think that may be a red herring. I shortened
> > some
> > > > > > > > things and it still complains "A repository was not found at
> > the
> > > > > > > > specified path."
>
> > > > > > > > On Mar 3, 9:06 pm, Christian Hammond <chip...@chipx86.com>
> > wrote:
> > > > > > > > > Oh that very well could be... Do you have a really long
> > username
> > > > or
> > > > > > > > > something?
>
> > > > > > > > > I'll bump that in a nightly. Hopefully tonight.
>
> > > > > > > > > Christian
>
> > > > > > > > > --
> > > > > > > > > Christian Hammond - chip...@chipx86.com
> > > > > > > > > Review Board -http://www.reviewboard.org
> > > > > > > > > VMware, Inc. -http://www.vmware.com
>
> > > > > > > > > On Wed, Mar 3, 2010 at 5:57 PM, Nik Bauman <n...@foodzie.com
>
> > > > wrote:
> > > > > > > > > > Could it be that my generate Raw file URL mask url is too
> > long?
> > > > > > When i
> > > > > > > > > > switch to custom it has the value filled out for me, but
> > the
> > > > > > > > > > validation doesn't work -
>
> > > > > > > > > > "Ensure this value has at most 128 characters (it has
> > 131)."
>
> > > > > > > > > > On Mar 3, 8:02 pm, Nik Bauman <n...@foodzie.com> wrote:
> > > > > > > > > > > Yes, I'm using 1.5 beta 1.
>
> > > > > > > > > > > And yes, the api token is from my account (the owner of
> > the
> > > > > > > > > > > repository). The following is a screenshot for greater
> > > > clarity to
> > > > > > see
> > > > > > > > > > > if I have anything wrong :
>
> >http://skitch.com/nbauman/n2gif/screen-shot-2010-03-03-at-4.04.52-pm
>
> > > > > > > > > > > Logging is turned on and permissions look okay but I
> > don't
> > > > have a
> > > > > > log
> > > > > > > > > > > file being generated yet... so I'm still trying to figure
> > out
> > > > > > what is
> > > > > > > > > > > going on there.
>
> > > > > > > > > > > -Nik
>
> > > > > > > > > > > On Mar 3, 6:29 pm, Christian Hammond <
> > chip...@chipx86.com>
> > > > > > wrote:
>
> > > > > > > > > > > > If the user-facing pages on Review Board say 1.5 beta
> > 1,
> > > > then
> > > > > > you
> > > > > > > > > > should
> > > > > > > > > > > > have the right  version.
>
> > > > > > > > > > > > Do you have the proper authentication token specified
> > for
> > > > the
> > > > > > > > > > repository?
>
> > > > > > > > > > > > If logging is turned on, check the log file and see if
> > it
> > > > has
> > > > > > any
> > > > > > > > more
> > > > > > > > > > > > detail.
>
> > > > > > > > > > > > Christian
>
> > > > > > > > > > > > --
> > > > > > > > > > > > Christian Hammond - chip...@chipx86.com
> > > > > > > > > > > > Review Board -http://www.reviewboard.org
> > > > > > > > > > > > VMware, Inc. -http://www.vmware.com
>
> > > > > > > > > > > > On Wed, Mar 3, 2010 at 1:11 PM, Nik Bauman <
> > > > n...@foodzie.com>
> > > > > > > > wrote:
> > > > > > > > > > > > > Hey folks,
>
> > > > > > > > > > > > > I have a private repository on github, I've installed
> > the
> > > > > > latest
> > > > > > > > beta
> > > > > > > > > > > > > (1.5), but I can't seem to create a private git
> > > > repository.
> > > > > > Every
> > > > > > > > > > time
> > > > > > > > > > > > > I input my credentials it's telling me that "A
> > repository
> > > > was
> > > > > > not
> > > > > > > > > > > > > found at the specified path."
>
> > > > > > > > > > > > > I see other threads referring to this issue when
> > people
> > > > > > weren't
> > > > > > > > using
> > > > > > > > > > > > > the latest alpha. Is there an update that I can get
> > > > beyond
> > > > > > the
> > > > > > > > > > current
> > > > > > > > > > > > > beta? Any way that I can ensure I didn't install the
> > > > wrong
> > > > > > > > version?
>
> > > > > > > > > > > > > Thanks,
> > > > > > > > > > > > > Nik
>
> > > > > > > > > > > > > --
> > > > > > > > > > > > > Want to help the Review Board project? Donate today
> > at
> > > > > > > > > > > > >http://www.reviewboard.org/donate/
> > > > > > > > > > > > > Happy user? Let us know athttp://
> > > >www.reviewboard.org/users/
> > > > > > > > > > > > > -~----------~----~----~----~------~----~------~--~---
> > > > > > > > > > > > > To unsubscribe from this group, send email to
> > > > > > > > > > > > > reviewboard+unsubscr...@googlegroups.com<reviewboard%2bunsubscr...@googlegr
> > > > > > > > > > > > >  oups.com>
> > <reviewboard%2bunsubscr...@googlegr oups.com>
> > > > <reviewboard%2bunsubscr...@googlegr oups.com>
> > > > > > <reviewboard%2bunsubscr...@googlegr oups.com>
> > > > > > > > <reviewboard%2bunsubscr...@googlegr oups.com>
> > > > > > > > > > <reviewboard%2bunsubscr...@googlegr oups.com>
> > > > > > > > > > > > > For more options, visit this group at
> > > > > > > > > > > > >http://groups.google.com/group/reviewboard?hl=en
>
> > > > > > > > > > --
> > > > > > > > > > Want to help the Review Board project? Donate today at
> > > > > > > > > >http://www.reviewboard.org/donate/
> > > > > > > > > > Happy user? Let us know athttp://
> >www.reviewboard.org/users/
> > > > > > > > > > -~----------~----~----~----~------~----~------~--~---
> > > > > > > > > > To unsubscribe from this group, send email to
> > > > > > > > > > reviewboard+unsubscr...@googlegroups.com<reviewboard%2bunsubscr...@googlegr
> > > > > > > > > >  oups.com>
> > <reviewboard%2bunsubscr...@googlegr oups.com>
> > > > <reviewboard%2bunsubscr...@googlegr oups.com>
> > > > > > <reviewboard%2bunsubscr...@googlegr oups.com>
> > > > > > > > <reviewboard%2bunsubscr...@googlegr oups.com>
> > > > > > > > > > For more options, visit this group at
> > > > > > > > > >http://groups.google.com/group/reviewboard?hl=en
>
> > > > > > > > --
> > > > > > > > Want to help the Review Board project? Donate today at
> > > > > > > >http://www.reviewboard.org/donate/
> > > > > > > > Happy user? Let us know athttp://www.reviewboard.org/users/
> > > > > > > > -~----------~----~----~----~------~----~------~--~---
> > > > > > > > To unsubscribe from this group, send email to
> > > > > > > > reviewboard+unsubscr...@googlegroups.com<reviewboard%2bunsubscr...@googlegr
> > > > > > > >  oups.com>
> > <reviewboard%2bunsubscr...@googlegr oups.com>
> > > > <reviewboard%2bunsubscr...@googlegr oups.com>
> > > > > > <reviewboard%2bunsubscr...@googlegr oups.com>
> > > > > > > > For more options, visit this group at
> > > > > > > >http://groups.google.com/group/reviewboard?hl=en
>
> > > > > > --
> > > > > > Want to help the Review Board project? Donate today at
> > > > > >http://www.reviewboard.org/donate/
> > > > > > Happy user? Let us know athttp://www.reviewboard.org/users/
> > > > > > -~----------~----~----~----~------~----~------~--~---
> > > > > > To unsubscribe from this group, send email to
> > > > > > reviewboard+unsubscr...@googlegroups.com<reviewboard%2bunsubscr...@googlegr
> > > > > >  oups.com>
> > <reviewboard%2bunsubscr...@googlegr oups.com>
> > > > <reviewboard%2bunsubscr...@googlegr oups.com>
> > > > > > For more options, visit this group at
> > > > > >http://groups.google.com/group/reviewboard?hl=en
>
> > > > --
> > > > Want to help the Review Board project? Donate today at
> > > >http://www.reviewboard.org/donate/
> > > > Happy user? Let us know athttp://www.reviewboard.org/users/
> > > > -~----------~----~----~----~------~----~------~--~---
> > > > To unsubscribe from this group, send email to
> > > > reviewboard+unsubscr...@googlegroups.com<reviewboard%2bunsubscr...@googlegr
> > > >  oups.com>
> > <reviewboard%2bunsubscr...@googlegr oups.com>
> > > > For more options, visit this group at
>
> ...
>
> read more »

-- 
Want to help the Review Board project? Donate today at 
http://www.reviewboard.org/donate/
Happy user? Let us know at http://www.reviewboard.org/users/
-~----------~----~----~----~------~----~------~--~---
To unsubscribe from this group, send email to 
reviewboard+unsubscr...@googlegroups.com
For more options, visit this group at 
http://groups.google.com/group/reviewboard?hl=en

Reply via email to