Looks like it's not seeing any problems when trying to write it... It should
log it. Hard to really say then.

The way you upgraded shouldn't be a problem.

The only thing I can think of is that perhaps Review Board isn't pointing to
the right place for media uploads, but that seems unlikely. In the end,
Django's responsible for creating those directories.

Try this:

   $ rb-site manage /var/www/html/reviewboard shell
   >>> from reviewboard.admin.siteconfig import load_site_config
   >>> from django.conf import settings
   >>> print settings.MEDIA_ROOT
   >>> load_site_config()
   >>> print settings.MEDIA_ROOT

Show me what that says.


Christian

-- 
Christian Hammond - chip...@chipx86.com
Review Board - http://www.reviewboard.org
VMware, Inc. - http://www.vmware.com


On Mon, Mar 8, 2010 at 9:00 AM, hschnit <herve.schnitz...@gmail.com> wrote:

> Christian,
> I had that setting already turned on (and restarted Apache many times
> since then).
> The output is what you see in the Logs that I attached previously.
> Since I had an older version, I tried to disable logging, restart
> apache, reenable logging, restart apache; Then try to upload a
> screenshot. I get the following output :
>
> 2010-03-08 11:37:37,280 - INFO - Reloading logging settings
> 2010-03-08 11:38:54,909 - INFO - Logging to /var/www/html/reviewboard/
> logs/reviewboard.log with a minimum level of DEBUG
> 2010-03-08 11:38:54,909 - INFO - Log file for Review Board v1.5 beta 1
> (PID 300)
> 2010-03-08 11:39:08,671 - INFO - Logging to /var/www/html/reviewboard/
> logs/reviewboard.log with a minimum level of DEBUG
> 2010-03-08 11:39:08,671 - INFO - Log file for Review Board v1.5 beta 1
> (PID 350)
> 2010-03-08 11:39:09,492 - INFO - Logging to /var/www/html/reviewboard/
> logs/reviewboard.log with a minimum level of DEBUG
> 2010-03-08 11:39:09,493 - INFO - Log file for Review Board v1.5 beta 1
> (PID 351)
> 2010-03-08 11:39:13,904 - INFO - Logging to /var/www/html/reviewboard/
> logs/reviewboard.log with a minimum level of DEBUG
> 2010-03-08 11:39:13,904 - INFO - Log file for Review Board v1.5 beta 1
> (PID 352)
> 2010-03-08 11:39:15,563 - DEBUG - Begin: Generating diff file info for
> diffset id 1493, filediff 10561
> 2010-03-08 11:39:15,619 - DEBUG - End: Generating diff file info for
> diffset id 1493, filediff 10561
> 2010-03-08 11:39:15,619 - DEBUG - Generating diff file info for
> diffset id 1493, filediff 10561 took 0.56269 seconds
> 2010-03-08 11:39:33,023 - INFO - Logging to /var/www/html/reviewboard/
> logs/reviewboard.log with a minimum level of DEBUG
> 2010-03-08 11:39:33,024 - INFO - Log file for Review Board v1.5 beta 1
> (PID 370)
>
>
> Is there a way to get information related to the upload itself ?
> Or is there another way I should proceed to upgrade ?  Upgrade for 0.9
> to 1.0 and then to 1.5 maybe ?
>
> Thanks for the help Christian, appreciated.
>
> -Herve
>
>
> On Mar 4, 2:11 pm, Christian Hammond <chip...@chipx86.com> wrote:
> > Oh, you had an old release.
> >
> > You should turn on logging in the Logging settings page. Then restart
> Apache
> > to be sure it takes effect (working on that bug).
> >
> > Christian
> >
> > --
> > Christian Hammond - chip...@chipx86.com
> > Review Board -http://www.reviewboard.org
> > VMware, Inc. -http://www.vmware.com
> >
> > On Thu, Mar 4, 2010 at 8:11 AM, hschnit <herve.schnitz...@gmail.com>
> wrote:
> > > Thank for the suggestion Christian. I tried it without success. I did
> > > just upgrade from 0.9 to 1.5B1 though.
> > > Is there a way to get more debugging info ?
> >
> > > On Mar 3, 6:41 pm, Christian Hammond <chip...@chipx86.com> wrote:
> > > > One thing you might want to try, as I hit this once myself. Go into
> the
> > > > settings and the File Storage section. Make sure the values are what
> > > you'd
> > > > expect, and then, even if they are, hit Save. Just in case, restart
> > > Apache
> > > > after that.
> >
> > > > We had a problem once (maybe it's still here) where, after an
> upgrade,
> > > the
> > > > file storage settings weren't being taken into consideration
> properly.
> >
> > > > This may not be the cause, but I'd like to make sure.
> >
> > > > Christian
> >
> > > > --
> > > > Christian Hammond - chip...@chipx86.com
> > > > Review Board -http://www.reviewboard.org
> > > > VMware, Inc. -http://www.vmware.com
> >
> > > > On Wed, Mar 3, 2010 at 8:43 AM, hschnit <herve.schnitz...@gmail.com>
> > > wrote:
> > > > > Thanks Christian,
> > > > > I've looked into the Apache and the reviewboard logfiles (see
> below).
> > > > > There isn't much in them. Nothing related to the creation of the
> > > > > folders. There are some issues in the apache log when trying to
> > > > > display pictures that are not present.
> > > > > I had set Debug = True in the RB config. That should have turned on
> > > > > the Django debugging output, right?
> > > > > Is there something else I can set that would give me a more verbose
> > > > > output ?
> >
> > > > > -Herve
> >
> > > > > ================== LOGS ===================
> >
> > > > > RB Log
> > > > > -----------
> > > > > 2010-03-02 16:29:19,340 - INFO - Logging to
> /var/www/html/reviewboard/
> > > > > logs/reviewboard.log with a minimum level of DEBUG
> > > > > 2010-03-02 16:29:19,340 - INFO - Log file for Review Board v1.5
> beta 1
> > > > > (PID 21393)
> >
> > > > > Apache Error Log
> > > > > ---------------------------
> > > > > [Tue Mar 02 16:29:18 2010] [notice] mod_python: (Re)importing
> module
> > > > > 'django.core.handlers.modpython'
> > > > > 2010-03-02 16:29:19,340 - INFO - Logging to
> /var/www/html/reviewboard/
> > > > > logs/reviewboard.log with a minimum level of DEBUG
> > > > > 2010-03-02 16:29:19,340 - INFO - Log file for Review Board v1.5
> beta 1
> > > > > (PID 21393)
> > > > > [Tue Mar 02 16:29:20 2010] [error] [client 10.64.175.69] File does
> not
> > > > > exist:
> /var/www/html/reviewboard/htdocs/media/uploaded/images/2010/03,
> > > > > referer: http://...
> > > > > [Tue Mar 02 16:29:27 2010] [error] [client 10.64.175.69] File does
> not
> > > > > exist:
> /var/www/html/reviewboard/htdocs/media/uploaded/images/2010/03,
> > > > > referer: http://...
> > > > > [Tue Mar 02 16:36:04 2010] [error] [client 10.64.175.69] File does
> not
> > > > > exist:
> /var/www/html/reviewboard/htdocs/media/uploaded/images/2010/03,
> > > > > referer: http://...
> >
> > > > > On Mar 2, 5:33 pm, Christian Hammond <chip...@chipx86.com> wrote:
> > > > > > Hi,
> >
> > > > > > Djblets is responsible for writing the actual image file, but
> it's
> > > Django
> > > > > > that's responsible for creating those directories. Is there
> anything
> > > in
> > > > > the
> > > > > > log file?
> >
> > > > > > Christian
> >
> > > > > > --
> > > > > > Christian Hammond - chip...@chipx86.com
> > > > > > Review Board -http://www.reviewboard.org
> > > > > > VMware, Inc. -http://www.vmware.com
> >
> > > > > > On Tue, Mar 2, 2010 at 2:30 PM, hschnit <
> herve.schnitz...@gmail.com>
> > > > > wrote:
> > > > > > > Hi,
> >
> > > > > > > I'm running into what I feel like is a configuration issue. I
> > > couldn't
> > > > > > > find anything relevant on the forums, maybe some of you guys
> > > already
> > > > > > > went through this.
> >
> > > > > > > I installed the RB 1.5 beta1 version. I'm running on a RHEL5
> system
> > > > > > > with Apache 2.2 and Python 2.4
> > > > > > > The path /var/www/html/reviewboard/htdocs/media/uploaded/images
> is
> > > > > > > writable by all (777) for the purpose of debugging permissions.
> > > > > > > I can import PIL (1.1.6) properly from python.
> >
> > > > > > > What I see is that I don't get any errors while uploading the
> > > > > > > screenshots but the upload folders YY/mm/dd are not getting
> > > created.
> > > > > > > The screenshot therefore doesn't display on the review request
> > > since
> > > > > > > the images are not present in the 'uploaded' folder.
> >
> > > > > > > Does anyone has some pointer to where to look ?
> > > > > > > What module is responsible for creating those folders ? PIL?
> RB?
> >
> > > > > > > Thanks,
> > > > > > > -Herve
> >
> > > > > > > --
> > > > > > > Want to help the Review Board project? Donate today at
> > > > > > >http://www.reviewboard.org/donate/
> > > > > > > Happy user? Let us know athttp://www.reviewboard.org/users/
> > > > > > > -~----------~----~----~----~------~----~------~--~---
> > > > > > > To unsubscribe from this group, send email to
> > > > > > > reviewboard+unsubscr...@googlegroups.com<reviewboard%2bunsubscr...@googlegroups.com>
> <reviewboard%2bunsubscr...@googlegroups.com<reviewboard%252bunsubscr...@googlegroups.com>
> >
> > > <reviewboard%2bunsubscr...@googlegroups.com<reviewboard%252bunsubscr...@googlegroups.com>
> <reviewboard%252bunsubscr...@googlegroups.com<reviewboard%25252bunsubscr...@googlegroups.com>
> >
> >
> > > > > <reviewboard%2bunsubscr...@googlegroups.com<reviewboard%252bunsubscr...@googlegroups.com>
> <reviewboard%252bunsubscr...@googlegroups.com<reviewboard%25252bunsubscr...@googlegroups.com>
> >
> > > <reviewboard%252bunsubscr...@googlegroups.com<reviewboard%25252bunsubscr...@googlegroups.com>
> <reviewboard%25252bunsubscr...@googlegroups.com<reviewboard%2525252bunsubscr...@googlegroups.com>
> >
> >
> > > > > > > For more options, visit this group at
> > > > > > >http://groups.google.com/group/reviewboard?hl=en
> >
> > > > > --
> > > > > Want to help the Review Board project? Donate today at
> > > > >http://www.reviewboard.org/donate/
> > > > > Happy user? Let us know athttp://www.reviewboard.org/users/
> > > > > -~----------~----~----~----~------~----~------~--~---
> > > > > To unsubscribe from this group, send email to
> > > > > reviewboard+unsubscr...@googlegroups.com<reviewboard%2bunsubscr...@googlegroups.com>
> <reviewboard%2bunsubscr...@googlegroups.com<reviewboard%252bunsubscr...@googlegroups.com>
> >
> > > <reviewboard%2bunsubscr...@googlegroups.com<reviewboard%252bunsubscr...@googlegroups.com>
> <reviewboard%252bunsubscr...@googlegroups.com<reviewboard%25252bunsubscr...@googlegroups.com>
> >
> >
> > > > > For more options, visit this group at
> > > > >http://groups.google.com/group/reviewboard?hl=en
> >
> > > --
> > > Want to help the Review Board project? Donate today at
> > >http://www.reviewboard.org/donate/
> > > Happy user? Let us know athttp://www.reviewboard.org/users/
> > > -~----------~----~----~----~------~----~------~--~---
> > > To unsubscribe from this group, send email to
> > > reviewboard+unsubscr...@googlegroups.com<reviewboard%2bunsubscr...@googlegroups.com>
> <reviewboard%2bunsubscr...@googlegroups.com<reviewboard%252bunsubscr...@googlegroups.com>
> >
> > > For more options, visit this group at
> > >http://groups.google.com/group/reviewboard?hl=en
>
> --
> Want to help the Review Board project? Donate today at
> http://www.reviewboard.org/donate/
> Happy user? Let us know at http://www.reviewboard.org/users/
> -~----------~----~----~----~------~----~------~--~---
> To unsubscribe from this group, send email to
> reviewboard+unsubscr...@googlegroups.com<reviewboard%2bunsubscr...@googlegroups.com>
> For more options, visit this group at
> http://groups.google.com/group/reviewboard?hl=en
>

-- 
Want to help the Review Board project? Donate today at 
http://www.reviewboard.org/donate/
Happy user? Let us know at http://www.reviewboard.org/users/
-~----------~----~----~----~------~----~------~--~---
To unsubscribe from this group, send email to 
reviewboard+unsubscr...@googlegroups.com
For more options, visit this group at 
http://groups.google.com/group/reviewboard?hl=en

Reply via email to