Hi, Christian,
    I had re-installed RB 1.5 Release Version of 1.5 beta1; It has no
such problem.
    Now another problem occured when using post-reivew
"RBTools-0.2rc1.tar.gz"; I installed it and try to post review request
with it. But it aways report errors of
  """
File "/data1/john/bin/develop_tools/python/lib/python2.5/site-packages/
RBTools-0.2rc1-py2.5.egg/rbtools/postreview.py", line 656, in
_encode_multipart_formdata
    return content_type, content.decode('utf-8').encode('utf-8')
  File "/data1/john/bin/develop_tools/python/lib/python2.5/encodings/
utf_8.py", line 16, in decode
    return codecs.utf_8_decode(input, errors, True)
UnicodeDecodeError: 'utf8' codec can't decode bytes in position
3541-3542: invalid data
  """
   As I saw the code return content_type, content.encode('utf-8'), I
changed it into :
 eturn content_type, content.decode('GB18030').encode('utf-8'); Then
things are OK.
   Is RBTools of this version considers local character settings?

Best Regards!

On 3月26日, 上午10时08分, JohnHenry <qhlonl...@163.com> wrote:
> Yes, I had tried these, I had even change that in the source file
> cvs.py ,function ' check_repository', directly setting the path  to
> the form of :pserver:John:myp...@192.168.3.150:/data1/john/
> tempcvsroot, But the on the Web UI, The repository settings, It will
> still report this problem. Then I tried to change setting info of
> database table 'scmtools_repository' directly, and tried to generate
> reviewrequest with WebUI 'New ReviewRequest', But failed again. (The
> post-review will aways repost /json/reviewboard/new/. site
> unaccessable. I don't konw why, My post-review is 20100323 nightily)
>
> Best Regards!
>
> On 3月26日, 上午2时15分, Christian Hammond <chip...@chipx86.com> wrote:
>
> > Remove the :pserver: part of the path in Review Board. If Review Board sees
> > that, it will ignore the username/password. If it's missing, though, it will
> > add it along with the username/password.
>
> > Christian
>
> > --
> > Christian Hammond - chip...@chipx86.com
> > Review Board -http://www.reviewboard.org
> > VMware, Inc. -http://www.vmware.com
>
> > 2010/3/25 JohnHenry <qhlonl...@163.com>
>
> > > I had keep tracking the source, The command execution :cvs -f -
> > > d :pserver:j...@192.168.3.150:/data1/john/tempcvsroot checkout -p
> > > CVSROOT/modules
> > >  get error. and failure value is 1, message is :
> > > cvs checkout: authorization failed: server 192.168.3.150 rejected
> > > access
> > > cvs checkout: used empty password; try "cvs login" with a real password
> > > \n'
> > >  How to deal with that error? The Reviewboard did not allow CVS login;
> > >  and I had set Username and password of CVS Repository, But it seems
> > > useless for Reviewboard
>
> > > Best Regards!
>
> > > On 3月25日, 下午6时03分, Christian Hammond <chip...@chipx86.com> wrote:
> > > > Yes, you can't select ClearCase and expect it to work. It will treat it
> > > as a
> > > > ClearCase server.
>
> > > > What Review Board does to check your CVS server is to do:
>
> > > > cvs -f -d :pserver:j...@192.168.3.150:/data1/john/tempcvsroot checkout
> > > -p
> > > > CVSROOT/modules
>
> > > > If that fails for any reason, it will report the repository as invalid.
>
> > > > Christian
>
> > > > --
> > > > Christian Hammond - chip...@chipx86.com
> > > > Review Board -http://www.reviewboard.org
> > > > VMware, Inc. -http://www.vmware.com
>
> > > > 2010/3/25 JohnHenry <qhlonl...@163.com>
>
> > > > > Not simply item chaos, When I select ClearCase, The following job of
> > > > > RR generation is completely impossible.
>
> > > > > On 3月25日, 下午3时45分, JohnHenry <qhlonl...@163.com> wrote:
> > > > > > Hi,
> > > > > >     I had just tried to install RB of version 1.5, But When I add a
> > > > > > repository of CVS, It always report
> > > > > > "A repository was not found at the specified path." When I tried to
> > > > > > select "ClearCase" and set the same path of CVS, Then success.
> > > > > >     I think Reviewboard had chaos in custom Repository "Repository
> > > > > > type:" setting selections.
>
> > > > > > Best Regards!
>
> > > > > --
> > > > > Want to help the Review Board project? Donate today at
> > > > >http://www.reviewboard.org/donate/
> > > > > Happy user? Let us know athttp://www.reviewboard.org/users/
> > > > > -~----------~----~----~----~------~----~------~--~---
> > > > > To unsubscribe from this group, send email to
> > > > > reviewboard+unsubscr...@googlegroups.com<reviewboard%2bunsubscr...@googlegroups.com>
> > > <reviewboard%2bunsubscr...@googlegr-oups.com<reviewboard%252bunsubscr...@googlegr-oups.com>
>
> > > > > For more options, visit this group at
> > > > >http://groups.google.com/group/reviewboard?hl=en
>
> > > > > To unsubscribe from this group, send email to reviewboard+
> > > > > unsubscribegooglegroups.com or reply to this email with the words
> > > "REMOVE
> > > > > ME" as the subject.- 隐藏被引用文字 -
>
> > > > - 显示引用的文字 -
>
> > > --
> > > Want to help the Review Board project? Donate today at
> > >http://www.reviewboard.org/donate/
> > > Happy user? Let us know athttp://www.reviewboard.org/users/
> > > -~----------~----~----~----~------~----~------~--~---
> > > To unsubscribe from this group, send email to
> > > reviewboard+unsubscr...@googlegroups.com<reviewboard%2bunsubscr...@googlegroups.com>
> > > For more options, visit this group at
> > >http://groups.google.com/group/reviewboard?hl=en
>
> > > To unsubscribe from this group, send email to reviewboard+
> > > unsubscribegooglegroups.com or reply to this email with the words "REMOVE
> > > ME" as the subject.

-- 
Want to help the Review Board project? Donate today at 
http://www.reviewboard.org/donate/
Happy user? Let us know at http://www.reviewboard.org/users/
-~----------~----~----~----~------~----~------~--~---
To unsubscribe from this group, send email to 
reviewboard+unsubscr...@googlegroups.com
For more options, visit this group at 
http://groups.google.com/group/reviewboard?hl=en

To unsubscribe from this group, send email to 
reviewboard+unsubscribegooglegroups.com or reply to this email with the words 
"REMOVE ME" as the subject.

Reply via email to