This is obviously not a real solution we can ship with.

Try instead to replace the 'imp.find_module("ldap")' with 'import ldap'

Sometimes imp.find_module doesn't work, on some installs. This is a Python
packaging issue.

Christian

-- 
Christian Hammond - chip...@chipx86.com
Review Board - http://www.reviewboard.org
VMware, Inc. - http://www.vmware.com


On Fri, Mar 26, 2010 at 7:01 PM, wasim <wasimka...@gmail.com> wrote:

> Hi Noah,
>
> Sorry for the late reply. I only have 2.5 on that machine I never
> installed python before. I solved the problem! I installed OpenLDAP
> 2.4.10 then added its bin directory to my path. Which got import ldap
> to work but still gave me the same error, so I commented out the
> triggering of the error and it worked. In checks.py in the following
> lines:
>
> def get_can_enable_ldap():
>    """
>    Checks whether LDAP authentication can be enabled.
>    """
>    try:
>        imp.find_module("ldap")
>        return (True, None)
>    except ImportError:
>        return (False, _(
>             'LDAP authentication requires the python-ldap library,
> which '
>            'is not installed.'
>        ))
>
> I just commented out return false and wrote return true and it worked!
> I tried with a bogus login and it didn't work which tells me it's not
> letting just anyone pass. Thanks for the quick response Noah.
>
> Thank you,
> Wasim
>
>
> On Mar 25, 6:24 pm, Noah Campbell <noahcampb...@gmail.com> wrote:
> > Sometimes using easy_install will install the library for a particular
> > version of python on your machine.  For example if you have 2.5 and
> > 2.6 and the easy_install you used is 2.5, the libraries will be
> > installed there.  When you start RB may be using 2.6, hence the error
> > message.
> >
> > I don't have the resources at hand, but you can google how to
> > determine where easy_install is putting the libraries.
> >
> > -Noah
> >
> > On Thu, Mar 25, 2010 at 4:06 PM, wasim <wasimka...@gmail.com> wrote:
> > > The Apache service you mean? If so then yes. The error appears in
> > > ReviewBoard on the general settings page under the LDAP Server box.
> > > The box is grayed out so I can't enter the server address and the the
> > > message is under it. Like below
> >
> > > LDAP Server:  [greyed out box would be here]
> > > The LDAP server to authenticate with. For example: ldap://localhost:389
> >
> > > (in red font)LDAP authentication requires the python-ldap library,
> > > which is not installed.
> >
> > > On Mar 25, 5:58 pm, Noah Campbell <noahcampb...@gmail.com> wrote:
> > >> After the reboot were you successful in starting the service?
> >
> > >> On Thu, Mar 25, 2010 at 3:55 PM, wasim <wasimka...@gmail.com> wrote:
> > >> > Hello Everyone,
> >
> > >> > I'm new to ReviewBoard, I installed it today. I installed it on
> > >> > Windows and would like to use LDAP or AD authentication. On the
> > >> > settings page when I change the authentication method to LDAP I get
> a
> > >> > message in red "LDAP authentication requires the python-ldap
> library,
> > >> > which is not installed". I think its installed because I ran
> > >> > "easy_install python-ldap" and it went through without any errors
> and
> > >> > I rebooted the server after installing it. I have no Python
> background
> > >> > but I have solid background in LDAP, AD, Apache, Windows Server, MS
> > >> > SQL, Perl and C# if any of that helps. I appreciate the help in
> > >> > advance.
> >
> > >> > Thank you,
> > >> > Wasim
> >
> > >> > -----
> > >> > Wasim Kayal
> > >> > EMC Corporation
> >
> > >> > --
> > >> > Want to help the Review Board project? Donate today athttp://
> www.reviewboard.org/donate/
> > >> > Happy user? Let us know athttp://www.reviewboard.org/users/
> > >> > -~----------~----~----~----~------~----~------~--~---
> > >> > To unsubscribe from this group, send email to
> reviewboard+unsubscr...@googlegroups.com<reviewboard%2bunsubscr...@googlegroups.com>
> > >> > For more options, visit this group athttp://
> groups.google.com/group/reviewboard?hl=en
> >
> > >> > To unsubscribe from this group, send email to reviewboard+
> unsubscribegooglegroups.com or reply to this email with the words "REMOVE
> ME" as the subject.
> >
> > > --
> > > Want to help the Review Board project? Donate today athttp://
> www.reviewboard.org/donate/
> > > Happy user? Let us know athttp://www.reviewboard.org/users/
> > > -~----------~----~----~----~------~----~------~--~---
> > > To unsubscribe from this group, send email to
> reviewboard+unsubscr...@googlegroups.com<reviewboard%2bunsubscr...@googlegroups.com>
> > > For more options, visit this group athttp://
> groups.google.com/group/reviewboard?hl=en
> >
> > > To unsubscribe from this group, send email to reviewboard+
> unsubscribegooglegroups.com or reply to this email with the words "REMOVE
> ME" as the subject.
>
> --
> Want to help the Review Board project? Donate today at
> http://www.reviewboard.org/donate/
> Happy user? Let us know at http://www.reviewboard.org/users/
> -~----------~----~----~----~------~----~------~--~---
> To unsubscribe from this group, send email to
> reviewboard+unsubscr...@googlegroups.com<reviewboard%2bunsubscr...@googlegroups.com>
> For more options, visit this group at
> http://groups.google.com/group/reviewboard?hl=en
>
> To unsubscribe from this group, send email to reviewboard+
> unsubscribegooglegroups.com or reply to this email with the words "REMOVE
> ME" as the subject.
>

-- 
Want to help the Review Board project? Donate today at 
http://www.reviewboard.org/donate/
Happy user? Let us know at http://www.reviewboard.org/users/
-~----------~----~----~----~------~----~------~--~---
To unsubscribe from this group, send email to 
reviewboard+unsubscr...@googlegroups.com
For more options, visit this group at 
http://groups.google.com/group/reviewboard?hl=en

To unsubscribe from this group, send email to 
reviewboard+unsubscribegooglegroups.com or reply to this email with the words 
"REMOVE ME" as the subject.

Reply via email to