Hi,

I could successfully install RB with Postgres in Windows 7. I could
login, add repos, remove users etc. However I cannot setup post review
to work. I've been struggling for the past 3 days on this and read
several forum posts on this, but nothing helped.

- I setup a repository using the Web UI. We are using SVN+Apache, so I
gave the http url in both PATH and mirror PATH. This is the URL I
enter in Tortoise for checking out and others.
- I checked out a working copy and ran post-review --server=RB_URL -d
and always getting the following output:
- I cannot create a new review request through Web UI also. The
reposiroty dropdown is not showing any values. Also a script error is
thrown 'Object does not support this property'

>>> svn info
>>> repository info: Path: http://xxx/svn/CE, Base path: /trunk/branches/Ch, 
>>> Supports changesets: False
>>> svn diff --diff-cmd=diff
>>> svn info WebContent/htdocs/index.html
>>> svn info WebContent/htdocs/index.html
>>> svn info WebContent/htdocs/index.html
>>> svn info WebContent/htdocs/index.html
>>> Looking for 'RB_IP /RBoard/' cookie in C:\Users\Administrator\AppData\R
oaming\.post-review-cookies.txt
>>> Loaded valid cookie -- no login required
>>> HTTP GETting /api/json/repositories/
>>> HTTP GETting /api/json/repositories/1/info/
>>> Got API Error 210 (HTTP code 200): There was an error fetching extended info
rmation for this repository.
>>> Error data: {'stat': 'fail', 'err': {'msg': 'There was an error fetching ext
ended information for this repository.', 'code': 210}}
>>> Attempting to create review request on http://xxx/svn/CE for None
>>> HTTP POSTing to http://yyy/Rboard/api/json/reviewrequests/new/: {'rep
ository_path': 'http://xxx/svn/CE'}
>>> Got API Error 206 (HTTP code 200): The repository path specified is not in t
he list of known repositories
>>> Error data: {'repository_path': 'http://xxx/svn/CE', 'stat': 'fail'
, 'err': {'msg': 'The repository path specified is not in the list of
known repo
sitories', 'code': 206}}
Error creating review request: The repository path specified is not in
the list
of known repositories (HTTP 200, API Error 206)

Thanks in advance

-- 
Want to help the Review Board project? Donate today at 
http://www.reviewboard.org/donate/
Happy user? Let us know at http://www.reviewboard.org/users/
-~----------~----~----~----~------~----~------~--~---
To unsubscribe from this group, send email to 
reviewboard+unsubscr...@googlegroups.com
For more options, visit this group at 
http://groups.google.com/group/reviewboard?hl=en

To unsubscribe, reply using "remove me" as the subject.

Reply via email to