I believe PySVN 1.7.2 would be sufficient.

One quick way to make sure it does work is to run Python on that server and
type:

    import pysvn

If that fails, then Python isn't seeing the module.

Otherwise, if you turn on logging in Review Board (you may have to restart
Apache for logging to take effect) you may be able to see an error
indicating what's going wrong when navigating to the New Review Request
page.

Christian

-- 
Christian Hammond - chip...@chipx86.com
Review Board - http://www.reviewboard.org
VMware, Inc. - http://www.vmware.com


On Wed, Apr 14, 2010 at 12:34 AM, sgkannan <sakthi.kan...@gmail.com> wrote:

> Dear Chris,
>
> Thanks. We are runing SVN/1.4.4 on Apache/2.0.59 (Win32) DAV/2
> mod_auth_sspi/1.0.4. I installed PySVN 1.7.2 which says it supports
> SVN 1.6.6 and earlier. Do I need to install the specific version
> compiled against 1.4.4? I could not find any windows installer
> specific for 1.4.4 in pysvn downloads although the page
> http://pysvn.tigris.org/project_downloads.html says "Older releases
> are available that where built against svn 1.4".
>
> Please advice.
>
> Thanks in advance.
>
> On Apr 14, 10:44 am, Christian Hammond <chip...@chipx86.com> wrote:
> > Hi,
> >
> > Okay, I misread the debug output and thought you were running 1.5. In
> 1.0.x,
> > there's no repository visibility setting, so that's fine.
> >
> > What may be happening then is that the dependencies for this type of
> > repository are not installed. You need a compatible version of pysvn
> > installed. 1.7.x is known to work.
> >
> > Christian
> >
> > --
> > Christian Hammond - chip...@chipx86.com
> > Review Board -http://www.reviewboard.org
> > VMware, Inc. -http://www.vmware.com
> >
> >
> >
> > On Tue, Apr 13, 2010 at 10:22 PM, sgkannan <sakthi.kan...@gmail.com>
> wrote:
> > > Dear Chris,
> >
> > > Thanks for your reply. I live in India and hence there would be some
> > > delay in respone from my side.
> >
> > > >> Make sure that the Repository is set to be visible in the admin UI.
> > > How do I set it to visible. I entered values for Name, Path, Mirror
> > > Path, Repo type, username and password and clicked on Save. I do not
> > > see any columns for visibility in scmtools_repository table also.
> >
> > > > Also make sure that the URL is *exactly* the URL that post-review is
> > > attempting to use.
> > > Yes, I double checked. The URL is exactly what is use in Tortoise.
> >
> > > > The "Object does not support this property" is alarming. Do you have
> more
> > > information on this?
> > > I've installed RB 1.0.6 on Python 2.5. I installed all the components
> > > out of the box and have not setup even a single user and have not
> > > configured a single repository. When I log in and go to new review
> > > request page in IE 7, I see a Java script error - Object does not
> > > support this property. Line 177 Char 9 URL:<RB>/r/new. When I setup a
> > > couple of users with all privilegages and setup repository and tried
> > > visiting the page again - i'm still seeing the same error. The machine
> > > where RB in installed is in network and when i try to access from
> > > other mahines which has different browsers and IE versions, I still
> > > see the same error.
> >
> > > Looking forward to your continued support to setup RB.
> >
> > > Thanks.
> >
> > > On Apr 14, 1:13 am, Christian Hammond <chip...@chipx86.com> wrote:
> > > > Hi,
> >
> > > > Make sure that the Repository is set to be visible in the admin UI.
> Also
> > > > make sure that the URL is *exactly* the URL that post-review is
> > > attempting
> > > > to use.
> >
> > > > The "Object does not support this property" is alarming. Do you have
> more
> > > > information on this?
> >
> > > > Which version of Review Board is this? I assume it's a 1.5 build, but
> can
> > > > you tell me which release/nightly?
> >
> > > > Christian
> >
> > > > --
> > > > Christian Hammond - chip...@chipx86.com
> > > > Review Board -http://www.reviewboard.org
> > > > VMware, Inc. -http://www.vmware.com
> >
> > > > On Tue, Apr 13, 2010 at 5:16 AM, sgkannan <sakthi.kan...@gmail.com>
> > > wrote:
> > > > > Hi,
> >
> > > > > I could successfully install RB with Postgres in Windows 7. I could
> > > > > login, add repos, remove users etc. However I cannot setup post
> review
> > > > > to work. I've been struggling for the past 3 days on this and read
> > > > > several forum posts on this, but nothing helped.
> >
> > > > > - I setup a repository using the Web UI. We are using SVN+Apache,
> so I
> > > > > gave the http url in both PATH and mirror PATH. This is the URL I
> > > > > enter in Tortoise for checking out and others.
> > > > > - I checked out a working copy and ran post-review --server=RB_URL
> -d
> > > > > and always getting the following output:
> > > > > - I cannot create a new review request through Web UI also. The
> > > > > reposiroty dropdown is not showing any values. Also a script error
> is
> > > > > thrown 'Object does not support this property'
> >
> > > > > >>> svn info
> > > > > >>> repository info: Path:http://xxx/svn/CE, Base path:
> > > > > /trunk/branches/Ch, Supports changesets: False
> > > > > >>> svn diff --diff-cmd=diff
> > > > > >>> svn info WebContent/htdocs/index.html
> > > > > >>> svn info WebContent/htdocs/index.html
> > > > > >>> svn info WebContent/htdocs/index.html
> > > > > >>> svn info WebContent/htdocs/index.html
> > > > > >>> Looking for 'RB_IP /RBoard/' cookie in
> > > C:\Users\Administrator\AppData\R
> > > > > oaming\.post-review-cookies.txt
> > > > > >>> Loaded valid cookie -- no login required
> > > > > >>> HTTP GETting /api/json/repositories/
> > > > > >>> HTTP GETting /api/json/repositories/1/info/
> > > > > >>> Got API Error 210 (HTTP code 200): There was an error fetching
> > > extended
> > > > > info
> > > > > rmation for this repository.
> > > > > >>> Error data: {'stat': 'fail', 'err': {'msg': 'There was an error
> > > > > fetching ext
> > > > > ended information for this repository.', 'code': 210}}
> > > > > >>> Attempting to create review request onhttp://xxx/svn/CEforNone
> > > > > >>> HTTP POSTing
> tohttp://yyy/Rboard/api/json/reviewrequests/new/:{'rep
> > > > > ository_path': 'http://xxx/svn/CE'}
> > > > > >>> Got API Error 206 (HTTP code 200): The repository path
> specified is
> > > not
> > > > > in t
> > > > > he list of known repositories
> > > > > >>> Error data: {'repository_path': 'http://xxx/svn/CE', 'stat':
> > > 'fail'
> > > > > , 'err': {'msg': 'The repository path specified is not in the list
> of
> > > > > known repo
> > > > > sitories', 'code': 206}}
> > > > > Error creating review request: The repository path specified is not
> in
> > > > > the list
> > > > > of known repositories (HTTP 200, API Error 206)
> >
> > > > > Thanks in advance
> >
> > > > > --
> > > > > Want to help the Review Board project? Donate today at
> > > > >http://www.reviewboard.org/donate/
> > > > > Happy user? Let us know athttp://www.reviewboard.org/users/
> > > > > -~----------~----~----~----~------~----~------~--~---
> > > > > To unsubscribe from this group, send email to
> > > > > reviewboard+unsubscr...@googlegroups.com<reviewboard%2bunsubscr...@googlegroups.com>
> <reviewboard%2bunsubscr...@googlegr­oups.com>
> > > <reviewboard%2bunsubscr...@googlegr­oups.com>
> > > > > For more options, visit this group at
> > > > >http://groups.google.com/group/reviewboard?hl=en
> >
> > > > > To unsubscribe, reply using "remove me" as the subject.- Hide
> quoted
> > > text -
> >
> > > > - Show quoted text -
> >
> > > --
> > > Want to help the Review Board project? Donate today at
> > >http://www.reviewboard.org/donate/
> > > Happy user? Let us know athttp://www.reviewboard.org/users/
> > > -~----------~----~----~----~------~----~------~--~---
> > > To unsubscribe from this group, send email to
> > > reviewboard+unsubscr...@googlegroups.com<reviewboard%2bunsubscr...@googlegroups.com>
> <reviewboard%2bunsubscr...@googlegr­oups.com>
> > > For more options, visit this group at
> > >http://groups.google.com/group/reviewboard?hl=en- Hide quoted text -
> >
> > - Show quoted text -
>
> --
> Want to help the Review Board project? Donate today at
> http://www.reviewboard.org/donate/
> Happy user? Let us know at http://www.reviewboard.org/users/
> -~----------~----~----~----~------~----~------~--~---
> To unsubscribe from this group, send email to
> reviewboard+unsubscr...@googlegroups.com<reviewboard%2bunsubscr...@googlegroups.com>
> For more options, visit this group at
> http://groups.google.com/group/reviewboard?hl=en
>

-- 
Want to help the Review Board project? Donate today at 
http://www.reviewboard.org/donate/
Happy user? Let us know at http://www.reviewboard.org/users/
-~----------~----~----~----~------~----~------~--~---
To unsubscribe from this group, send email to 
reviewboard+unsubscr...@googlegroups.com
For more options, visit this group at 
http://groups.google.com/group/reviewboard?hl=en

Reply via email to