RB is definitely installed for Python 2.5.  So is reviewboard.settings
a file?  I've done a find . -name reviewboard.settings in /usr/lib/
python2.5 and /var/www/reviewboard and the file is not there.  As far
as I know until the restart on Sunday, no files have been changed.
What do I need to do to fix this? Do I need to re-install? Guidence
would be appreciated.  Thanks

On Aug 24, 3:26 pm, Christian Hammond <chip...@chipx86.com> wrote:
> reviewboard.settings is part of Review Board itself. It could be that your
> install is broken or your web server is pointing to the wrong path. The file
> itself does not change, so the syntax errors warning shouldn't be a concern.
>
> Another thing to make sure is that Review Board is installed for Python 2.5
> and not some other version.
>
> Christian
>
> --
> Christian Hammond - chip...@chipx86.com
> Review Board -http://www.reviewboard.org
> VMware, Inc. -http://www.vmware.com
>
> On Tue, Aug 24, 2010 at 2:30 PM, tag_98007work <tag98007w...@gmail.com>wrote:
>
>
>
> > I've been running Reviewboard 1.5 RC1 for about a week.  According to
> > the logs sometime Sunday morning there was a restart, after that I'm
> > getting the messages:
>
> > Error log:
>
> > [Sun Aug 22 08:03:41 2010] [notice] SIGUSR1 received.  Doing graceful
> > restart
> > /usr/lib/python2.5/site-packages/pycrypto-2.2-py2.5-linux-i686.egg/
> > Crypto/Util/randpool.py:40: RandomPool_DeprecationWarning: This
> > application uses RandomPool, which is BROKEN in older releases.  See
> >http://www.pycrypto.org/randpool-broken
> >  RandomPool_DeprecationWarning)
> > /usr/lib/python2.5/site-packages/pycrypto-2.2-py2.5-linux-i686.egg/
> > Crypto/Util/randpool.py:40: RandomPool_DeprecationWarning: This
> > application uses RandomPool, which is BROKEN in older releases.  See
> >http://www.pycrypto.org/randpool-broken
> >  RandomPool_DeprecationWarning)
> > [Sun Aug 22 08:03:41 2010] [notice] mod_python: Creating 8 session
> > mutexes based on 3 max processes and 25 max threads.
> > [Sun Aug 22 08:03:41 2010] [notice] mod_python: using mutex_directory /
> > tmp
> > [Sun Aug 22 08:03:42 2010] [notice] Apache/2.2.9 (Debian) mod_python/
> > 3.3.1 Python/2.5.2 configured -- resuming normal operations
> > [Sun Aug 22 08:08:10 2010] [error] [client 192.168.54.132] mod_python
> > (pid=12535, interpreter='reviewboard_reviewboard',
> > phase='PythonHandler', handler='django.core.handlers.modpython'):
> > Application error, referer:http://thall.wgti.net/reviews/r/17/
> > [Sun Aug 22 08:08:10 2010] [error] [client 192.168.54.132] ServerName:
> > 'reviewboard', referer:http://thall.wgti.net/reviews/r/17/
> > [Sun Aug 22 08:08:10 2010] [error] [client 192.168.54.132]
> > DocumentRoot: '/var/www/reviewboard/htdocs', referer:
> >http://thall.wgti.net/reviews/r/17/
> > [Sun Aug 22 08:08:10 2010] [error] [client 192.168.54.132] URI: '/
> > reviews/api/json/reviewrequests/17/last-update/', referer:
> >http://thall.wgti.net/reviews/r/17/
> > [Sun Aug 22 08:08:10 2010] [error] [client 192.168.54.132] Location: '/
> > reviews/', referer:http://thall.wgti.net/reviews/r/17/
> > [Sun Aug 22 08:08:10 2010] [error] [client 192.168.54.132] Directory:
> > None, referer:http://thall.wgti.net/reviews/r/17/
> > [Sun Aug 22 08:08:10 2010] [error] [client 192.168.54.132] Filename: '/
> > var/www/reviewboard/htdocs/reviews', referer:
> >http://thall.wgti.net/reviews/r/17/
> > [Sun Aug 22 08:08:10 2010] [error] [client 192.168.54.132] PathInfo: '/
> > api/json/reviewrequests/17/last-update/', referer:
> >http://thall.wgti.net/reviews/r/17/
> > [Sun Aug 22 08:08:10 2010] [error] [client 192.168.54.132] Traceback
> > (most recent call last):, referer:http://thall.wgti.net/reviews/r/17/
> > [Sun Aug 22 08:08:10 2010] [error] [client 192.168.54.132]   File "/
> > usr/lib/python2.5/site-packages/mod_python/importer.py", line 1537, in
> > HandlerDispatch\n    default=default_handler, arg=req,
> > silent=hlist.silent), referer:http://thall.wgti.net/reviews/r/17/
> > [Sun Aug 22 08:08:10 2010] [error] [client 192.168.54.132]   File "/
> > usr/lib/python2.5/site-packages/mod_python/importer.py", line 1229, in
> > _process_target\n    result = _execute_target(config, req, object,
> > arg), referer:http://thall.wgti.net/reviews/r/17/
> > [Sun Aug 22 08:08:10 2010] [error] [client 192.168.54.132]   File "/
> > usr/lib/python2.5/site-packages/mod_python/importer.py", line 1128, in
> > _execute_target\n    result = object(arg), referer:
> >http://thall.wgti.net/reviews/r/17/
> > [Sun Aug 22 08:08:10 2010] [error] [client 192.168.54.132]   File "/
> > usr/lib/python2.5/site-packages/Django-1.2.1-py2.5.egg/django/core/
> > handlers/modpython.py", line 228, in handler\n    return
> > ModPythonHandler()(req), referer:http://thall.wgti.net/reviews/r/17/
> > [Sun Aug 22 08:08:10 2010] [error] [client 192.168.54.132]   File "/
> > usr/lib/python2.5/site-packages/Django-1.2.1-py2.5.egg/django/core/
> > handlers/modpython.py", line 191, in __call__\n
> > self.load_middleware(), referer:http://thall.wgti.net/reviews/r/17/
> > [Sun Aug 22 08:08:10 2010] [error] [client 192.168.54.132]   File "/
> > usr/lib/python2.5/site-packages/Django-1.2.1-py2.5.egg/django/utils/
> > functional.py", line 276, in __getattr__\n    self._setup(), referer:
> >http://thall.wgti.net/reviews/r/17/
> > [Sun Aug 22 08:08:10 2010] [error] [client 192.168.54.132]   File "/
> > usr/lib/python2.5/site-packages/Django-1.2.1-py2.5.egg/django/conf/
> > __init__.py", line 40, in _setup\n    self._wrapped =
> > Settings(settings_module), referer:http://thall.wgti.net/reviews/r/17/
> > [Sun Aug 22 08:08:10 2010] [error] [client 192.168.54.132]   File "/
> > usr/lib/python2.5/site-packages/Django-1.2.1-py2.5.egg/django/conf/
> > __init__.py", line 75, in __init__\n    raise ImportError("Could not
> > import settings '%s' (Is it on sys.path? Does it have syntax errors?):
> > %s" % (self.SETTINGS_MODULE, e)), referer:
> >http://thall.wgti.net/reviews/r/17/
> > [Sun Aug 22 08:08:10 2010] [error] [client 192.168.54.132]
> > ImportError: Could not import settings 'reviewboard.settings' (Is it
> > on sys.path? Does it have syntax errors?): No module named
> > reviewboard.settings, referer:http://thall.wgti.net/reviews/r/17/
>
> > Where should reviewboard.settings live?
>
> > Any insight would be great.
>
> > Thanks
>
> > --
> > Want to help the Review Board project? Donate today at
> >http://www.reviewboard.org/donate/
> > Happy user? Let us know athttp://www.reviewboard.org/users/
> > -~----------~----~----~----~------~----~------~--~---
> > To unsubscribe from this group, send email to
> > reviewboard+unsubscr...@googlegroups.com<reviewboard%2bunsubscr...@googlegr­oups.com>
> > For more options, visit this group at
> >http://groups.google.com/group/reviewboard?hl=en- Hide quoted text -
>
> - Show quoted text -

-- 
Want to help the Review Board project? Donate today at 
http://www.reviewboard.org/donate/
Happy user? Let us know at http://www.reviewboard.org/users/
-~----------~----~----~----~------~----~------~--~---
To unsubscribe from this group, send email to 
reviewboard+unsubscr...@googlegroups.com
For more options, visit this group at 
http://groups.google.com/group/reviewboard?hl=en

Reply via email to