I have narrowed this down further.

I created a "service" account in Reviewboard for post-review to create
Review Requests via the webapi.  That service account is conveniently
called "post-review."  If I create a Review Request from post-review
(the CLI) and NOT publish it, then go to RB, login as "post-review"
and execute the webapi URL to publish the Review Request, it will be
published but emails will NOT be sent out.  However, if I create the
Review Request from the CLI and not publish it (same as before), then
login to RB as MY account (not "post-review") and execute the webapi
call to publish, the emails ARE sent out.  This is curious because
I've tried setting "post-review" as a Superuser, and still no emails
were sent.

Any ideas?


On Sep 1, 6:31 pm, RShelley <12gaugeme...@gmail.com> wrote:
> This has me pretty baffled.  I wrote a Java API awhile ago to publish
> a review request, among other things.  The API does in fact publish
> the request (it's visible to users, and is no longer in draft mode),
> however, emails are not being sent to the groups and reviewers on the
> request.  If I post a Review to a Review Request, the emails send just
> fine.
> The strange thing is, if I use the "--publish" command of post-review,
> it works fine and emails are sent.  I looked at the source code for
> post-review and the webapi URL in there is the same as what I'm using
> ("/api/json/reviewrequests/<ID>/publish/", POST, no fields).  If I put
> the publish URL into my browser and do it, it also works.  I double
> checked that my "publish" call is a POST, and that I am logging in via
> the webapi (I imagine the publish would fail if I wasn't).  I looked
> at the source for reviewboard itself, and there's nothing I can see
> out of the ordinary for sending the emails.  The account I'm
> publishing with I've even set to superuser just in case there was a
> permission issue, and that didn't solve it either.  I have also
> verified that the groups/reviewers are added BEFORE the publish call
> is made.  If I leave it as is, published, and re-run it to republish
> it, emails are still never sent out to the groups and reviewers (so I
> don't think it's something to do with things not being saved timely
> enough) - and in fact, the Review Request will be updated and
> republished with the diffs from the original publish (sans emails).
> The RB logs show no errors.  Frustratingly, this was working until a
> recent power outage had us restart all our servers... and that really
> makes no sense.
> I'm at a loss at this point.  I'm not sure what to try next or where
> to look.  Anyone have any ideas?
> We're on RB 1.5
> Thanks!
> -Ryan

Want to help the Review Board project? Donate today at 
Happy user? Let us know at http://www.reviewboard.org/users/
To unsubscribe from this group, send email to 
For more options, visit this group at 

Reply via email to