Your $PATH variable isn't being set anywhere. Which web server are you
using? You may need to tweak the web server to set an appropriate $PATH
pointing to your standard binary directories.

Christian

-- 
Christian Hammond - chip...@chipx86.com
Review Board - http://www.reviewboard.org
VMware, Inc. - http://www.vmware.com


On Thu, Sep 16, 2010 at 9:12 AM, j4ys0n <j4y...@gmail.com> wrote:

> Hello,
>
> I'm getting an error when trying to run ReviewBoard. I was able to get
> it installed successfully, but it doesn't work when i try to access
> the URL.
>
> I'm not really sure where to go from here, but Googling hasn't yielded
> anything useful yet. Any help is appreciated. Thanks!
>
> Here's the debug info I get:
>
>
> KeyError at /reviewboard.fcgi
> 'PATH'
> Request Method: GET
> Request URL:    http://svn.doremus.com/reviewboard.fcgi
> Django Version: 1.2.3
> Exception Type: KeyError
> Exception Value:
> 'PATH'
> Exception Location:     /System/Library/Frameworks/Python.framework/
> Versions/2.5/lib/python2.5/UserDict.py in __getitem__, line 22
> Python Executable:      /System/Library/Frameworks/Python.framework/
> Versions/2.5/Resources/Python.app/Contents/MacOS/Python
> Python Version: 2.5.1
> Python Path:    ['/usr/local/apache2/htdocs/reviews/conf', '/usr/local/
> apache2/htdocs/reviews/htdocs', '/Library/Python/2.5/site-packages/
> ReviewBoard-1.0.9-py2.5.egg', '/Library/Python/2.5/site-packages/
> python_memcached-1.45-py2.5.egg', '/Library/Python/2.5/site-packages/
> pytz-2010l-py2.5.egg', '/Library/Python/2.5/site-packages/
> flup-1.0.3.dev_20100525-py2.5.egg', '/Library/Python/2.5/site-packages/
> Pygments-1.3.1-py2.5.egg', '/Library/Python/2.5/site-packages/
> Djblets-0.6.4-py2.5.egg', '/Library/Python/2.5/site-packages/
> django_evolution-0.5-py2.5.egg', '/Library/Python/2.5/site-packages/
> Django-1.2.3-py2.5.egg', '/Library/Python/2.5/site-packages/
> setuptools-0.6c12dev_r84273-py2.5.egg', '/Library/Python/2.5/site-
> packages/PIL-1.1.6-py2.5-macosx-10.5-i386.egg', '/System/Library/
> Frameworks/Python.framework/Versions/2.5/lib/python25.zip', '/System/
> Library/Frameworks/Python.framework/Versions/2.5/lib/python2.5', '/
> System/Library/Frameworks/Python.framework/Versions/2.5/lib/python2.5/
> plat-darwin', '/System/Library/Frameworks/Python.framework/Versions/
> 2.5/lib/python2.5/plat-mac', '/System/Library/Frameworks/
> Python.framework/Versions/2.5/lib/python2.5/plat-mac/lib-
> scriptpackages', '/System/Library/Frameworks/Python.framework/Versions/
> 2.5/Extras/lib/python', '/System/Library/Frameworks/Python.framework/
> Versions/2.5/lib/python2.5/lib-tk', '/System/Library/Frameworks/
> Python.framework/Versions/2.5/lib/python2.5/lib-dynload', '/Library/
> Python/2.5/site-packages', '/System/Library/Frameworks/
> Python.framework/Versions/2.5/Extras/lib/python/PyObjC']
>
> --
> Want to help the Review Board project? Donate today at
> http://www.reviewboard.org/donate/
> Happy user? Let us know at http://www.reviewboard.org/users/
> -~----------~----~----~----~------~----~------~--~---
> To unsubscribe from this group, send email to
> reviewboard+unsubscr...@googlegroups.com<reviewboard%2bunsubscr...@googlegroups.com>
> For more options, visit this group at
> http://groups.google.com/group/reviewboard?hl=en

-- 
Want to help the Review Board project? Donate today at 
http://www.reviewboard.org/donate/
Happy user? Let us know at http://www.reviewboard.org/users/
-~----------~----~----~----~------~----~------~--~---
To unsubscribe from this group, send email to 
reviewboard+unsubscr...@googlegroups.com
For more options, visit this group at 
http://groups.google.com/group/reviewboard?hl=en

Reply via email to