Hey everyone,

I'm trying to get ReviewBoard set up.  Installing the server was no
problem, however I've been having issues with post-review and
perforce.  I have two problems, the first is clearly a permission
problem, but I can't seem to find where the python files live to
change them.  I'm not super familiar with Python so excuse my

I'm on OS X and running an older (server 2005.2) version of perforce.

The first error is:
post-review -d
>>> svn info
>>> git rev-parse --git-dir
>>> hg root
>>> p4 info
Traceback (most recent call last):
  File "/usr/local/bin/post-review", line 8, in <module>
    load_entry_point('RBTools==0.2', 'console_scripts', 'post-review')
  File "build/bdist.linux-x86_64/egg/rbtools/postreview.py", line
2809, in main
  File "build/bdist.linux-x86_64/egg/rbtools/postreview.py", line
2759, in determine_client
  File "build/bdist.linux-x86_64/egg/rbtools/postreview.py", line
1409, in get_repository_info
AttributeError: 'NoneType' object has no attribute 'group'

When running as root this changes to the following:
sudo post-review -d
>>> svn info
>>> git rev-parse --git-dir
>>> hg root
>>> p4 info
The current directory does not contain a checkout from a
supported source code repository.

The p4 command line tool is on my path and runs without issue alone.
Any and all pointers are appreciated.  Or if there's a better place
for me to ask this, please let me know.  I've tried digging through
the docs and didn't see anything that might solve the issues.  Clearly
running the tool as root isn't ideal, but isn't a dealbreaker either.
Thanks in advance!


Want to help the Review Board project? Donate today at 
Happy user? Let us know at http://www.reviewboard.org/users/
To unsubscribe from this group, send email to 
For more options, visit this group at 

Reply via email to