I cannot find the way to get post-review to work with a private GitHub
repository. Can you please give me a hand? This is driving me crazy,
specially after spending days migrating to Git pretty much to use
Review Board. :)

I have successfully configured the repository on the Web interface and
I have a local mirror of that repository, which I had to create just
to be able to run post-review (it errors out if I call it from another
directory); both repositories are registered in Review Board (i.e.,
"g...@github.com:us/project.git" and "/srv/mirror/project").

I'm trying to generate a review for all the changes that happened in a
feature branch, which was started from "master". This is how I run it:
$ cd /srv/mirror/project
$ post-review --server=http://example.org/reviews/ --guess-summary --
guess-description --username=foo --password=bar --submit-as=baz --

But I get the following:
>>> Uploading diff, size: 648218
>>> HTTP POSTing to 
>>> http://example.org/reviews/api/json/reviewrequests/57/diff/new/: {}
>>> Got API Error 207 (HTTP code 200): The file was not found in the repository
>>> Error data: {'deprecated': {'in_version': '1.5'}, 'stat': 'fail', 'file': 
>>> '.bzrignore', 'err': {'msg': 'The file was not found in the repository', 
>>> 'code': 207}, 'revision': 'e4537c290c47cd2946318c6e02f2edb6d7a732b7'}

Error uploading diff

Your review request still exists, but the diff is not attached.

If I add the "--output-diff", I get the diff and seems OK.

I think the fact that it fails with the file ".bzrignore" is a
coincidence and is nothing to do with the migration from our previous
VCS. I get the same error even after removing it from "master" and the
feature branch.

I'm using Review Board 1.5 RC2 and RBTools 0.2.

Can you please help me out?

Thanks in advance,

 - Gustavo.

Want to help the Review Board project? Donate today at 
Happy user? Let us know at http://www.reviewboard.org/users/
To unsubscribe from this group, send email to 
For more options, visit this group at 

Reply via email to