The carriage returns in the settings fields of django_project_version
were indeed the problem. I converted all cr/lf pairs to lf and the
upgrade worked perfectly.

Thanks for the help.

On Oct 1, 4:52 pm, D Krueger <> wrote:
> I've tracked down the source of the problem, but I don't know of a
> solution (if there is one).
> I invoked rb-site on the test site we created when first testing
> 1.0.5.
> It worked perfectly.
> So I started using pdb to investigate where rb-site was failing on our
> standard site, which led me to:
>   django_evolution/management/>None ->
>   old_proj_sig = pickle.loads(str(latest_version.signature))
> Then I investigated the differences in the signature values in
> django_project_version for the working and non-working
> installations. The non-working one had ^M after every line because it
> had been migrated from a Windows server.
> My suspicion is that the signature pickled by the Windows server isn't
> compatible with the Linux server. Is that a possbility?
> I'm at a loss as to how to proceed. Any help would be much appreciated
> (as is the help already given).

Want to help the Review Board project? Donate today at
Happy user? Let us know at
To unsubscribe from this group, send email to
For more options, visit this group at

Reply via email to